在线检测未来函数

同花顺出击量柱指标公式

来源:Internet,编辑:股旁网,2017-09-05

HPLZ1:=V/REF(V,1)>=0.95 AND V/REF(V,1)<=1.05;
HLZ2:=REF(HHV(V,2),1);
HPLZ2:=V/HLZ2>=0.95 AND V/HLZ2<=1.05;
HLZ3:=REF(HHV(V,3),1);
HPLZ3:=V/HLZ3>=0.95 AND V/HLZ3<=1.05;
HLZ4:=REF(HHV(V,4),1);
HPLZ4:=V/HLZ4>=0.95 AND V/HLZ4<=1.05;
HLZ5:=REF(HHV(V,5),1);
HPLZ5:=V/HLZ5>=0.95 AND V/HLZ5<=1.05;
HLZ6:=REF(HHV(V,6),1);
HPLZ6:=V/HLZ6>=0.95 AND V/HLZ6<=1.05;
HLZ7:=REF(HHV(V,7),1);
HPLZ7:=V/HLZ7>=0.95 AND V/HLZ7<=1.05;
HLZ8:=REF(HHV(V,8),1);
HPLZ8:=V/HLZ8>=0.95 AND V/HLZ8<=1.05;
HLZ9:=REF(HHV(V,9),1);
HPLZ9:=V/HLZ9>=0.95 AND V/HLZ9<=1.05;
HLZ10:=REF(HHV(V,10),1);
HPLZ10:=V/HLZ10>=0.95 AND V/HLZ10<=1.05;
HLZ11:=REF(HHV(V,11),1);
HPLZ11:=V/HLZ11>=0.95 AND V/HLZ11<=1.05;
HLZ12:=REF(HHV(V,12),1);
HPLZ12:=V/HLZ12>=0.95 AND V/HLZ12<=1.05;
HLZ13:=REF(HHV(V,13),1);
HPLZ13:=V/HLZ13>=0.95 AND V/HLZ13<=1.05;
PLZ:=HPLZ13 OR HPLZ12 OR HPLZ11 OR HPLZ10 OR HPLZ9 OR HPLZ8 OR HPLZ7 OR HPLZ6 OR HPLZ5 OR HPLZ4 OR HPLZ3 OR HPLZ2 OR HPLZ1;
N:=100;
DDL:=100*(V-LLV(V,N))/(HHV(V,N)-LLV(V,N));
M:=13;
DL:=100*(V-LLV(V,M))/(HHV(V,M)-LLV(V,M));
倍量:V>=REF(V,1)*1.9,coloryellow;
倍缩:V<=REF(V,1)*0.55,colorred;
STICKLINE(C>O,0,V,8,1),colorred;
STICKLINE(C<=O,0,V,8,0),colorcyan;
STICKLINE(倍量,0,V,8,0),coloryellow;
STICKLINE(倍缩,0,V,8,0),colorred;
IF (MARKETTYPE == 16 OR MARKETTYPE == 32 OR MARKETTYPE == 48)
总手:VOL;
ELSE
总量:VOL;
diff:=EMA(C,12)-EMA(C,26);
dea:=EMA(diff,9);
第一红柱:CROSS(diff,dea),colorred,LINETHICK2;
VAR1:=SMA(AMOUNT/10,10,1)/10000;
VAR2:=REF(VAR1,1);
VAR1=HHV(VAR1,20);
多转空:=((((LLV(MACD,4)>0) AND (MACD<REF(MACD,1))) AND (REF(MACD,1)>REF(MACD,2))) AND (REF(MACD,2)>REF(MACD,3)));
空转多:=((((HHV(MACD,4)<0) AND (MACD>REF(MACD,1))) AND (REF(MACD,1)<REF(MACD,2))) AND (REF(MACD,2)<REF(MACD,3)));
DRAWICON(多转空,MACD,2);
DRAWICON(空转多,MACD,1);
LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
阶段底部:=(AV + NEWVOL);
出击:CROSS(阶段底部,0);
DIF3:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA3:=EMA(DIF3,9);
MACD3 := 2*(DIF3-DEA3);
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
止跌:MACD3>REF(MACD3,1) AND REF(MACD3,2)>=REF(MACD3,1) AND J<50 AND C>REF(C,1) AND C>O AND J>REF(J,1);

同花顺出击量柱指标公式

 

相关文章