在线检测未来函数

通达信量异指标公式

来源:Internet,编辑:股旁网,2017-09-07

N:=21; M:=5;
天:400,POINTDOT,COLORBLUE,LINETHICK4;
海:100,POINTDOT,COLORRED,LINETHICK4;
TH:=SUM(IF(CLOSE>REF(CLOSE,1),VOL,0),N);
TL:=SUM(IF(CLOSE<REF(CLOSE,1),VOL,0),N);
TQ:=SUM(IF(CLOSE=REF(CLOSE,1),VOL,0),N);
VAR0:100*(TH*2+TQ)/(TL*2+TQ),COLOR0000FF,LINETHICK2;
VAR1:MA(VAR0,M),COLOR00FFFF,LINETHICK2;
{DRAWBAND(VAR0,RGB(255,0,0),VAR1,RGB(0,0,220));}
W:=CROSS(VAR0,VAR1);
WL1:=VAR1<100;
WL2:=VAR1<150 AND VAR1>REF(VAR1,1);
WLT1:=W AND WL1;
WLT2:=W AND WL2;
TJ1:=FILTER(WLT1,5);
TJ2:=FILTER(WLT2,8);
STICKLINE(TJ1,0,80,4,0),COLOR000099;
STICKLINE(TJ1,0,80,2,0),COLOR0000BB;
STICKLINE(TJ1,0,80,1,0),COLOR0000DD;
STICKLINE(TJ1,0,80,0.3,0),COLOR0000FF;
DRAWTEXT(TJ1,83,'全仓'),COLOR00FFFF;
STICKLINE(TJ2,0,50,4,0),COLOR990099;
STICKLINE(TJ2,0,50,2,0),COLORBB00BB;
STICKLINE(TJ2,0,50,1,0),COLORDD00DD;
STICKLINE(TJ2,0,50,0.3,0),COLORFF00FF;
DRAWTEXT(TJ2,53,'追买'),COLOR00FFFF;
SAL1:CROSS(VAR1,VAR0) AND VAR1>250;
SAL2:VAR0>400;
SAL:FILTER(SAL1 OR SAL2,5);
DRAWICON(SAL,VAR0,15);

通达信量异指标公式

 

相关文章