在线检测未来函数

通达信MACDK线指标公式

来源:Internet,编辑:股旁网,2017-09-07

VAR1:=REF(MA(C,26),10);
开:=O-VAR1;
高:=H-VAR1;
低:=L-VAR1;
收:=C-VAR1;
MID:=MA(C,26);
UPPER:=MID+2*STD(C,26);
LOWER:=MID-2*STD(C,26);
V1:=(C-LOWER)/(UPPER-LOWER)*100;
V2:=V1-EMA(V1,5);
K1:=SUM(LLV(V2,4),4)/4;
V3:=EMA(V2,64)*10;
V4:=EMA(0.4*V2*(-1),3);
V5:=-1*EMA(V2,39)*10;
A:=V3>10;
B:=V2>V4;
D:=V5>10;
E:=V3<=10 OR V2<=V4 OR V5<=10;
STICKLINE(C,0,0,6,0), COLORYELLOW;
STICKLINE(收>=开 AND E,高,低,0,0), COLORRED;
STICKLINE(收>=开 AND E,收,开,8,0) ,COLORRED;
STICKLINE(收< 开 AND E,高,低,0,0) ,COLORGREEN;
STICKLINE(收< 开 AND E,收,开,8,0) ,COLORGREEN;
STICKLINE(开> 收 AND A ,低,高,0,0),COLORFF0000;
STICKLINE(开> 收 AND A ,收,开,8,0),COLORFF0000;
STICKLINE(开<=收 AND A,低,高,0,0),COLORYELLOW;
STICKLINE(开<=收 AND A,收,开,8,1),COLORYELLOW;
STICKLINE(开> 收 AND B,低,高,0,0),COLORRED;
STICKLINE(开> 收 AND B,收,开,8,0),COLORRED;
STICKLINE(开<=收 AND B,低,高,0,0),COLORRED;
STICKLINE(开<=收 AND B,收,开,8,1),COLORRED;
STICKLINE(开> 收 AND D,低,高,0,0),COLORGREEN;
STICKLINE(开> 收 AND D,收,开,8,0),COLORGREEN;
STICKLINE(开<=收 AND D,低,高,0,0),COLORGREEN;
STICKLINE(开<=收 AND D,收,开,8,1),COLORGREEN;
M3:EMA(收,3),COLORWHITE;
M5:EMA(收,5),COLOR00FF00;
{DTTZ底头特准000}
VABR1:=MA(CLOSE,5);
VABR2:=MA(CLOSE,10);
VABR3:=MA(CLOSE,20);
VABR4:=MA(CLOSE,30);
VABR5:=(VABR1+VABR2+VABR3+VABR4)/4;
VABR6:=(VABR5-REF(VABR5,5))/REF(VABR5,5)*1500;
VABR8:=EMA(VABR6,8);
VABR9:=TROUGHBARS(3,15,1)<10;
VABR10:=PEAKBARS(3,15,1)<10;
VABR11:=IF(VABR9=1,50,0);
VABR12:=IF(VABR10=1,50,0);
底部:=IF(VABR11=50,50,0);
头部:=IF(VABR12=50,100,0);
DRAWTEXT(底部>REF(底部,1),0,'底'),COLOR00FF00;
DRAWTEXT(头部>REF(头部,1),0,'顶'),COLORYELLOW;
0,COLORFFA2AF;

通达信MACDK线指标公式

 

相关文章