在线检测未来函数

通达信三一二一买卖主图指标公式

来源:Internet,编辑:股旁网,2017-09-08

N1:=85;
N2:=0;
N3:=40;
N4:=5;
N5:=3;
N6:=1;
N7:=1;
N8:=1;
N9:=1;
周期:CURRBARSCOUNT,NODRAW,COLORGREEN;
X_1:=DATE<=1991111;
X_2:=周期<=N1;
X_3:=N2;
X_4:=N1;
X_5:=N3;
X_6:=N6;
X_7:=N7;
X_8:=N8;
X_9:=周期<=N3;
X_10:=N9;
X_11:=IF(N4=1,0.5,IF(N4=2,1,IF(N4=3,(-1),IF(N4=4,3,4))));
X_12:=3;
X_13:=IF(X_1,IF(X_10,REFX(HHV(MAX(OPEN,CLOSE),X_4),周期-1),REFX(HHV(HIGH,X_4),周期-1)),0);
X_14:=IF(X_10,REFX(LLV(MIN(OPEN,CLOSE),X_4),周期-1),REFX(LLV(LOW,X_4),周期-1));
X_15:=(X_13+X_14)/2;
X_16:=X_13-(X_13-X_14)/3;
X_17:=X_14+(X_13-X_14)/3;
X_18:=IF(X_1,IF(X_10,REFX(HHV(MAX(OPEN,CLOSE),X_5),周期-1),REFX(HHV(HIGH,X_5),周期-1)),0);
X_19:=IF(X_10,REFX(LLV(MIN(OPEN,CLOSE),X_5),周期-1),REFX(LLV(LOW,X_5),周期-1));
X_20:=(X_18+X_19)/2;
X_21:=X_18-(X_18-X_19)/3;
X_22:=X_19+(X_18-X_19)/3;
X_23:=(-1);
X_24:=0;
X_25:=1;
X_26:=IF(X_10,REFX(BARSLAST(MAX(OPEN,CLOSE)=X_13),周期-1)+1,REFX(BARSLAST(HIGH=X_13),周期-1)+1);
X_27:=IF(X_10,REFX(BARSLAST(MAX(OPEN,CLOSE)=X_18),周期-1)+1,REFX(BARSLAST(HIGH=X_18),周期-1)+1);
X_28:=周期=X_26;
X_29:=周期=X_27;
STICKLINE(X_28,LOW,X_14,X_23,X_25),COLORLIGREEN;
STICKLINE(X_29,LOW,X_19,X_23,X_25),COLORLIGREEN;
DRAWTEXT(X_28 OR X_29 AND X_8,X_14,VAR2STR(周期,0)),COLORGREEN,LINETHICK9;
X_30:=周期<=X_26;
X_31:=周期<=X_27;
STICKLINE(X_30,X_13,X_13,X_11,X_24),COLORLIGREEN;
STICKLINE(X_30,X_14,X_14,X_11,X_24),COLORLIGREEN;
STICKLINE(X_30,X_15,X_15,X_11,X_24),COLORRED;
STICKLINE(X_30,X_16,X_16,X_11,X_24),COLORLIGREEN;
STICKLINE(X_30,X_17,X_17,X_11,X_24),COLORLIGREEN;
STICKLINE(X_31,X_18,X_18,X_12,X_24),COLORLIRED;
STICKLINE(X_31,X_19,X_19,X_12,X_24),COLORLIRED;
STICKLINE(X_31,X_20,X_20,X_12,X_24),COLORRED;
STICKLINE(X_31,X_21,X_21,X_12,X_24),COLORLIRED;
STICKLINE(X_31,X_22,X_22,X_12,X_24),COLORLIRED;
X_32:=ISLASTBAR AND X_6;
DRAWTEXT(X_32,X_13,VAR2STR(X_13,2)),COLORGREEN;
DRAWTEXT(X_32,X_14,VAR2STR(X_14,2)),COLORGREEN;
DRAWTEXT(X_32,X_15,VAR2STR(X_15,2)),COLORYELLOW;
DRAWTEXT(X_32,X_16,VAR2STR(X_16,2)),COLORGREEN;
DRAWTEXT(X_32,X_17,VAR2STR(X_17,2)),COLORGREEN;

通达信三一二一买卖主图指标公式

 

相关文章