在线检测未来函数

向上跳空缺口不回补的选股公式

来源:Internet,编辑:股旁网,2017-09-04

编写要求:

120天内有向上跳空第一个缺口且不回补的选股公式。要求120天内存在这样缺口的股都能选股来,第二个第二个缺口可以忽略不计。

股旁网解答:

GK:=L>(REF(H,1));
T:=BARSLAST(GK);
T1:=SUMBARS(T=0,2);
T2:=SUMBARS(T=0,3);
T3:=SUMBARS(T=0,4);
T4:=SUMBARS(T=0,5);
T5:=SUMBARS(T=0,6);
T6:=SUMBARS(T=0,7);
A1:=LLV(L,T+1)>REF(H,T+1) AND T<120;
A2:=LLV(L,T1)>REF(H,T1) AND T1<120;
A3:=LLV(L,T2)>REF(H,T2) AND T2<120;
A4:=LLV(L,T3)>REF(H,T3) AND T3<120;
A5:=LLV(L,T4)>REF(H,T4) AND T4<120;
A6:=LLV(L,T5)>REF(H,T5) AND T5<120;
A7:=LLV(L,T6)>REF(H,T6) AND T6<120;
XG:=A1 OR A2 OR A3 OR A4 OR A5 OR A6 OR A7;
DRAWICON(XG,L,1);

相关文章