在线检测未来函数

通达信K线把脉师主图指标公式

来源:Internet,编辑:股旁网,2017-10-03

{使用说明:K线把脉师可以自动辨别早晨之星、黄昏之星、长十字、垂死十字、早晨十字星、黄昏十字星、射击之星、倒转锤头、锤头线、吊颈线、穿头破脚、乌云盖顶、曙光初现、身怀六甲、十字胎、平顶、平底、大阳烛、三个白武士、双飞乌鸦、孕育线、多方炮、出水芙蓉、上升

M1:=5;
M2:=10;
M3:=20;
M4:=60;
MA1:MA(CLOSE,M1);
MA2:MA(CLOSE,M2);
MA3:MA(CLOSE,M3);
MA4:MA(CLOSE,M4);
BM:=EMA(C,2);
SM:=EMA(SLOPE(C,21)*22+C,42);
BU:=CROSS(BM,SM);
SEL:=CROSS(SM,BM);
STICKLINE(BM>=SM,LOW,HIGH,0,1),COLORRED;
STICKLINE(BM>=SM,CLOSE,OPEN,2,1),COLORRED;
STICKLINE(BM<SM,LOW,HIGH,0,1),COLORCYAN;
STICKLINE(BM<SM,CLOSE,OPEN,2,1),COLORCYAN;
STICKLINE(C/REF(C,1)>=1.096 AND H=C,O,C,1,0),COLORYELLOW;
TT:=240/FROMOPEN;
比:=TT;
J12:=(HIGH-((HIGH-LOW)/3));
J23:=(LOW+((HIGH-LOW)/3));
T1{早晨之星}:=CONST(IF((REF(CLOSE,2)/REF(OPEN,2)<0.95 AND REF(OPEN,1)
< REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.03 AND
CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2)),1,0));
T2{黄昏之星}:=CONST(IF((REF(CLOSE,2)/REF(OPEN,2)>1.03 AND REF(OPEN,1)
> REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.02
AND CLOSE/OPEN<0.97 AND CLOSE<REF(CLOSE,2)),1,0));
T3{长十字}:=CONST(IF((CLOSE=OPEN AND HIGH/LOW >1.03),1,0));
T4{垂死十字}:=CONST(IF((CLOSE=OPEN AND CLOSE=LOW AND CLOSE!=HIGH),1,0));
T5{早晨十字星}:=CONST(IF((REF(CLOSE,2)/REF(OPEN,2)<0.95 AND REF(OPEN,1)
< REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) AND
CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2)),1,0));
T6{黄昏十字星}:=CONST(IF((REF(CLOSE,2)/REF(OPEN,2)>1.05 AND REF(OPEN,1)
> REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) AND
CLOSE/OPEN<0.95 AND CLOSE<REF(CLOSE,2)),1,0));
T7{射击之星}:=CONST(IF((MIN(OPEN,CLOSE)=LOW AND HIGH-LOW >
3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE > MA(CLOSE,5)),1,0));
T8{倒转锤头}:=CONST(IF((MIN(OPEN,CLOSE)=LOW AND HIGH-LOW >
3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE < MA(CLOSE,5)),1,0));
T9{锤头}:=CONST(IF((HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW >
3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE < MA(CLOSE,5)),1,0));
T10{吊颈}:=CONST(IF((HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW >
3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE>MA(CLOSE,5)),1,0));
T11{穿头破脚}:=CONST(IF(((REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.96 AND CLOSE<REF(OPEN,1)
AND OPEN>REF(CLOSE,1))OR (REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.04
AND CLOSE>REF(OPEN,1) AND OPEN<REF(CLOSE,1))),1,0));
T12{乌云盖顶}:=CONST(IF((REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.97
AND OPEN>REF(CLOSE,1) AND CLOSE<REF(CLOSE,1)),1,0));
T13{曙光初现}:=CONST(IF((REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.03
AND OPEN<REF(CLOSE,1) AND CLOSE>REF(CLOSE,1)),1,0));
T14{身怀六甲}:=CONST(IF((ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1)>0.04 AND ABS(CLOSE-OPEN)/CLOSE<0.005 AND
MAX(CLOSE,OPEN) < MAX(REF(CLOSE,1),REF(OPEN,1)) AND MIN(CLOSE,OPEN)
> MIN(REF(CLOSE,1),REF(OPEN,1))),1,0));
T15{十字胎}:=CONST(IF((ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1)>0.04 AND CLOSE=OPEN AND
CLOSE < MAX(REF(CLOSE,1),REF(OPEN,1)) AND CLOSE > MIN(REF(CLOSE,1)
,REF(OPEN,1))),1,0));
T16{平顶}:=CONST(IF((ABS(HIGH-REF(HIGH,1))/HIGH<0.001),1,0));
T17{平底}:=CONST(IF(((ABS(LOW-REF(LOW,1))/LOW<0.001 AND ABS(REF(LOW,1)
-REF(LOW,2))/REF(LOW,1)<=0.001)),1,0));
T18{大阳烛}:=CONST(IF((CLOSE/OPEN>1.05 AND HIGH/LOW < CLOSE/OPEN+0.018),1,0));
T19{三个白武士}:=CONST(IF((REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)>REF(OPEN,1) AND CLOSE>OPEN
AND REF(CLOSE,1)>REF(CLOSE,2) AND CLOSE>REF(CLOSE,1)),1,0));
T20{双飞乌鸦}:=CONST(IF((REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN AND CLOSE/OPEN<0.98),1,0));
T21{孕育线}:=CONST(IF((REF(CLOSE,2)>REF(OPEN,2) AND (REF(CLOSE,2)
-REF(OPEN,2))/REF(OPEN,2)>=2/100 AND REF(OPEN,1)>=REF(CLOSE,1)
AND (REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<=2/100 AND REF(OPEN,1)
<=REF(CLOSE,2) AND REF(CLOSE,1)>=REF(OPEN,2) AND C>=OPEN
AND (CLOSE-OPEN)/OPEN>=2/100 AND CLOSE>=REF(OPEN,1) AND OPEN<=REF(CLOSE,1)
AND (MAX(CLOSE,REF(C,2))-MIN(CLOSE,REF(CLOSE,2)))/MIN(CLOSE,REF(CLOSE,2))<=1/100),1,0));
T22{多方炮}:=CONST(IF((REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>OPEN),1,0));
T23{出水芙蓉}:=CONST(IF(((OPEN<EMA(C,20) OR OPEN<EMA(C,40) OR OPEN<
EMA(C,60)) AND (C>MAX(EMA(C,20),MAX(EMA(C,40),EMA(C,60))))AND (V/MA(V,30)>1.2 AND C/REF(C,1)>1.049)),1,0));
T24{上升三部曲}:=CONST(IF((REF(CLOSE,4)/REF(OPEN,4)>1.03 AND REF(CLOSE,3)
<REF(OPEN,3) AND REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1)
AND REF(LOW,4)<REF(LOW,3) AND REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)
<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2)
AND REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN>1.03 AND CLOSE>REF(CLOSE,4)),1,0));
T25{下跌三部曲}:=CONST(IF(( REF(CLOSE,4)/REF(OPEN,4)<0.97 AND REF(CLOSE,3)
>REF(OPEN,3) AND REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)>REF(OPEN,1)
AND REF(LOW,4)<REF(LOW,3) AND REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)
<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) AND REF(HIGH,4)>REF(HIGH,1)
AND CLOSE/OPEN<0.97 AND CLOSE<REF(CLOSE,4)),1,0));
T26{跳空缺口}:=CONST(IF(HIGH<REF(LOW,1) OR LOW>REF(HIGH,1),1,0));
T27{三只乌鸦}:=CONST(IF((REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)
<REF(OPEN,1) AND CLOSE<OPEN AND REF(CLOSE,1)<REF(CLOSE,2)
AND CLOSE<REF(CLOSE,1)),1,0));
T28{光脚阴线}:=CONST(IF((LOW=CLOSE AND HIGH!=LOW),1,0));
T29{光头阳线}:=CONST(IF((HIGH=CLOSE AND HIGH!=LOW),1,0));
T30{分离}:=CONST(IF((OPEN=REF(OPEN,1) AND (CLOSE-OPEN)*(REF(CLOSE,1)-REF(OPEN,1))<0),1,0));
T31{长下影}:=CONST(IF(((MIN(CLOSE,OPEN)-LOW)/(HIGH-LOW)>0.667),1,0));
T32{长上影}:=CONST(IF(((HIGH-MAX(CLOSE,OPEN))/(HIGH-LOW)>0.667),1,0));
T33{十字星}:=CONST(IF((CLOSE=OPEN AND HIGH!=LOW),1,0));
T34{大阴烛}:=CONST(IF((OPEN/CLOSE>1.05 AND HIGH/LOW<OPEN/CLOSE+0.018),1,0));
T35{好友反攻}:=CONST(IF(((REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>OPEN
AND ABS(CLOSE-REF(CLOSE,1))/CLOSE<0.002) OR (REF(CLOSE,1)>REF(OPEN,1)
AND CLOSE<OPEN AND ABS(CLOSE-REF(CLOSE,1))
/CLOSE<0.002)),1,0));
T36{倾盆大雨}:=CONST(IF((REF(C,1)/REF(O,1)>=1.03 AND O<REF(C,1) AND O>REF(O,1) AND C<REF(O,1)),1,0));
T37:=CONST(V*比>REF(V,1) AND MA(V,5)>REF(MA(V,5),1));
T38:=CONST(V*比<REF(V,1) AND MA(V,5)>REF(MA(V,5),1));
T39:=CONST(V*比>REF(V,1) AND MA(V,5)<REF(MA(V,5),1));
T40:=CONST(V*比<REF(V,1) AND MA(V,5)<REF(MA(V,5),1));
T41:=CONST((((IF((CLOSE=OPEN),1,0)+IF((CLOSE >=J12),1,0))+IF((CLOSE<=J23),1,0))>1));
T42:=CONST((((AMOUNT/VOL)/100)>REF(HIGH,1)));
T43:=CONST((((AMOUNT/VOL)/100)<REF(LOW,1)));
TS1:=IF(T1=1,0.02+0.02,0.02),NODRAW;
TS2:=IF(T2=1,TS1+0.05,TS1),NODRAW;
TS3:=IF(T3=1,TS2+0.05,TS2),NODRAW;
TS4:=IF(T4=1,TS3+0.05,TS3);
TS5:=IF(T5=1,TS4+0.05,TS4);
TS6:=IF(T6=1,TS5+0.05,TS5);
TS7:=IF(T7=1,TS6+0.05,TS6);
TS8:=IF(T8=1,TS7+0.05,TS7);
TS9:=IF(T9=1,TS8+0.05,TS8);
TS10:=IF(T10=1,TS9+0.05,TS9),NODRAW;
TS11:=IF(T11=1,TS10+0.05,TS10);
TS12:=IF(T12=1,TS11+0.05,TS11);
TS13:=IF(T13=1,TS12+0.05,TS12);
TS14:=IF(T14=1,TS13+0.05,TS13);
TS15:=IF(T15=1,TS14+0.05,TS14);
TS16:=IF(T16=1,TS15+0.05,TS15);
TS17:=IF(T17=1,TS16+0.05,TS16);
TS18:=IF(T18=1,TS17+0.05,TS17);
TS19:=IF(T19=1,TS18+0.05,TS18);
TS20:=IF(T20=1,TS19+0.05,TS19);
TS21:=IF(T21=1,TS20+0.05,TS20);
TS22:=IF(T22=1,TS21+0.05,TS21);
TS23:=IF(T23=1,TS22+0.05,TS22);
TS24:=IF(T24=1,TS23+0.05,TS23);
TS25:=IF(T25=1,TS24+0.05,TS24);
TS26:=IF(T26=1,TS25+0.05,TS25);
TS27:=IF(T27=1,TS26+0.05,TS26);
TS28:=IF(T28=1,TS27+0.05,TS27);
TS29:=IF(T29=1,TS28+0.05,TS28);
TS30:=IF(T30=1,TS29+0.05,TS29);
TS31:=IF(T31=1,TS30+0.05,TS30);
TS32:=IF(T32=1,TS31+0.05,TS31);
TS33:=IF(T33=1,TS32+0.05,TS32);
TS34:=IF(T34=1,TS33+0.05,TS33);
TS35:=IF(T35=1,TS34+0.05,TS34);
TS36:=IF(T36=1,TS35+0.05,TS35);
TS37:=IF(T37=1,TS36+0.05,TS36);
TS38:=IF(T38=1,TS37+0.05,TS37);
TS39:=IF(T39=1,TS38+0.05,TS38);
TS40:=IF(T40=1,TS39+0.05,TS39);
TS41:=IF(T41=1,TS36+0.05,TS36);
TS42:=IF(T42=1,TS41+0.05,TS41);
TS43:=IF(T43=1,TS42+0.05,TS42);
DRAWTEXT_FIX(T1=1,0,TS1,0,'早晨之星:见底回升'),COLORFF00FF;
DRAWTEXT_FIX(T2=1,0,TS2,0,'黄昏之星:见顶回落'),COLORFFFF00;
DRAWTEXT_FIX(T3=1,0,TS3,0,'长十字:重要的警告信号,原趋势停顿或反转'),COLORGREEN;
DRAWTEXT_FIX(T4=1,0,TS4,0,'垂死十字:下跌信号'),COLORFFFF00;
DRAWTEXT_FIX(T5=1,0,TS5,0,'早晨十字星:上涨信号,见底回升'),COLORFF00FF;
DRAWTEXT_FIX(T6=1,0,TS6,0,'黄昏十字星:趋势停顿或反转,下跌或,见顶回落'),COLORFFFF00;
DRAWTEXT_FIX(T7=1,0,TS7,0,'射击之星:,市场顶部就在眼前,可能见顶回落,但可靠性较低'),COLORFFFF00;
DRAWTEXT_FIX(T8=1,0,TS8,0,'倒转锤头构成一个看涨信号,可能见底回升'),COLORFF00FF;
DRAWTEXT_FIX(T9=1,0,TS9,0,'锤头线:可能见底回升,如有量配合,信号强烈'),COLOR0000FF;
DRAWTEXT_FIX(T10=1,0,TS10,0,'吊颈线:上升行情中见顶回落,顶部出现,见顶信号'),COLORFFFF00;
DRAWTEXT_FIX(T11=1,0,TS11,0,'穿头破脚:顶部出现,见顶回落信号'),COLORFFFF00;
DRAWTEXT_FIX(T12=1,0,TS12,0,'乌云盖顶:见顶回落信号'),COLORFFFF00;
DRAWTEXT_FIX(T13=1,0,TS13,0,'曙光初现:将演化为V型反转或横盘。后市见底回升'),COLORFF00FF;
DRAWTEXT_FIX(T14=1,0,TS14,0,'身怀六甲:底部,是见底回升,顶部,是见顶回落信号'),COLORGREEN;
DRAWTEXT_FIX(T15=1,0,TS15,0,'十字胎:上升趋势看跌,下跌趋势看涨'),COLORGREEN;
DRAWTEXT_FIX(T16=1,0,TS16,0,'平顶线:行情见顶,股价将反转,但下跌力度较小'),COLORFFFFFF;
DRAWTEXT_FIX(T17=1,0,TS17,0,'平底线:行情探低见底,股价行将反转上升,但力度较小'),COLORFFFFFF;
DRAWTEXT_FIX(T18=1,0,TS18,0,'大阳烛:上升中,剧烈地向上攀升。下行中,剧烈地向上反弹'),COLOR0000FF;
DRAWTEXT_FIX(T19=1,0,TS19,0,'三个白武士:每日收盘价上移,表示可能见底回升'),COLORFFFFFF;
DRAWTEXT_FIX(T20=1,0,TS20,0,'双飞乌鸦:行情开始疲软将见顶回落'),COLORFF0000;
DRAWTEXT_FIX(T21=1,0,TS21,0,'孕育线:下跌行情是反弹信号,下跌中是反弹信号,上涨中预示行情已经完结'),COLOR00FFFF;
DRAWTEXT_FIX(T22=1,0,TS22,0,'多方炮:底部可能上涨,中间上涨中继,顶部见顶信号'),COLORGREEN;
DRAWTEXT_FIX(T23=1,0,TS23,0,'出水芙蓉:阳线穿过20、40、60日均线,上攻势头初现'),COLORFF00FF;
DRAWTEXT_FIX(T24=1,0,TS24,0,'上升三部曲:上涨信号'),COLORFF00FF;
DRAWTEXT_FIX(T25=1,0,TS25,0,'下跌三部曲:下跌信号'),COLORFFFF00;
DRAWTEXT_FIX(T26=1,0,TS26,0,'跳空缺口:突破盘整,上涨或下跌开始信号'),COLORGREEN;
DRAWTEXT_FIX(T27=1,0,TS27,0,'三只乌鸦站枝头,可能见顶回落'),COLORFFFF00;
DRAWTEXT_FIX(T28=1,0,TS28,0,'光脚阴线:下跌信号'),COLORFFFF00;
DRAWTEXT_FIX(T29=1,0,TS29,0,'光头阳线:多方积极上攻态势,后市看涨'),COLOR0000FF;
DRAWTEXT_FIX(T30=1,0,TS30,0,'分离线:注意看涨分离和看跌分离'),COLORGREEN;
DRAWTEXT_FIX(T31=1,0,TS31,0,'长下影:有可能止跌回升,升势末期,须小心'),COLORGREEN;
DRAWTEXT_FIX(T32=1,0,TS32,0,'长上影:表明行情上档压力沉重,升势受阻'),COLORFFFF00;
DRAWTEXT_FIX(T33=1,0,TS33,0,'十字星:重要的警告信号,原趋势停顿或反转'),COLORGREEN;
DRAWTEXT_FIX(T34=1,0,TS34,0,'大阴烛:后市向淡,发生逆转'),COLORFF0000;
DRAWTEXT_FIX(T35=1,0,TS35,0,'好友反攻:跌势已尽,要展开一段反弹行情'),COLORFF00FF;
DRAWTEXT_FIX(T36=1,0,TS36,0,'倾盆大雨:见顶信号'),COLORFFFF00;
DRAWTEXT_FIX(T41=1,0,TS41,0,'极端行情,在未来的几日内有85%的机会变更方向'),COLORWHITE;

通达信K线把脉师主图指标公式

 

相关文章