在线检测未来函数

通达信一百万买卖点指标公式

来源:Internet,编辑:股旁网,2017-10-09

MA3: MA(CLOSE,3),COLORYELLOW;
箱顶: HHV(MA((LOW+HIGH+CLOSE+OPEN)/4,5),58),COLOR00AAFF;
箱底: LLV(MA((LOW+HIGH+CLOSE+OPEN)/4,6),58),COLOR00FF00;
VAR1:=EMA((HIGH+LOW+CLOSE)/3*(HHV(HIGH,10)-CLOSE)/(HHV(HIGH,10)-LLV(LOW,10))*20/10+箱底,2);
VAR2:=(3*VAR1-2*SMA(VAR1,5,1))*0.3;
VAR3:=(HHV(INDEXH,13)-INDEXC)/(HHV(INDEXH,13)-LLV(INDEXL,13));
VAR4:=EMA(3*VAR3-2*SMA(VAR3,18,1),5);
VAR5:=(INDEXC-LLV(INDEXL,8))/(HHV(INDEXH,8)-LLV(INDEXL,8));
VAR6:=3*SMA(VAR5,3,1)-2*SMA(SMA(VAR5,3,1),5,1);
VAR7:=(INDEXC*2+INDEXH+INDEXL)/4;
VAR8:=EMA(VAR7,13)-EMA(VAR7,34);
VAR9:=EMA(VAR8,5);
VARA:=(VAR8-VAR9+箱底)*1;
VARB:=1.86*EMA(CLOSE,12)-EMA(CLOSE,34);
趋势力度: VARB,COLORFFAA99;
VARC:=箱底;
STICKLINE(C>=O,C,O,3,0),COLORRED;
STICKLINE(C>=O,C,O,2,0),COLOR7070FF;
STICKLINE(C>=O,C,O,1,0),COLORYELLOW;
STICKLINE(C>=O,H,L,0,0),COLORYELLOW;
STICKLINE(C<=O,C,O,3,0),COLORFF2020;
STICKLINE(C<=O,C,O,2,0),COLORFF6600;
STICKLINE(C<=O,C,O,1,0),COLORFFCC66;
STICKLINE(C<=O,H,L,0,0),COLORFFCC66;
牛气冲天: STICKLINE(趋势力度>=VARC,VARC,趋势力度,2,0),COLORRED;
STICKLINE(趋势力度<=REF(趋势力度,1) AND 趋势力度>VARC,VARC,趋势力度,2,1),COLORWHITE;
趁机派发: STICKLINE(REF(趋势力度,2)<REF(趋势力度,1) AND 趋势力度<=REF(趋势力度,1) AND 趋势力度>VARC,VARC,趋势力度,2,0),COLORGREEN;
DRAWICON(REF(趋势力度,2)<REF(趋势力度,1) AND 趋势力度<=REF(趋势力度,1) AND 趋势力度>VARC,趋势力度,2);
熊气盖天: STICKLINE(趋势力度<VARC-0.5,VARC-0.5,趋势力度,2,1),COLORYELLOW;
转强信号:STICKLINE(趋势力度>REF(趋势力度,1) AND 趋势力度<VARC-0.5,VARC-0.5,趋势力度,2,0),COLORRED;
MA34: MA(CLOSE,34),COLORWHITE;
DRAWTEXT(CROSS(MA3,箱底),LOW*0.95,'试'),COLORFFCC66;
STICKLINE(CROSS(MA3,箱底),LOW*0.99,L*0.95,2,0),COLORFFCC66;
DRAWTEXT(CROSS(MA3,MA34),LOW*0.95,'买'),COLORFF00FF;
STICKLINE(CROSS(MA3,MA34),LOW*0.990,L*0.97,2,0),COLORFF00FF;
DRAWTEXT(CROSS(MA3,箱顶) AND CLOSE>箱顶,箱顶*0.95,'追'),COLORRED;
STICKLINE(CROSS(MA3,箱顶) AND CLOSE>箱顶,箱顶*0.99,箱顶*0.97,2,0),COLORYELLOW;
DRAWTEXT(CROSS(箱顶,MA3) AND CLOSE<箱顶,HIGH*1.05,'卖'),COLOR00FF00;
STICKLINE(CROSS(箱顶,MA3) AND CLOSE<箱顶,HIGH*1.03,H*1.0,1,0),COLOR00FF00;
DRAWTEXT(REF(VARA,2)<REF(VARA,1) AND REF(VARA,1)>VARA AND VARA>箱顶 AND CLOSE>箱顶,HIGH*1.05,'顶'),COLORWHITE;
STICKLINE(REF(VARA,2)<REF(VARA,1) AND REF(VARA,1)>VARA AND VARA>箱顶 AND CLOSE>箱顶,HIGH*1.005,H*1.03,1,0),COLORWHITE;

通达信一百万买卖点指标公式

 

相关文章