在线检测未来函数

通达信起爆牛股主图指标公式

来源:Internet,编辑:股旁网,2017-10-10

HM1:=ABS(((3.48*CLOSE+HIGH+LOW+O)/5-EMA(CLOSE,20))/EMA(CLOSE,20));
HM2:=DMA(((2.15*CLOSE+LOW+HIGH + O)/5),HM1);
妖股线:=EMA(HM2,200)*1.26 ,LINETHICK2,COLORGREEN;
牛熊线:=EMA(HM2,200)*1.18 ,LINETHICK2,COLORGREEN;
Q1:=MA((L+H+C)/3,5);
压力:=HHV(Q1,60),COLORCYAN,LINETHICK2;
A:IF((压力 >REF(压力,1)),压力,DRAWNULL),COLORCYAN,DOTLINE,LINETHICK2;
AHC1:=CLOSE*VOL;
AHC2:=EMA((EXPMA(AHC1,3)/EXPMA(VOL,3)+EXPMA(AHC1,6)/EXPMA(VOL,6)+EXPMA(AHC1,12)/EXPMA(VOL,12)+EXPMA(AHC1,24)/EXPMA(VOL,24))/4,13),COLORYELLOW;
上轨:=1.06*AHC2,LINETHICK2,COLORWHITE;
顶:1.13*AHC2,LINETHICK2,COLORWHITE;
MM:=MIN(A,妖股线);
MM2:=MIN(上轨,妖股线);
DRAWBAND(MM,RGB(250,0,250),MM2,0 );
KK:=MIN(A,牛熊线);
KK2:=MIN(上轨,牛熊线);
DRAWBAND(KK,0,KK2,0);
IF((妖股线 <= REF(妖股线,1)),妖股线,DRAWNULL),COLORGREEN,DOTLINE,LINETHICK2;
IF((妖股线 >= REF(妖股线,1)),妖股线,DRAWNULL),COLORGREEN,DOTLINE,LINETHICK2;
IF((压力 <= REF(压力,1)),压力,DRAWNULL),COLORGREEN,DOTLINE,LINETHICK2;
IF((压力 >= REF(压力,1)),压力,DRAWNULL),COLORCYAN,DOTLINE,LINETHICK2;
IF((上轨 <= REF(上轨,1)),上轨,DRAWNULL),COLORGREEN,DOTLINE,LINETHICK2;
IF((上轨 >= REF(上轨,1)),上轨,DRAWNULL),COLORWHITE,DOTLINE,LINETHICK2;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
ZT:=REF(C,1)*1.1-C<0.01 AND H=C;
启爆1:=CROSS(C,上轨) AND ZT;
DRAWTEXT(启爆1,L*0.98,'启爆'),COLORYELLOW;
超牛:=CROSS(C,顶) AND ZT;
DRAWTEXT(超牛,L*0.98,'超牛'),COLORRED;

通达信起爆牛股主图指标公式

 

相关文章