在线检测未来函数

通达信波段抓妖主图指标公式

来源:Internet,编辑:股旁网,2017-10-10

MA5:=MA(C,5);
MA8:=MA(C,8);
MA10:=MA(C,10);
MA20:=MA(C,20);
MA30:=MA(C,30);
MA60:=MA(C,60);
MA120:=MA(C,120);
MA250:=MA(C,250);
VAR6:=REF(CLOSE,1);
VAR7:=SMA(MAX(CLOSE-VAR6,0),6,1)/SMA(ABS(CLOSE-VAR6),6,1)*100;
STICKLINE(CROSS(84,VAR7),CLOSE,OPEN,2.8,0),COLORGREEN;
卖出:=CROSS(84,VAR7);
DRAWTEXT(卖出,H*1.001,''),COLORGREEN;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
抄底:=REF(J,1)<10 AND REF(MACD,1)<REF(MACD,2) AND MACD>REF(MACD,1) AND MACD<0 AND
CCI>REF(CCI,1) AND (REF(CCI,2)<-100 OR REF(CCI,3)<-100);
STICKLINE(抄底,CLOSE,OPEN,3.2,0),COLORYELLOW;
月DIF:="MACD.DIF#MONTH";
月DEA:="MACD.DEA#MONTH",;
周DIF:="MACD.DIF#WEEK";
周DEA:="MACD.DEA#WEEK",;
日DIF:="MACD.DIF";
日DEA:="MACD.DEA";
金叉:=CROSS(日DIF,日DEA);
周金叉:=CROSS(周DIF,周DEA);
月金叉:=CROSS(月DIF,月DEA);
金叉共振:=IF(CROSS(周DIF,周DEA),MACD+0.1,0),COLORWHITE,LINETHICK2;
共振:=IF((日DIF>日DEA AND 周DIF>周DEA AND 月金叉) OR ( 周DIF>周DEA AND 月DIF>月DEA AND 日金叉) AND C/REF(C,1)>1.08
OR (月DIF>月DEA AND 日DIF>日DEA AND 周金叉) OR (日金叉 AND 周金叉 AND 月金叉),MACD+0.2,0),COLORF00FF0,LINETHICK3;
STICKLINE(金叉共振 AND C/REF(C,1)>1.05,O,REF(C,1)*1.05,3.2,0),COLOR0077FF;
STICKLINE(金叉共振 AND C/REF(C,1)>1.05,O,REF(C,1)*1.05,2.5,0),COLOR0099FF;
STICKLINE(金叉共振 AND C/REF(C,1)>1.05,O,REF(C,1)*1.05,1.9,0),COLOR00BBFF;
STICKLINE(金叉共振 AND C/REF(C,1)>1.05,O,REF(C,1)*1.05,1.2,0),COLOR00DDFF;
STICKLINE(金叉共振 AND C/REF(C,1)>1.05,O,REF(C,1)*1.05,0.3,0),COLOR00FFFF;
STICKLINE(共振 AND C/REF(C,1)>1.08,C,REF(C,1)*1.05,3,0),COLOR000099;
STICKLINE(共振 AND C/REF(C,1)>1.08,C,REF(C,1)*1.05,2.2,0),COLOR0000CC;
STICKLINE(共振 AND C/REF(C,1)>1.08,C,REF(C,1)*1.05,1.5,0),COLOR0000FF;
STICKLINE(共振 AND C/REF(C,1)>1.08,C,REF(C,1)*1.05,0.5,0),COLORCC66FF;
STICKLINE(共振 AND C/REF(C,1)>1.08,REF(C,1)*1.05,C,0.5,0),COLORYELLOW;
DRAWTEXT(共振 AND C/REF(C,1)>1.08,REF(C,1)*1.058,'抓妖'),COLORYELLOW;
DRAWTEXT(金叉共振 AND C/REF(C,1)>1.05,REF(C,1)*1.028,'↖妖股初现'),COLORRED;
每股净资产:FINANCE(34),NODRAW,COLORRED;
每股公积金:FINANCE(18),NODRAW,COLORGREEN;
未分配利润:FINANCE(32),NODRAW,COLORMAGENTA;
DRAWTEXT_FIX(ISLASTBAR,0,0,0,CODE),COLORGREEN;
DRAWTEXT_FIX(ISLASTBAR,0.1,0,0,STKNAME),COLORMAGENTA;
DRAWTEXT_FIX(ISLASTBAR,0.2,0,0,HYBLOCK),COLORCYAN;
DRAWTEXT_FIX(ISLASTBAR,0.3,0,0,DYBLOCK),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.4,0,0,GNBLOCK),COLORGREEN;
DRAWTEXT_FIX(ISLASTBAR,0,0.1,0,FGBLOCK),COLORWHITE;

通达信波段抓妖主图指标公式

 

相关文章