在线检测未来函数

同花顺MACD主力版指标公式

来源:Internet,编辑:股旁网,2017-10-11

0,colorligray;
DIF:EMA(CLOSE,12)-EMA(CLOSE,26),colorwhite,LINETHICK1;
DEA:EMA(DIF,9),COLOR00FFFF,LINETHICK1;
MACD:2*(DIF-DEA),COLORFF00FF,COLORSTICK;
DRAWICON(CROSS(DIF,DEA),DEA,1);
DRAWICON(CROSS(DEA,DIF),DEA,2);
主力线:EMA(DIF-MA(REF(DIF,1),1),1)*1.862,colorgreen,LINETHICK1;
能量线:EMA(DEA-MA(REF(DEA,1),1),1)*1.862,COLORFFFF1A,LINETHICK1;
IF(主力线>=能量线 AND 主力线>-0.0099,主力线,DRAWNULL),colorred,LINETHICK2;
IF(主力线>-0.0099 AND DIF>REF(DIF,1),主力线,DRAWNULL),colorred,LINETHICK2;
IF(主力线>=能量线 AND 能量线>REF(能量线,1) AND 能量线>-0.0099,能量线,DRAWNULL),colorlimagenta,LINETHICK2;
IF(能量线>-0.0099 AND DIF>DEA AND DIF>-0.0099,能量线,DRAWNULL),colorlimagenta,LINETHICK2;
STICKLINE(MACD>0 AND MACD>=REF(MACD,1),0,MACD,6,0),color0000ff;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),0,MACD,6,0),colorffff00;
STICKLINE(MACD<0 AND MACD>=REF(MACD,1),0,MACD,6,0),colorff00ff;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),0,MACD,6,0),color00ff00;
A:=(3*C+L+O+H)/6;
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/210;
S2:=SMA(C,3,1);
S6:=SMA(C,5,1);
DK:=2*(S2-S6);
主力成本:EMA(X,13),COLORFF00FF,LINETHICK0;
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
YXF:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);
蓝:IF(FILTER(YXF=1,5),20,0),colorliblue,LINETHICK3;
红: IF(FILTER(YXF=1,5),10,0),colorred,LINETHICK2;
黄: IF(FILTER(YXF=1,5),5,0),coloryellow,LINETHICK1;

同花顺MACD主力版指标公式

 

相关文章