在线检测未来函数

通达信明日就有起主图及选股指标公式

来源:Internet,编辑:股旁网,2017-10-16

STICKLINE(OPEN>CLOSE,CLOSE,OPEN,3,1),COLOR00CC00;
X_1:=0.01*AMOUNT/VOL;
X_2:=IF(X_1>REF(X_1,1),VOL,-VOL);
X_3:=SUM(IF(X_1=REF(X_1,1),0,X_2/10000),0);
X_4:=X_3=HHV(X_3,4);
X_5:=100*VOL/(FINANCE(7)/100);
ER10:OPEN/CLOSE*100-100,NODRAW,COLORYELLOW;
ER11:EMA(CLOSE,60)/EMA(CLOSE,31)*100-100,NODRAW,COLORYELLOW;
X_6:=DOWNNDAY(EMA(CLOSE,60),5);
X_7:=UPNDAY(EMA(CLOSE,31),2) AND ER11<=1.86 AND ER11>=1.7 AND REF(LOW,1)<REF(CLOSE,1) AND REF(CLOSE,1)<REF(EMA(CLOSE,60),1) AND REF(CLOSE,1)>REF(EMA(CLOSE,31),1);
X_8:=X_4 AND X_5>=3 AND ER10>=0.12 AND OPEN>CLOSE AND CLOSE>EMA(CLOSE,60) AND EMA(CLOSE,60)>EMA(CLOSE,31) AND REF(X_6,1) AND X_7;
X_9:=BARSLAST(X_8);
ER100:DRAWICON(X_8,HIGH*1.01,17);
STICKLINE(CURRBARSCOUNT<=CONST(X_9+1) AND X_9=0,OPEN,CLOSE,3,0),COLOR009900;
STICKLINE(CURRBARSCOUNT<=CONST(X_9+1) AND X_9=0,OPEN,CLOSE,2,0),COLOR00AA00;
STICKLINE(CURRBARSCOUNT<=CONST(X_9+1) AND X_9=0,OPEN,CLOSE,1,0),COLOR00BB00;
STICKLINE(CURRBARSCOUNT<=CONST(X_9+1) AND X_9=0,OPEN,CLOSE,0.1,0),COLOR00CC00;
线5升:MA(CLOSE,5),COLORRED;
线5跌:IF(MA(CLOSE,5)<REF(MA(CLOSE,5),1),MA(CLOSE,5),DRAWNULL),COLORGREEN;
线10升:MA(CLOSE,10),COLORRED;
线10跌:IF(MA(CLOSE,10)<REF(MA(CLOSE,10),1),MA(CLOSE,10),DRAWNULL),COLORGREEN;
线20升:MA(CLOSE,20),COLORRED;
线20跌:IF(MA(CLOSE,20)<REF(MA(CLOSE,20),1),MA(CLOSE,20),DRAWNULL),COLORGREEN;

{
选股公式:

X_1:=NOT(NAMELIKE(1) OR NAMELIKE(2)) AND VOL>1;
X_2:=0.01*AMOUNT/VOL;
X_3:=IF(X_2>REF(X_2,1),VOL,-VOL);
X_4:=SUM(IF(X_2=REF(X_2,1),0,X_3/10000),0);
X_5:=X_4=HHV(X_4,4);
X_6:=100*VOL/(FINANCE(7)/100);
X_7:=OPEN/CLOSE*100-100;
X_8:=EMA(CLOSE,60)/EMA(CLOSE,31)*100-100;
X_9:=DOWNNDAY(EMA(CLOSE,60),5);
X_10:=UPNDAY(EMA(CLOSE,31),2) AND X_8<=1.86 AND X_8>=1.7 AND REF(LOW,1)<REF(CLOSE,1) AND REF(CLOSE,1)<REF(EMA(CLOSE,60),1) AND REF(CLOSE,1)>REF(EMA(CLOSE,31),1);
X_11:=X_5 AND X_6>=3 AND X_7>=0.12 AND OPEN>CLOSE AND CLOSE>EMA(CLOSE,60) AND EMA(CLOSE,60)>EMA(CLOSE,31) AND REF(X_9,1) AND X_10;
ER100:X_1 AND X_11;
}

通达信明日就有起主图及选股指标公式

 

相关文章