在线检测未来函数

通达信黄金地量指标公式

来源:Internet,编辑:股旁网,2017-10-23

总手:VOL,VOLSTICK;
ZZ:=IF(REF(C,1)>REF(O,1) AND O>REF(C,1)*1.014 AND C<O*1.02,1,3);
SAT:=(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20));
量能饱和度:IF(SAT>1,1,SAT)*100,COLORYELLOW,NODRAW;
AA:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主买:IF(CLOSE>OPEN,AA*(HIGH-LOW),IF(CLOSE<OPEN,AA*((HIGH-OPEN)+(CLOSE-LOW)),VOL /2)),POINTDOT,COLORRED;
主卖:IF(CLOSE>OPEN,AA*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,AA*(HIGH-LOW),VOL /2)),COLORCYAN,POINTDOT;
V5:=MA(V,5);
V12:=MA(V,12);
V34:=MA(V,34);
C6:=MA(C,6);
STICKLINE(C,0,VOL,2,0),COLORGRAY;
STICKLINE(CROSS(C,C6) AND V>V5*1.2 AND V>V12*1.2 AND ZZ>2 AND C>H*0.975,0,VOL,2,0),COLORRED;
STICKLINE(CROSS(C6,C) AND V>V5*1.2 AND V>V12*1.2,0,VOL,2,0),COLORGREEN;
STICKLINE(VOL>MA(VOL,5)*2 AND V>V34*3 AND C<REF(C,1)*1.05,0,VOL,2,0),COLORYELLOW;
STICKLINE(VOL<MA(VOL,5)/2 AND V<V12/2,0,VOL,2,0),COLORBLUE;
STICKLINE(VOL>MA(VOL,5)*2 AND V>V34*3 AND C<REF(C,1)*1.05 AND CROSS(C,C6) AND V>V5*1.2 AND V>V12*1.2 AND ZZ>2 AND C>H*0.975,VOL*0.5,0,2,0),COLORRED;
STICKLINE(VOL>MA(VOL,5)*2 AND V>V34*3 AND C<REF(C,1)*1.05 AND CROSS(C6,C) AND V>V5*1.2 AND V>V12*1.2,VOL*0.5,0,2,0),COLORWHITE;
N:=27;
N2:=9;
N4:=16;
VAR1:=IF(DATE>=1030131,1,1);
VAR2:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
VAR3:=SMA(VAR2,3,1)*VAR1;
VAR4:=SMA(VAR3,N2,1)*VAR1;
VAR5:=3*VAR3-2*VAR4*VAR1;
STICKLINE(VOL AND VAR5>VAR4,0,VOL,2,1),COLORRED;
STICKLINE(VOL AND VAR5<VAR4,0,VOL,2,1),COLORGREEN;
STICKLINE(VOL AND VAR4<N4,-10,VOL*0.5,2,0),COLORBLUE;
VARN2:=CLOSE-REF(CLOSE,1);
VARN3:=IF(CLOSE-REF(CLOSE,1)>=0,VARN2,0);
VARN4:=REF(CLOSE,1)-CLOSE;
VARN5:=IF(CLOSE-REF(CLOSE,1)<=0,VARN4,0);
VARN6:=SUM(VARN3,16)/SUM(VARN5,16);
VARN7:=100-100/(1+VARN6);
VARN8:=EMA(VARN7,16);
VARN9:=EMA(VARN8,8);
VARNA:=EMA(VARN8,45);
MO:=(VARN8-VARNA);
ML:=(VARN9-VARNA);
VARN1A:=EMA(CLOSE,32);
VARN2A:=MA(OPEN,32);
趋势:=(VARN1A-VARN2A);
STICKLINE(MO>ML AND 趋势<0 AND MO>REF(MO,3) AND 趋势>REF(趋势,3),VOL,0,3,0) COLORYELLOW;
MV1:MA(VOL,5);
MV2:MA(VOL,10);
MV3:MA(VOL,20);
DRAWTEXT (VOL>MA(VOL,5)*2 AND V>V34*3 AND C<REF(C,1)*1.05,V,'天'),COLORYELLOW;
DRAWTEXT (VOL<MA(VOL,5)/2 AND V<V12/2,(V5+V)/2,'地'),COLORYELLOW;
DRAWTEXT (CROSS(C,C6) AND V>V5*1.2 AND V>V12*1.2 AND ZZ>2 AND C>H*0.975,V,'吸'),COLORRED;
DRAWTEXT (CROSS(C6,C) AND V>V5*1.2 AND V>V12*1.2,V,'出'),COLORGREEN;

通达信黄金地量指标公式

 

相关文章