在线检测未来函数

通达信好用主图指标公式

来源:Internet,编辑:股旁网,2017-10-23

{智能辅助线}
HHJSJDA:=(3*CLOSE+OPEN+LOW+HIGH)/6;
HHJSJDB:(20*HHJSJDA+19*REF(HHJSJDA,1)+18*REF(HHJSJDA,2)+17*REF(HHJSJDA,3)+16*REF(HHJSJDA,4)+15*REF(HHJSJDA,5)+14*REF(HHJSJDA,6)
+13*REF(HHJSJDA,7)+12*REF(HHJSJDA,8)+11*REF(HHJSJDA,9)+10*REF(HHJSJDA,10)+9*REF(HHJSJDA,11)+8*REF(HHJSJDA,12)
+7*REF(HHJSJDA,13)+6*REF(HHJSJDA,14)+5*REF(HHJSJDA,15)+4*REF(HHJSJDA,16)+3*REF(HHJSJDA,17)+2*REF(HHJSJDA,18)+
REF(HHJSJDA,20))/210,COLORYELLOW;
HHJSJDC:MA(HHJSJDB,5),COLORRED;
{流量幅和行业板块}
总额:=AMOUNT;
买1:=IF(O=C AND (C-REF(C,1))/REF(C,1)*100>9.8,AMOUNT,AMOUNT/((H-L)*2-ABS(O-C))*(C-L));
买%:=买1/AMOUNT*100;
流入1:=AMOUNT*买%/10000000000;
流出1:=AMOUNT/100000000-流入1;
净流:=(流入1-流出1);
总额3:=SUM(AMOUNT,3);
流入3:=SUM(流入1,3);
流出3:=SUM(流出1,3);
净流3:=SUM(流入1-流出1,3);
总额5:=SUM(AMOUNT,5);
流入5:=SUM(流入1,5);
流出5:=SUM(流出1,5);
净流5:=SUM(流入1-流出1,5);
总额10:=SUM(AMOUNT,10);
流入10:=SUM(流入1,10);
流出10:=SUM(流出1,10);
净流10:=SUM(流入1-流出1,10);
画:=CONST(FINDHIGH(总额10,0,190,1));
DRAWTEXT_FIX(1,0.11,0.12,0,'净流(亿):'),COLOR8080FF,LINETHICK1;
DRAWTEXT_FIX(1,0.18,0.1,0,'1日'),COLOR8080FF,LINETHICK1;
DRAWTEXT_FIX(1,0.23,0.1,0,'3日'),COLOR8080FF,LINETHICK1;
DRAWTEXT_FIX(1,0.28,0.1,0,'5日'),COLOR8080FF,LINETHICK1;
DRAWTEXT_FIX(1,0.33,0.1,0,'10日'),COLOR8080FF,LINETHICK1;
DRAWNUMBER_FIX(1,0.18,0.15,0,CONST((净流))),COLORYELLOW;
DRAWNUMBER_FIX(1,0.23,0.15,0,CONST((净流3))),COLORYELLOW;
DRAWNUMBER_FIX(1,0.28,0.15,0,CONST((净流5))),COLORYELLOW;
DRAWNUMBER_FIX(1,0.33,0.15,0,CONST((净流10))),COLORYELLOW;
Z1A:=STRCAT(HYBLOCK,' ');
Z2A:=STRCAT(Z1A,FGBLOCK);
Z3A:=STRCAT(Z2A,DYBLOCK);
Z4A:=STRCAT(Z3A,' ');
DRAWTEXT_FIX(ISLASTBAR,0.25,0.98,0,STRCAT(Z4A,GNBLOCK)),COLORCYAN;
{短中线}
MA1:=MA(C,1);
MA2:=MA(C,2);
MA3:=MA(C,3);
MA4:=MA(C,5);
MA52:=MA(C,8);
MA62:=MA(C,13);
短线:MA((MA1+MA2+MA3+MA4+MA52+MA62)/6,5),COLORMAGENTA,LINETHICK2;
{短线出击}
TT2:=DMA((((HIGH + LOW) + (CLOSE * 2)) / 4.15),0.9);
TT1:=REF(EMA(TT2,3),1);
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
AA1:=AMOUNT/VOL;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=VOL<MA(V,5)*1.5;
FF1:=BB1 AND CC1 AND DD1 AND EE1;
F:=100*(C-REF(C,1))/REF(C,1);
P1:=IF(C<REF(O,1) AND F<0,1,0);
P2:=IF(C<REF(O,2) AND F<0,1,0);
TT3:=P1=0 AND REF(P1,1)=1 AND P2=0 AND REF(P2,1)=1 ;
TT4:=P1=1 AND REF(P1,1)=0 AND P2=1 AND REF(P2,1)=0 ;
Z1:=MA(C,13);
ZX:=REF(Z1,13/2+1);
DRAWTEXT(CROSS(CLOSE,TT1)AND J<55,LOW,'买'),COLORRED;
STICKLINE(TT3,OPEN,CLOSE,3,0),COLORFF00FF;
A1:=EMA(C,14)COLORWHITE,LINETHICK1;
A1X:=(A1-REF(A1,1))/REF(A1,1)*100,NODRAW;
STICKLINE(CROSS(A1X,0),C,O,2,0)COLORYELLOW;
STICKLINE(CROSS(0,A1X),C,O,2,0)COLORGREEN;
{时间窗}
AZ:=BARSCOUNT(CLOSE);
AH:=HHV(HIGH,144);
AL:=LLV(LOW,144);
B0:=(AH-AL)/34;
BL1:=HIGH+B0;
BL2:=LOW-B0;
STICKLINE((AZ+0)/34=FLOOR((AZ+0)/34),BL2,BL2-2*B0,2,0),COLORFFFFFF;
DRAWTEXT((AZ+0)/34=FLOOR((AZ+0)/34),BL2-4*B0,'窗'),COLORFFFFFF;
{股市上涨}
VAR3:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)<=REF(C,3) AND REF(C,2)<REF(C,4) AND C>=REF(C,1);
{绿}
STICKLINE(VAR3,O,(O+C)/2,2.5,0),COLOR00BB00;
STICKLINE(VAR3,O,(O+C)/2,0.2,0),COLOR00FF00;
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
买:=LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2));
{买卖线}
买线:=EMA(CLOSE,2);
卖线:=EMA(SLOPE(CLOSE,32)*20+CLOSE,56),LINETHICK0;
BU:=CROSS(买线,卖线);
SEL:=CROSS(卖线,买线);
DRAWTEXT (BU,LOW*0.989,'点'),COLORYELLOW,LINETHICK3;
STICKLINE(CROSS(买线,卖线),OPEN,CLOSE,2,0),COLORYELLOW;
{买进主图}
A7:=C-REF(C,1);
A8:=100*EMA(EMA(A7,6),6)/EMA(EMA(ABS(A7),6),6);
买3:=LLV(A8,2)=LLV(A8,7) AND COUNT(A8<0,2) AND CROSS(A8,MA(A8,2));
DRAWTEXT(FILTER(买3=1,5),LOW-0.15,'进'),COLORYELLOW;
STICKLINE(买3,OPEN,CLOSE,2,0),COLORYELLOW;
{看牛骑牛主图}
天使:=EMA(C,2);
魔鬼:=EMA(SLOPE(C,9)*20+C,40);
买5:=CROSS(天使,魔鬼);
DRAWTEXT (买5,LOW*0.97,'牛'),COLORMAGENTA;
STICKLINE(CROSS(天使,魔鬼),OPEN,CLOSE,2,0),COLORYELLOW;
{庄现主图}
AA:=CROSS(MA(C,5),MA(C,21)) AND CROSS(MA(C,5),MA(C,34)) AND CROSS(MA(C,5),MA(C,55));
BB:=MA(C,55)>MA(C,13) AND CROSS(MA(C,13),MA(C,34)) AND MA(C,34)>MA(C,21) AND ABS(MA(C,55)-MA(C,21))/MA(C,21)<0.05;
CC:=MA(C,34)>MA(C,5) AND CROSS(MA(C,5),MA(C,21)) AND MA(C,21)>MA(C,13);
DD:=ABS((MA(C,5)-MA(C,13))+(MA(C,13)-MA(C,21))+(MA(C,21)-MA(C,34)))<0.02 AND MA(C,5)>REF(MA(C,5),1) AND MA(C,13)>REF(MA(C,13),1);
EE:=MA(C,21)>MA(C,5) AND CROSS(MA(C,5),MA(C,13)) AND MA(C,13)>MA(C,55) AND ABS(MA(C,21)-MA(C,55))/MA(C,55)<0.05;
FFF:=AA OR BB OR CC OR DD OR EE ;
探测:=FFF AND FILTER( FFF,8);
DRAWTEXT(探测,L*0.978,'●'),COLORRED;
STICKLINE(探测,O,C,3,0),LINETHICK2,COLORWHITE;
JG:=REF(C,BARSLAST(VOL=HHV(VOL,7)));
CON:=BARSLAST(VOL=HHV(VOL,7));
STICKLINE(CON>0,JG,JG,10,0),COLORYELLOW,LINETHICK2;

通达信好用主图指标公式

 

相关文章