在线检测未来函数

通达信涨停难逃选股指标公式

来源:Internet,编辑:股旁网,2017-10-26

X_1:=CLOSE/REF(CLOSE,1)>1.02;
X_2:=VOL>MA(VOL,5);
X_3:=X_1 AND X_2;
X_4:=IF(X_3,70,0);
X_5:=X_4;
X_6:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
X_7:=IF(CLOSE>OPEN,X_6*(HIGH-LOW), X_6*(L-H));
X_8:=X_7/VOL*100;
X_9:=X_8>=80;
X_10:=ATAN((EMA(CLOSE,5)/REF(EMA(CLOSE,5),1)-1)*100)*57.299999;
X_11:=ATAN((EMA(CLOSE,10)/REF(EMA(CLOSE,10),1)-1)*100)*57.299999;
X_12:=ATAN((EMA(CLOSE,20)/REF(EMA(CLOSE,20),1)-1)*100)*57.299999;
X_13:=X_10>=60 AND X_11>13;
X_14:=IF(CLOSE>REF(CLOSE,1),88,0);
X_15:=IF(CLOSE/REF(CLOSE,1)>1.02 AND HIGH/CLOSE<1.01 AND X_14>0,91,0);
X_16:=FILTER(X_15>1,5);
X_17:=MA(CLOSE,90);
X_18:=MA(CLOSE,288);
X_19:=IF(1.1>SMA(CLOSE,2,1)/SMA(CLOSE,13,2)>1.03,SMA(HIGH,21,5)*1.05,SMA(HIGH,21,2)*1.05);
X_20:=IF(1.09>SMA(CLOSE,5,1)/SMA(CLOSE,15,1)>0.3,SMA(LOW,10,1),SMA(LOW,5,1));
X_21:=IF(MA(VOL,2)>MA(VOL,3)/2>MA(VOL,5),SMA(HIGH,2,1),SMA(CLOSE,3,1));
X_22:=IF(MA(VOL,3)>MA(VOL,5)>MA(VOL,9),SMA(CLOSE,3,1),SMA(CLOSE,5,1));
X_23:=CROSS(X_21,X_19) OR CROSS(X_17,X_20) OR CROSS(X_19,X_18);
X_24:=X_16 OR X_23;
X_25:=CLOSE/REF(CLOSE,3)*100-100;
X_26:=STICKLINE(X_25>12,0,50,2,0);
X_27:=MA(CLOSE,5);
X_28:=MA(CLOSE,10);
X_29:=MA(VOL,10);
X_30:=HHV(HIGH,5)=HHV(HIGH,0) AND BARSCOUNT(CLOSE)>=5;
X_31:=CLOSE>REF(CLOSE,1)*1.02;
X_32:=VOL>X_29;
X_33:=OPEN>X_28 AND CLOSE>X_27;
X_34:=X_30 AND X_31 AND X_32 AND X_33;
X_35:=X_25 OR X_34;
X_5 AND X_9 AND X_13 AND X_24 AND X_35,COLORligray,LINETHICK1 ;

通达信涨停难逃选股指标公式

 

相关文章