在线检测未来函数

通达信短线行情及选股指标公式

来源:Internet,编辑:股旁网,2017-11-06

SYXTJ:=(H-MAX(O,C))/MAX(O,C)*100<3;
RSV:=(C-LLV(L,9*4))/(HHV(H,9*4)-LLV(L,9*4))*100;
K:=SMA(RSV,3*4,1);
D:=SMA(K,3*4,1);
J:=3*K-2*D;
DXHQ:=FILTER(EXIST(CROSS(J,D),10) AND NOT(UPNDAY(C,3)) AND J>REF(J,1) AND REF("KDJ.J#DAY",1)<25 AND "KDJ.J#DAY"<"KDJ.D#DAY" AND REF("KDJ.J#DAY",1)<REF("KDJ.J#DAY",2) AND "KDJ.J#DAY">REF("KDJ.J#DAY",1),5) AND SYXTJ;
XG:=DXHQ;
FFA:=1090;
N:=IF(XG,1/FFA*300,DRAWNULL);
B:=1;
NOTEXT1:120*N+B,COLORBLACK;
STICKLINE(XG,40*N+B,20*N+B,3.5,0),COLORA8A8A8;
STICKLINE(XG,50*N+B,49*N+B,1.7,0),COLORA8A8A8;
STICKLINE(XG,49*N+B,48*N+B,1.9,0),COLORA8A8A8;
STICKLINE(XG,48*N+B,47*N+B,2.1,0),COLORA8A8A8;
STICKLINE(XG,47*N+B,46*N+B,2.3,0),COLORA8A8A8;
STICKLINE(XG,46*N+B,45*N+B,2.5,0),COLORA8A8A8;
STICKLINE(XG,45*N+B,44*N+B,2.7,0),COLORA8A8A8;
STICKLINE(XG,44*N+B,43*N+B,2.9,0),COLORA8A8A8;
STICKLINE(XG,43*N+B,42*N+B,3.1,0),COLORA8A8A8;
STICKLINE(XG,42*N+B,41*N+B,3.3,0),COLORA8A8A8;
STICKLINE(XG,41*N+B,40*N+B,3.5,0),COLORA8A8A8;
STICKLINE(XG,101*N+B,96*N+B,0.1,0),COLORWHITE;
STICKLINE(XG,96*N+B,92*N+B,0.3,0),COLORWHITE;
STICKLINE(XG,92*N+B,88*N+B,0.6,0),COLORWHITE;
STICKLINE(XG,88*N+B,84*N+B,0.9,0),COLORWHITE;
STICKLINE(XG,84*N+B,80*N+B,1.2,0),COLORWHITE;
STICKLINE(XG,80*N+B,50*N+B,1.4,0),COLORWHITE;
STICKLINE(XG,74*N+B,70*N+B,0.6,0),COLORRED;
STICKLINE(XG,65*N+B,64*N+B,1.5,0),COLORBLUE;
STICKLINE(XG,51*N+B,49*N+B,1.5,0),COLORBLUE;
STICKLINE(XG,49*N+B,25*N+B,1.5,0),COLORWHITE;
STICKLINE(XG,25*N+B,20*N+B,1.3,0),COLORRED;
STICKLINE(XG,20*N+B,13*N+B,1,0),COLORRED;
STICKLINE(XG,13*N+B,7*N+B,0.7,0),COLORRED;
STICKLINE(XG,7*N+B,1*N+B,0.3,0),COLORRED;
STICKLINE(XG,1*N+B,-7*N+B,0.1,0),COLORRED;
STICKLINE(XG,24.8*N+B,21.8*N+B,1,0),COLORYELLOW;
STICKLINE(XG,21.8*N+B,18.8*N+B,0.5,0),COLORYELLOW;
STICKLINE(XG,18.8*N+B,15.8*N+B,0.1,0),COLORYELLOW;
STICKLINE(XG,60*N+B,55*N+B,0.5,0),COLORRED;
AA1:=STRCAT(CON2STR(YEAR,0),'年');
AA2:=STRCAT(CON2STR(MONTH,0),'月');
AA3:=STRCAT(CON2STR(DAY,0),'日');
AA4:=STRCAT(' 星期',IF(WEEKDAY=1,'一',IF(WEEKDAY=2,'二',IF(WEEKDAY=3,'三',IF(WEEKDAY=4,'四',IF(WEEKDAY=5,'五',''))))));
AA:=STRCAT(STRCAT(STRCAT(AA1,AA2),AA3),AA4);
DRAWTEXT_FIX(ISLASTBAR,0.4,0,0,AA),COLORYELLOW;

{
选股公式:

SYXTJ:=(H-MAX(O,C))/MAX(O,C)*100<3;
RSV:=(C-LLV(L,9*4))/(HHV(H,9*4)-LLV(L,9*4))*100;
K:=SMA(RSV,3*4,1);
D:=SMA(K,3*4,1);
J:=3*K-2*D;
FILTER(EXIST(CROSS(J,D),10) AND NOT(UPNDAY(C,3)) AND J>REF(J,1) AND REF("KDJ.J#DAY",1)<25 AND "KDJ.J#DAY"<"KDJ.D#DAY" AND REF("KDJ.J#DAY",1)<REF("KDJ.J#DAY",2) AND "KDJ.J#DAY">REF("KDJ.J#DAY",1),5) AND SYXTJ;
}

通达信短线行情及选股指标公式

 

相关文章