在线检测未来函数

通达信背离线指标公式

来源:Internet,编辑:股旁网,2017-11-07

{使用说明:当股价下跌,未涨或小幅涨,而背离线涨幅大,则是底背离,买入时机;当股价上涨,而被离线未涨或下跌,则是顶背离,卖出时机。}

N:=21;
M:=5;
TH:=SUM(IF(CLOSE>REF(CLOSE,1),VOL,0),N);
TL:=SUM(IF(CLOSE<REF(CLOSE,1),VOL,0),N);
TQ:=SUM(IF(CLOSE=REF(CLOSE,1),VOL,0),N);
VAR0:100*(TH*2+TQ)/(TL*2+TQ),COLOR0000FF,LINETHICK2;
VAR1:MA(VAR0,M),COLOR00FFFF,LINETHICK2;
W:=CROSS(VAR0,VAR1);
WL1:=VAR1<100;
WL2:=VAR1<150 AND VAR1>REF(VAR1,1);
WLT1:=W AND WL1;
WLT2:=W AND WL2;
TJ1:=FILTER(WLT1,5);
TJ2:=FILTER(WLT2,8);
DRAWTEXT(TJ1,83,'买入'),COLORRED;
SAL1:CROSS(VAR1,VAR0) AND VAR1>250;
SAL2:VAR0>400;
SAL:FILTER(SAL1 OR SAL2,5);

通达信背离线指标公式

 

相关文章