在线检测未来函数

同花顺抢劫MACD指标公式

来源:Internet,编辑:股旁网,2017-11-08

SHORT:=6;
LONG:=13;
MID:=4;
HJ_1:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
HJ_2:=EMA(HJ_1,MID);
HJ_3:=2*(HJ_1-HJ_2);
HJ_4:=IF(HJ_3>0,1,(-1));
HJ_5:=REF(HJ_4,1);
HJ_6:=HJ_4*HJ_5;
HJ_7:=BARSLAST(HJ_6<0);
HJ_8:=HJ_7+1;
HJ_9:=(SUM(HJ_3,0)-REF(SUM(HJ_3,0),HJ_8))/10;
HJ_10:=IF(HJ_3>0 AND HJ_3>=REF(HJ_3,1),HJ_3,0);
HJ_11:=IF(HJ_3>0 AND HJ_3<=REF(HJ_3,1),HJ_3,0);
HJ_12:=IF(HJ_3<0 AND HJ_3<REF(HJ_3,1),HJ_3,0);
HJ_13:=IF(HJ_3<0 AND HJ_3>REF(HJ_3,1),HJ_3,0);
STICKLINE(HJ_10>0,0,HJ_3,2,0),COLOR0000BB;
STICKLINE(HJ_11>0,0,HJ_3,2,1),COLOR0000BB;
STICKLINE(HJ_12<0,HJ_3,0,2,0),colorgreen;
STICKLINE(HJ_13<0,HJ_3,0,2,1),colorgreen;
快线:HJ_1,colorwhite;
慢线:HJ_2,coloryellow;
乖离:HJ_3*100,NODRAW;
面积:=HJ_9,NODRAW;
HJ_14:=CROSS(HJ_1,HJ_2) AND HJ_1<(-0.01);
DRAWICON(HJ_14,HJ_2*1.02,36);
HJ_15:=COUNT(CROSS(HJ_1,HJ_2),BARSLAST(HJ_2>=0));
HJ_16:=CROSS(HJ_1,HJ_2) AND HJ_2<0 AND COUNT(HJ_15=2,21)=1;
DRAWICON(HJ_16,HJ_2*1.12,1);
HJ_17:=BARSLAST(REF(CROSS(HJ_1,HJ_2),1));
HJ_18:=REF(CLOSE,HJ_17+1)>CLOSE AND HJ_1>REF(HJ_1,HJ_17+1) AND CROSS(HJ_1,HJ_2);
A1:=REF(C,1);
A2:=DCLOSE;
A3:=(A2-A1)/A1*100;
AA1:=(A3-REF(A3,1));
AA2:=9.8;
选股1:=CROSS(AA1,AA2);
A11:=REF(V,1);
A12:=DVOL;
A13:=A12/A11;
AA3:=(A13-REF(A13,1));
AA4:=500;
选股2:=CROSS(AA3,AA4);
抢劫:选股1 AND 选股2;
VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
组合买: (VAR11+VAR13+VAR15+VAR17), , colorred;
V10:=PEAKBARS(3,15,1)<10; V12:=IF(V10=1,50,0);
头部:= IF(V12=50,100,0);
卖:IF(头部>REF(头部,1),1.3,0),colorgreen,LINETHICK2;DRAWTEXT(卖,1.4,'高顶出货 '),colorgreen;
V9:=TROUGHBARS(3,15,1)<10; V11:=IF(V9=1,50,0);
底部:= IF(V11=50,50,0);
买:IF( 底部>REF(底部,1),1.1,0),colorlimagenta,LINETHICK2; DRAWTEXT(买,1.2,'主力抄底 '),colorlimagenta;
总亿:AMOUNT/100000000,COLORFF00FF,NODRAW;
VAR1:=AMOUNT/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
流入亿:IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*((HIGH-OPEN)+(CLOSE-LOW)),AMOUNT/2))/100000000,colorred,NODRAW;
流出亿:IF(CLOSE>OPEN,0-VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-VAR1*(HIGH-LOW),0-AMOUNT/2))/100000000,colorwhite,NODRAW;
额亿:流入亿+流出亿,COLORFFFF00,NODRAW;
{线:=MA(CLOSE,1)-MA(CLOSE,6),NODRAW;}
YUWEI:=MA(CLOSE,1)-MA(CLOSE,6),NODRAW;
F1:=ZIG(3,16);
VERTLINE(F1<REF(F1,1),2),coloraa8800;
m5:=EMA(C,5);
m10:=EMA(C,10);
m20:=EMA(C,20);
zf:=(H-L)/REF(C,1)*100;
v1:=C>m5 AND m5>m10 AND m10>m20 AND C>REF(C,1) AND m5>REF(m5,1)
AND m10>REF(m10,1) AND m20>REF(m20,1) AND C/O>1.03 AND (H-C)/C<0.02;
v2:=V>REF(V,1)*1.3 ;
V3:=V/REF(MA(V,5),1)*2>=4;
V4:=V/REF(MA(V,5),1)*2<=15;
大60度且5日线:=ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*180/3.14159>60;
开始拉升:=zf>10 AND v1 AND v2 AND V3 AND 大60度且5日线 AND V4 AND ZF5,colorgreen,nodraw;
STICKLINE(开始拉升>0 AND 开始拉升>=REF(开始拉升,1),0,开始拉升,8,0),colorgreen;
DRAWTEXT(开始拉升,1.3,"将要拉升"),colorgreen;

同花顺抢劫MACD指标公式

 

相关文章