在线检测未来函数

同花顺黄金分割角度主图指标公式

来源:Internet,编辑:股旁网,2017-11-10

M5:=MA(C,5);
M10:=MA(C,10);
M20:=MA(C,20);
M60:=MA(C,60);
A:=M5>=M60 AND M10>=M60 AND M20>=M60;
T:=BARSLAST(CROSS(A,0.5));
HT:=HHVBARS(H,T+1);
NOTEXT1:DRAWLINE(CURRBARSCOUNT=CONST(T)+1,REF(H,T),ISLASTBAR,REF(H,T),0),colorred;
NOTEXT2:DRAWLINE(CURRBARSCOUNT=CONST(T)+1,REF(H,T),HT=0,REF(H,HT),1),colorred;
NOTEXT3:DRAWLINE(CURRBARSCOUNT=CONST(T)+1,REF(H,T),HT=0,(REF(H,HT)-REF(H,T))*0.382+REF(H,T),1),DOTLINE,colormagenta;
NOTEXT4:DRAWLINE(CURRBARSCOUNT=CONST(T)+1,REF(H,T),HT=0,(REF(H,HT)-REF(H,T))*0.618+REF(H,T),1),DOTLINE,colorgreen;
压力:NOTEXT2,NODRAW,coloryellow;
支撑1:NOTEXT3,NODRAW,colormagenta;
支撑2:NOTEXT4,NODRAW,colorgreen;
LT0:=FINDLOWBARS(L,0,30,1);
HT0:=FINDHIGHBARS(H,LT0=0,60,1);
LL:=REF(L,LT0);
HH:=REF(H,HT0);
NOTEXT01:DRAWLINE(HT0=0,HH,LT0=0,HH,1),coloryellow;
NOTEXT02:DRAWLINE(HT0=0,HH,LT0=0,LL,1),coloryellow;
NOTEXT03:DRAWLINE(HT0=0,HH,LT0=0,(HH-LL)*0.382+LL,1),DOTLINE,colorlimagenta;
NOTEXT04:DRAWLINE(HT0=0,HH,LT0=0,(HH-LL)*0.618+LL,1),DOTLINE,colorliblue;
TA:=BARSLAST(REF(NOTEXT01,1)=DRAWNULL AND HT=0);
X支撑线:REF(L,LT0),coloryellow,NODRAW;
X阻力1:(HH-LL)*0.382+LL,colorlimagenta,NODRAW;
X阻力2:(HH-LL)*0.618+LL,colorliblue, NODRAW;

同花顺黄金分割角度主图指标公式

 

相关文章