在线检测未来函数

同花顺九转轨道指标公式

来源:Internet,编辑:股旁网,2017-11-14

短上轨:EMA(H,26),colorred;
短下轨:EMA(L,26),colorgreen;
NOTEXT短下轨0:IF(C>短下轨,短下轨,DRAWNULL),colorred;
NOTEXT短下轨1:IF(C<短下轨,短下轨,DRAWNULL),colorgreen;
NOTEXT短上轨0:IF(C>短上轨,短上轨,DRAWNULL),colorred;
NOTEXT短上轨1:IF(C<短上轨,短上轨,DRAWNULL),colorgreen;
STICKLINE(C>短上轨,短上轨,短下轨,0,0),colorred;
STICKLINE(C<短下轨,短上轨,短下轨,0,0),colorgreen;
长上轨:EMA(H,89),colormagenta;
长下轨:EMA(L,89),colorblue;
NOTEXT长下轨0:IF(C>长下轨,长下轨,DRAWNULL),colormagenta;
NOTEXT长下轨1:IF(C<长下轨,长下轨,DRAWNULL),colorblue;
NOTEXT长上轨0:IF(C>长上轨,长上轨,DRAWNULL),colormagenta;
NOTEXT长上轨1:IF(C<长上轨,长上轨,DRAWNULL),colorblue;
STICKLINE(C>长上轨,长上轨,长下轨,0,0),colormagenta;
STICKLINE(C<长下轨,长上轨,长下轨,0,0),colorblue;
DRAWTEXT((REF(C,3)<REF(短下轨,3) OR REF(C,3)<REF(短上轨,3)) AND (REF(C,2)<REF(短下轨,2) OR REF(C,2)<REF(短上轨,2)) AND (REF(C,1)<REF(短下轨,1) OR REF(C,1)<REF(短上轨,1)) AND C>短上轨 AND 短上轨<长下轨 AND COUNT(C<短下轨,6)>0,L*0.96,'4'),colormagenta;
DRAWTEXT((REF(C,3)<REF(短下轨,3) OR REF(C,3)<REF(短上轨,3)) AND (REF(C,2)<REF(短下轨,2) OR REF(C,2)<REF(短上轨,2)) AND (REF(C,1)<REF(短下轨,1) OR REF(C,1)<REF(短上轨,1)) AND C>短上轨 AND C>长上轨 AND COUNT(C<短下轨,6)>0,L*0.98,'10'),colormagenta;
DRAWTEXT((REF(C,3)<REF(长下轨,3) OR REF(C,3)<REF(长上轨,3)) AND (REF(C,2)<REF(长下轨,2) OR REF(C,2)<REF(长上轨,2)) AND (REF(C,1)<REF(长下轨,1) OR REF(C,1)<REF(长上轨,1)) AND C>长上轨 AND C>短上轨 AND COUNT(C<长下轨,6)>0,L*0.98,'10'),colormagenta;
DRAWTEXT((REF(C,3)>REF(短上轨,3) OR REF(C,3)>REF(短下轨,3)) AND (REF(C,2)>REF(短上轨,2) OR REF(C,2)>REF(短下轨,2)) AND (REF(C,1)>REF(短上轨,1) OR REF(C,1)>REF(短下轨,1)) AND C<短下轨 AND 短上轨>长上轨 AND C>长下轨 AND COUNT(C>短上轨,6)>0,H*1.04,'6'),colormagenta;
DRAWTEXT((REF(C,3)>REF(短上轨,3) OR REF(C,3)>REF(短下轨,3)) AND (REF(C,2)>REF(短上轨,2) OR REF(C,2)>REF(短下轨,2)) AND (REF(C,1)>REF(短上轨,1) OR REF(C,1)>REF(短下轨,1)) AND C<短下轨 AND 短下轨<长下轨 AND COUNT(C>短上轨,6)>0,H*1.04,'0'),colormagenta;
DRAWTEXT((REF(C,3)>REF(长上轨,3) OR REF(C,3)>REF(长下轨,3)) AND (REF(C,2)>REF(长上轨,2) OR REF(C,2)>REF(长下轨,2)) AND (REF(C,1)>REF(长上轨,1) OR REF(C,1)>REF(长下轨,1)) AND C<长下轨 AND C<短下轨 AND COUNT(C>长上轨,6)>0,H*1.04,'0'),colormagenta;
A1:=C>REF(C,4);
NT:=BARSLASTCOUNT(A1);
TJ11:=NT=9;
TJ13:=ISLASTBAR AND BETWEEN(NT,5,8);
AY:=(BACKSET(TJ11>0,9) OR BACKSET(TJ13>0,NT))*NT;
DRAWTEXT(NT=9,H*1.02,'9'),colorgreen;
B1:=C<REF(C,4);
NT0:=BARSLASTCOUNT(B1);
TJ21:=NT0=9 ;
TJ23:=ISLASTBAR AND BETWEEN(NT0,5,8);
AY1:=(BACKSET(TJ21>0,9) OR BACKSET(TJ23>0,NT0))*NT0;
DRAWTEXT(NT0=9,L*0.98,'9'),colorgreen;
短上轨:EMA(H,26),coloryellow;
短下轨:EMA(L,26),coloryellow;
长上轨:EMA(H,89),colorblue;
长下轨:EMA(L,89),colorblue;

同花顺九转轨道指标公式

 

相关文章