在线检测未来函数

同花顺涨放量跌缩量主图指标公式

来源:Internet,编辑:股旁网,2017-11-15

MA3:MA(CLOSE,3);
MA10:MA(CLOSE,10);
MA20:MA(CLOSE,20);
MA60:MA(CLOSE,60);
DIFF:= EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:= EMA(DIFF,9);
动力线:=EMA((C-LLV(L,10))/(HHV(H,25)-LLV(L,10))*4,4);
DRAWTEXT(MA3>=REF(MA3,1) AND REF(MA3,1)<=REF(MA3,2),H*1.030,'上'),colorred;
DRAWTEXT(MA3>=REF(MA3,1) AND REF(MA3,1)<=REF(MA3,2),H*1.020,'拐'),colorred;
DRAWTEXT(MA3<=REF(MA3,1) AND REF(MA3,1)>=REF(MA3,2),H*1.030,'下'),colorwhite;
DRAWTEXT(MA3<=REF(MA3,1) AND REF(MA3,1)>=REF(MA3,2),H*1.020,'拐'),colorwhite;
DRAWTEXT(V=LLV(V,50),L*0.970,'1'), COLORFF00FF;
DRAWTEXT(V=LLV(V,50),L*0.965,'0'), COLORFF00FF;
DRAWTEXT(V=LLV(V,50),L*0.960,'0'), COLORFF00FF;
DRAWTEXT(V=LLV(V,50),L*0.955,'地'), COLORFF00FF;
DRAWTEXT(V=LLV(V,50),L*0.950,'量'), COLORFF00FF;
DRAWLINE(HHV(H,10)=H,H,LLV(L,10)=L,L,0);
DRAWLINE(LLV(L,10)=L,L,HHV(H,10)=H,H,0);
PT1:=CONST(HHV(H,20));
IF(CURRBARSCOUNT<=20,PT1,DRAWNULL),DOTLINE,colormagenta;
DRAWNUMBER(CURRBARSCOUNT<=1,PT1*1.003,PT1),colormagenta;
PT2:=CONST(LLV(L,20));
IF(CURRBARSCOUNT<=20,PT2,DRAWNULL),DOTLINE,colormagenta;
DRAWNUMBER(CURRBARSCOUNT<=1,PT2*1.003,PT2),colormagenta;
Q1:(PT1-PT2)/PT2*100,NODRAW;
Q2:(PT2-PT1)/PT1*100,NODRAW;
DRAWNUMBER(CURRBARSCOUNT=2,PT1*0.995,Q1),coloryellow;
DRAWTEXT(CURRBARSCOUNT=2,PT1*1.00,'涨幅'),colorwhite;
DRAWNUMBER(CURRBARSCOUNT=2,PT2*0.995,Q2),coloryellow;
DRAWTEXT(CURRBARSCOUNT=2,PT2*1.00,'跌幅'),colorwhite;
FLSL:(V-REF(V,1))/REF(V,1)*100,NODRAW;
DRAWTEXT(V>REF(V,1) AND C>REF(C,1),H*1.005,'涨'),colorred;
DRAWTEXT(V<REF(V,1) AND C>REF(C,1),H*1.005,'涨'),colorgreen;
DRAWTEXT(V<REF(V,1) AND C<REF(C,1),H*1.005,'跌'),coloryellow;
DRAWTEXT(V>REF(V,1) AND C<REF(C,1),H*1.005,'跌'),colorgreen;
DRAWNUMBER(V>=1.5*REF(V,1) AND C>REF(C,1),L*0.99,FLSL),colorred;
DRAWNUMBER(V>=1.5*REF(V,1) AND C<REF(C,1),L*0.99,FLSL),colorwhite;
DRAWNUMBER(V*1.5<REF(V,1) AND C>REF(C,1),L*0.99,FLSL),colorgreen;
DRAWNUMBER(V*1.5<REF(V,1) AND C<REF(C,1),L*0.98,FLSL),coloryellow;
DRAWTEXT(V>REF(V,1) AND C=REF(C,1),H*1.005,'平'),colormagenta;
DRAWTEXT(V<REF(V,1) AND C=REF(C,1),H*1.002,'平'),colorwhite;
DRAWICON((CROSS(DIFF,DEA)),L*0.995,34);
DRAWICON((CROSS(DEA,DIFF)),H*1.015,35);
DRAWICON(DIFF>=REF(DIFF,1) AND REF(DIFF,1)<=REF(DIFF,2),L*0.99,9);
DRAWICON(DIFF<=REF(DIFF,1) AND REF(DIFF,1)>=REF(DIFF,2),H*1.02,6);

同花顺涨放量跌缩量主图指标公式

 

相关文章