在线检测未来函数

同花顺多指数背离指标公式

来源:Internet,编辑:股旁网,2017-11-30

SQX:=(C-MA(CLOSE,13))*100;
DIF:=EMA(MA(SQX,7),1),colorwhite;
DEA:=EMA(DIF,7),coloryellow;
MACD:=(DIF-DEA)*2,COLORSTICK;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,0.1,0),colorred;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),MACD,0,0.1,0),COLOR00FFFF;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),MACD,0,0.1,0),COLORFFFF00;
STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,0.1,0),COLORFF00A9;
RSV:=((CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21)))*247.2-123.6;
K:SMA(SMA( RSV,3,1),3,1),colorwhite;
D:MA(EMA(K,3),3),coloryellow;
J:3*K-2*D,colormagenta;
A11:=BARSLAST(REF(CROSS(DIF,DEA),1));
B1:=REF(C,A11+1)>C AND REF(DIF,A11+1)<DIF AND CROSS(DIF,DEA);
A12:=BARSLAST(REF(CROSS("KDJ.K","KDJ.D"),1));
B2:=REF(C,A12+1)>C AND REF("KDJ.K",A12+1)<"KDJ.K" AND CROSS("KDJ.K","KDJ.D");
A13:=BARSLAST(REF(CROSS("RSI.RSI1","RSI.RSI2"),1));
B3:=REF(C,A13+1)>C AND REF("RSI.RSI1",A13+1)<"RSI.RSI1"AND CROSS("RSI.RSI1","RSI.RSI2");
C1:=BARSLAST(REF(CROSS(DEA,DIF),1));
D1:=REF(C,C1+1)<C AND REF(DIF,C1+1)>DIF AND CROSS(DEA,DIF);
C2:=BARSLAST(REF(CROSS("KDJ.D","KDJ.K"),1));
D2:=REF(C,C2+1)<C AND REF("KDJ.K",C2+1)>"KDJ.K" AND CROSS("KDJ.D","KDJ.K");
C3:=BARSLAST(REF(CROSS("RSI.RSI2","RSI.RSI1"),1));
D3:=REF(C,C3+1)<C AND REF("RSI.RSI1",C3+1)>"RSI.RSI1" AND CROSS("RSI.RSI2","RSI.RSI1");
MACD底背:IF(B1>0,50,0),LINETHICK2,colorred;
KDJ底背:IF(B2>0,65,0),LINETHICK2,COLORFF00FF;
RSI底背:IF(B3>0,80,0),LINETHICK2,coloryellow;
MACD顶背:IF(D1>0,-50,0),LINETHICK2,COLOR00FF00;
KDJ顶背:IF(D2>0,-65,0),LINETHICK2,COLORFFCC66;
RSI顶背:IF(D3>0,-80,0),LINETHICK2,colorwhite;

同花顺多指数背离指标公式

 

相关文章