在线检测未来函数

PDI线上穿过MDI线选股公式

来源:Internet,编辑:股旁网,2017-11-01

编写要求:

6天内出现过,PDI线自下而上穿过MDI线,选股公式。

股旁网解答:

N:=14;M:=6;
MTR:=SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=SUM(IF(HD>0&&HD>LD,HD,0),N);
DMM:=SUM(IF(LD>0&&LD>HD,LD,0),N);
PDI:= DMP*100/MTR;
MDI:= DMM*100/MTR;
ADX:= MA(ABS(MDI-PDI)/(MDI+PDI)*100,M);
ADXR:=(ADX+REF(ADX,M))/2;
CROSS(PDI,MDI);

相关文章