在线检测未来函数

通达信仿七星级主图指标公式

来源:Internet,编辑:股旁网,2017-12-01

N:=60;
X:=(2*C+H+L+O/2)/4.5;
X2:=(1.97*C+H+L+O/2)/4.5;
多空线:(20*X+19*REF(X,1)+18*REF(X,2)+17*REF(X,3)+16*REF(X,4)+15*REF(X,5)+14*REF(X,6)
+13*REF(X,7)+12*REF(X,8)+11*REF(X,9)+10*REF(X,10)+9*REF(X,11)+8*REF(X,12)
+7*REF(X,13)+6*REF(X,14)+5*REF(X,15)+4*REF(X,16)+3*REF(X,17)+2*REF(X,18)+
REF(X,20))/210,COLORGREEN;
B1:=EMA(C,3);
B2:=SMA(SMA(B1,2,1),2,1);
SMA2:=EMA(B2,3);
停损下限:IF(LLV(EMA(B2,8),3)<B2,LLV(EMA(B2,8),3),B2),COLORRED,NODRAW;
IF(B2>SMA2,B2,DRAWNULL),COLORRED,LINETHICK4,NODRAW;
IF(B2<SMA2,B2,DRAWNULL),COLORGREEN,LINETHICK4,NODRAW;
SNAKEA:HHV(EMA(B2,1),1),COLORYELLOW;
HHV(EMA(B2,1),N),COLORYELLOW;
LLV(EMA(B2,1),N),COLORYELLOW;
多空线2:(20*X2+19*REF(X2,1)+18*REF(X2,2)+17*REF(X2,3)+16*REF(X2,4)+15*REF(X2,5)+14*REF(X2,6)
+13*REF(X2,7)+12*REF(X2,8)+11*REF(X2,9)+10*REF(X2,10)+9*REF(X2,11)+8*REF(X2,12)
+7*REF(X2,13)+6*REF(X2,14)+5*REF(X2,15)+4*REF(X2,16)+3*REF(X2,17)+2*REF(X2,18)+
REF(X2,20))/210,COLORGREEN;
IF(B2>SMA2,多空线,DRAWNULL),COLORRED,LINETHICK3;
IF(B2>SMA2,多空线2,DRAWNULL),COLORRED,LINETHICK3;
中期线:EMA(C,60),COLORGREEN,LINETHICK7;
IF(中期线>=REF(中期线,1),中期线,DRAWNULL),COLORLIMAGENTA,LINETHICK7;
AAAA:=MA(C,1);
AAA:=SMA(SMA(SMA(AAAA,2,1),2,1),2,1);
BBB:=MA(AAA,3);
DRAWBAND(AAA,RGB(255,193,193),BBB,RGB(34,139,34));
DD:=多空线<REF(多空线,1);
IF(DD,多空线,DRAWNULL),COLORGREEN;
A:=(EMA(C,3)>多空线);
IF(A,(多空线+多空线2)/2,DRAWNULL),COLORMAGENTA,POINTDOT,LINETHICK9;

通达信仿七星级主图指标公式

 

相关文章