在线检测未来函数

通达信八爪保罗主图指标公式

来源:Internet,编辑:股旁网,2017-12-01

VARA:=(2*C+H+L)/4,NODRAW ;
VAR2:=BARSLAST( VARA=LLV(VARA,55))+1;
XXX2:=SMA(VARA,VAR2,1),COLORBLUE,NODRAW ;
VAR3:=BARSLAST( VARA=HHV(VARA,55))+1;
XXX3:=SMA(VARA,VAR3,1),COLORRED,NODRAW ;
VAR4:=BARSLAST( VARA=LLV(VARA,10))+1;
XXX4:=SMA(VARA,VAR4,1),COLORBLUE,NODRAW ;
VAR5:=BARSLAST( VARA=HHV(VARA,10))+1;
XXX5:=SMA(VARA,VAR5,1),COLORRED,NODRAW ;
XXX2A:=EMA(VARA,VAR2),COLORBLUE,NODRAW ;
XXX3A:=EMA(VARA,VAR3),COLORRED,NODRAW ;
XXX4A:=EMA(VARA,VAR4),COLORBLUE,NODRAW ;
XXX5A:=EMA(VARA,VAR5),COLORRED,NODRAW ;
X3:IF(C<REF(XXX3,1),REF(XXX3,1),DRAWNULL),COLORGREEN,LINETHICK2;
X3A:IF(C<REF(XXX3A,1),REF(XXX3A,1),DRAWNULL),COLORGREEN,LINETHICK2;
X5:IF(C<REF(XXX5,1),REF(XXX5,1),DRAWNULL),COLORGREEN,LINETHICK1;
X5A:IF(C<REF(XXX5A,1),REF(XXX5A,1),DRAWNULL),COLORGREEN,LINETHICK1;
X2:IF(C>REF(XXX2,1),REF(XXX2,1),DRAWNULL),COLORRED,LINETHICK2;
X2A:IF(C>REF(XXX2A,1),REF(XXX2A,1),DRAWNULL),COLORRED,LINETHICK2;
X4:IF(C>REF(XXX4,1),REF(XXX4,1),DRAWNULL),COLORRED,LINETHICK1;
X4A:IF(C>REF(XXX4A,1),REF(XXX4A,1),DRAWNULL),COLORRED,LINETHICK1;
{十战七胜--买进信号}
A7:=C-REF(C,1);
A8:=100*EMA(EMA(A7,6),6)/EMA(EMA(ABS(A7),6),6);
买:=LLV(A8,2)=LLV(A8,7) AND COUNT(A8<0,2) AND CROSS(A8,MA(A8,2));
{DRAWTEXT(FILTER(买=1,5),LOW-0.05,'↖买进'),COLORYELLOW;}
STICKLINE(买,OPEN,CLOSE,2,0),COLORYELLOW;
{小十战七胜--买进信号}
A88:=100*EMA(EMA(A7,3),3)/EMA(EMA(ABS(A7),3),3);
买1:=LLV(A88,2)=LLV(A88,7) AND COUNT(A88<0,2) AND CROSS(A88,MA(A88,2));
STICKLINE(买1,OPEN,CLOSE,2,0),COLORMAGENTA;
跳空:=L>REF(H,1);
不破价2:=REF(H,(BARSLAST(跳空)+1));
A2:=BARSLAST(跳空)+1 ;
TJ12:=REF(H,A2);
TJ32:=L>TJ12;
TJ42:=SUM(TJ32,A2)=A2;
缺口:IF(TJ42>=1,不破价2,DRAWNULL),COLORFFD680,LINETHICK4,POINTDOT;
跳空1:=H<REF(L,1);
不破价1:=REF(L,(BARSLAST(跳空1)+1));
A1:=BARSLAST(跳空1)+1 ;
TJ11:=REF(L,A1);
TJ31:=H<TJ11;
TJ41:=SUM(TJ31,A1)=A1;
下缺口:IF(TJ41>=1,不破价1,DRAWNULL),COLORGREEN,LINETHICK4,POINTDOT;
{短期精准线信号}
N:=3;
L0:=0.00;{点位差参数}
L1:=ABS(L-REF(L,1))<=L0;
L2:=ABS(L-REF(L,2))<=L0;
L3:=ABS(L-REF(L,3))<=L0;
L4:=ABS(L-REF(L,4))<=L0;
L5:=ABS(L-REF(L,5))<=L0;
L6:=ABS(L-REF(L,6))<=L0;
L7:=ABS(L-REF(L,7))<=L0;
L8:=ABS(L-REF(L,8))<=L0;
精准线首次:=L1 OR L2 OR L3 OR L4 OR L5 OR L6 OR L7 OR L8;
精准左:=FILTER(精准线首次,N) ;
天数:=BARSLAST(精准左);
LTS:=REF(L,天数);
精准右:=ABS(L-LTS)<=L0;
STICKLINE(精准右,OPEN,CLOSE,2,0),COLORBLUE;

通达信八爪保罗主图指标公式

 

相关文章