在线检测未来函数

通达信猛牛选股指标公式

来源:Internet,编辑:股旁网,2017-12-11

N:=14;
MM:=6;
MTR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),N);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),N);
多头线: DMP*100/MTR,COLORRED,LINETHICK2;
空头线: DMM*100/MTR,COLORGREEN,LINETHICK2;
趋势线: EXPMEMA(ABS(空头线-多头线)/(空头线+多头线)*100,MM),COLORYELLOW,LINETHICK2;
强弱分界:30,COLORWHITE,DOTLINE,LINETHICK1;
VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0);
VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.03) AND((HIGH)/(CLOSE)<1.03) AND ((多头线-空头线)>10) AND 多头线>25 AND (趋势线>REF(趋势线,1)) AND (VAR3AA>0),91,0);
XG:=(FILTER((VAR4AA>90),21)),COLORYELLOW;
STICKLINE(XG,30,0,4,0),COLOR000099;
STICKLINE(XG,30,0,2,0),COLOR0000BB;
STICKLINE(XG,30,0,1,0),COLOR0000DD;
STICKLINE(XG,30,0,0.9,0),COLOR0000FF;

通达信猛牛选股指标公式

 

相关文章