在线检测未来函数

通达信最强音至尊选股指标公式

来源:Internet,编辑:股旁网,2017-12-14

ZQ_1:=MA(CLOSE,5);
ZQ_2:=MA(CLOSE,10);
ZQ_3:=MA(CLOSE,60);
ZQ_4:=MA(CLOSE,120);
ZQ_5:=REF(CLOSE,1)<REF(ZQ_1,1) AND OPEN<ZQ_1 AND ZQ_1>ZQ_4;
ZQ_6:=REF(ZQ_5 ,1)=0 AND ZQ_5;
ZQ_7:=EMA(HHV(HIGH,1),8);
ZQ_8:=EMA(CLOSE,8);
ZQ_9:=ZQ_8<REF(ZQ_8,1) AND CLOSE<ZQ_8;
ZQ_10:=IF(ZQ_7<REF(ZQ_7,1) OR ZQ_9,1,0);
ZQ_11:=(COUNT(ZQ_10=1,4)=3 AND ZQ_10=0)*89;
ZQ_12:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
ZQ_13:=IF(CLOSE>OPEN,ZQ_12*(HIGH-LOW),IF(CLOSE<OPEN,ZQ_12*(HIGH-OPEN+CLOSE-LOW),VOL/2))+IF(CLOSE>OPEN,0-ZQ_12*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE<OPEN,0-ZQ_12*(HIGH-LOW),0-VOL/2));
ZQ_14:=ZQ_13/20/1.15;
ZQ_15:=ZQ_14*0.55+REF(ZQ_14,1)*0.33+REF(ZQ_14,2)*0.22;
ZQ_16:=EMA(ZQ_15,3);
ZQ_17:=ZQ_16<100;
ZQ_18:=COUNT(ZQ_17,9)<2;
ZQ_19:=CLOSE/REF(CLOSE,1)>1.09;
ZQ_20:=CLOSE=HIGH;
ZQ_21:=REF(ZQ_19,1) AND REF(ZQ_20,1);
ZQ_22:=COUNT(ZQ_21,11)>0;
ZQ_23:=MA(CLOSE,3);
ZQ_24:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
ZQ_25:=(HIGH-REF(CLOSE,1))/REF(CLOSE,1)*100;
ZQ_26:=REF(HHV(VOL,10),1);
ZQ_27:=MA(CLOSE,20);
ZQ_28:=(ZQ_23+ZQ_1)/2;
ZQ_29:=COUNT(COUNT(ZQ_24>9.9 AND CLOSE=HIGH,1)>=1,30)>0;
ZQ_30:=COUNT(COUNT(ZQ_24>9.9 AND CLOSE=HIGH,1)>=1,60)>0;
ZQ_31:=ZQ_27>REF(ZQ_27,1) AND VOL<ZQ_26 AND ZQ_29 AND ZQ_25>3 AND OPEN<=ZQ_1 AND CLOSE>ZQ_1 AND (COUNT(ZQ_28>REF(ZQ_28,1),3)>=3 OR COUNT(ZQ_1>REF(ZQ_1,1),3)>=3) AND COUNT(ZQ_27>REF(ZQ_27,1),25)>=16;
ZQ_32:=(CLOSE-OPEN)/OPEN*100;
ZQ_33:=ZQ_30 AND VOL<1.3*REF(VOL,1) AND COUNT(ZQ_32>0.5,6)>=5 AND COUNT(ZQ_23>ZQ_1,5)>=5 AND COUNT(HIGH>REF(HIGH,1),6)>=5 AND ZQ_25>4.5 AND OPEN<=ZQ_23 AND CLOSE>ZQ_23 AND OPEN>ZQ_1;
ZQ_34:=ZQ_31 OR ZQ_33;
ZQ_35:=ZQ_34=1 AND COUNT(ZQ_34,15)=1;
ZQ_36:=AMOUNT/VOL/7;
ZQ_37:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
ZQ_38:=SUM(AMOUNT,10)/ZQ_36/7;
ZQ_39:=DMA(ZQ_37,VOL/ZQ_38);
ZQ_40:=(CLOSE-ZQ_39)/ZQ_39*100;
ZQ_41:=-ZQ_40;
ZQ_42:=ZQ_40>ZQ_41;
ZQ_43:=CROSS(ZQ_40,0.6) AND ZQ_42;
ZQ_44:=EMA(CLOSE/REF(CLOSE,1),5);
ZQ_45:=EMA(CLOSE/REF(CLOSE,1),10);
ZQ_46:=CROSS(ZQ_44,ZQ_45);
ZQ_47:=ZQ_43 AND ZQ_46;
ZQ_48:=ZQ_47 AND ZQ_35;
ZQ_49:=COUNT(ZQ_35,10)>0;
ZQ_50:=ZQ_47 AND ZQ_49 AND ZQ_22;
ZQ_51:=ZQ_47 AND ZQ_22 AND ZQ_11;
ZQ_52:=ZQ_48 AND ZQ_22;
ZQ_53:=ZQ_50 OR ZQ_52 OR ZQ_51;
ZQ_54:=(EMA(CLOSE,12)-EMA(CLOSE,26))/EMA(CLOSE,26)*100;
ZQ_55:=EMA(ZQ_54,9);
ZQ_56:=(ZQ_54-ZQ_55)*100;
ZQ_57:=ZQ_56-REF(ZQ_56,1);
ZQ_58:=CROSS(ZQ_57,50);
ZQ_59:=EMA(EMA(EMA(CLOSE,12),12),12);
ZQ_60:=(ZQ_59-REF(ZQ_59,1))/REF(ZQ_59,1)*100;
ZQ_61:=MA(ZQ_60 ,9);
ZQ_62:=ZQ_60>ZQ_61;
ZQ_63:=CLOSE/REF(CLOSE,1)>1.09;
ZQ_64:=CLOSE=HIGH;
ZQ_65:=REF(ZQ_63,1) AND REF(ZQ_64,1);
ZQ_66:=COUNT(ZQ_65,4)>0;
ZQ_67:=COUNT(ZQ_65,5)>0;
ZQ_68:=(3*CLOSE+LOW+OPEN+HIGH)/6;
ZQ_69:=(20*ZQ_68+19*REF(ZQ_68,1)+18*REF(ZQ_68,2)+17*REF(ZQ_68,3)+16*REF(ZQ_68,4)+15*REF(ZQ_68,5)+14*REF(ZQ_68,6)+13*REF(ZQ_68,7)+12*REF(ZQ_68,8)+11*REF(ZQ_68,9)+10*REF(ZQ_68,10)+9*REF(ZQ_68,11)+8*REF(ZQ_68,12)+7*REF(ZQ_68, 13)+6*REF(ZQ_68,14)+5*REF(ZQ_68,15)+4*REF(ZQ_68,16)+3*REF(ZQ_68,17)+2*REF(ZQ_68,18)+REF(ZQ_68,20))/210;
ZQ_70:=MA(ZQ_69,6);
ZQ_71:=ZQ_69>ZQ_70;
ZQ_72:=CLOSE>1.02*REF(CLOSE,1);
ZQ_73:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100<(-6);
ZQ_74:=REF(CLOSE,1)>(REF(CLOSE,BARSLAST(ZQ_72))+REF(CLOSE,BARSLAST(ZQ_72)+1))/2 AND CLOSE<(REF(CLOSE,BARSLAST(ZQ_72))+REF(CLOSE,BARSLAST(ZQ_72)+1))/2;
ZQ_75:=REF(CLOSE,1)<(REF(CLOSE,BARSLAST(ZQ_73))+REF(CLOSE,BARSLAST(ZQ_73)+1))/2 AND CLOSE>(REF(CLOSE,BARSLAST(ZQ_73))+REF(CLOSE,BARSLAST(ZQ_73)+1))/2;
ZQ_76:=BARSLAST(ZQ_73)<=7 AND ZQ_72 AND ZQ_75 AND COUNT(ZQ_72,BARSLAST(ZQ_73))=1 AND NOT(HIGH=LOW) AND REF(NOT(HIGH=LOW),BARSLAST(ZQ_73))=1;
ZQ_77:=COUNT(ZQ_76,7)>0;
ZQ_78:=((CLOSE-REF(MA(CLOSE,6),1))/6+MA(CLOSE,6))*1.004;
ZQ_79:=CROSS(CLOSE,ZQ_78) AND ZQ_78>REF(ZQ_78,1);
ZQ_80:=((CLOSE-REF(MA(CLOSE,18),1))/18+MA(CLOSE,18))*1.004;
ZQ_81:=CROSS(CLOSE,ZQ_80) AND ZQ_80>REF(ZQ_80,1);
ZQ_82:=ZQ_79 AND ZQ_81 AND ZQ_76 AND ZQ_71 AND ZQ_62;
ZQ_83:=ZQ_66 AND ZQ_76 AND ZQ_71 AND ZQ_62;
ZQ_84:=ZQ_82 OR ZQ_83;
ZQ_85:=ZQ_18 AND ZQ_53;
最强音终极:ZQ_84 OR ZQ_85,COLORRED;

通达信最强音至尊选股指标公式

 

相关文章