在线检测未来函数

通达信趋势维持线指标公式

来源:Internet,编辑:股旁网,2017-12-15

DRAWGBK(CURRBARSCOUNT=1, RGB(110,108,108),RGB(88,30,0),0,'',0);
RSV:=(CLOSE-LLV(LOW,40))/(HHV(HIGH,40)-LLV(LOW,40))*100;
K:=SMA(RSV,18,1) LINETHICK1 COLORFF4600;
K1:=K LINETHICK2 COLORFF0000;
D:=SMA(K,3,1) LINETHICK1 COLOR0FFF2B;
D1:=D LINETHICK2 COLOR007F00;
J:3*K-2*D LINETHICK2 COLORRED;
J1:=J LINETHICK1 COLORFFF60A;
IF(J>REF(J,1),J,DRAWNULL) CIRCLEDOT,LINETHICK1 COLORWHITE;
IF(J>REF(J,1),J,DRAWNULL) CIRCLEDOT,LINETHICK3 COLORC0FFFF;
IF(J<REF(J,1),J,DRAWNULL) CIRCLEDOT,LINETHICK3,COLOR9F35DD;
IF(J<REF(J,1),J,DRAWNULL) CIRCLEDOT,LINETHICK1,COLORFFB0FF;
IF(J<REF(J,1),J,DRAWNULL) CIRCLEDOT,LINETHICK2,COLORFF8BFF;
趋势维持线:=EMA(J,4.2) COLORRED LINETHICK2 ;
轨道线:(J+REF(J,1)+REF(J,2)+REF(J,3))/4*(K/D) COLORGREEN;
差值1:J-轨道线,NODRAW;
差值2:(J-K1)+50,COLORRED;
IF(差值2<50,差值2,DRAWNULL),COLORCYAN;
{地网线}
VAR1:=(CLOSE-MA(CLOSE,21))/MA(CLOSE,21)*100;
VAR2:=(CLOSE-LLV(LOW,43))/(HHV(HIGH,43)-LLV(LOW,43))*100;
VAR3:=SMA(VAR2,2,1);
红线数值:SMA(VAR3,2,1),COLORRED,LINETHICK2;
天罗:=100+(-ABS(VAR1)),COLORYELLOW,LINETHICK2;
地网:=ABS(VAR1),LINETHICK2;
牛熊分界:50;
弱势区:20;
强势区:80;
DRAWTEXT(CROSS(红线数值>=天罗,1),红线数值,'?'),LINETHICK4,COLORGREEN;
DRAWTEXT(CROSS(红线数值>=地网,1),红线数值,'?'),LINETHICK4,COLORGREEN;

通达信趋势维持线指标公式

 

相关文章