在线检测未来函数

同花顺MACD粗线指标公式

来源:Internet,编辑:股旁网,2017-12-15

JJ :=(C*2+H+L)/4;
SKK :( EMA(JJ,13) - EMA(JJ,22))*180,COLORWHITE;
SDD : EMA(SKK,10),COLORYELLOW;
多方: (SKK-SDD)*0.000000001,COLORBLACK,LINETHICK0;
空方: -1*(SKK-SDD)*0.000000001,COLORBLACK,LINETHICK0;
RC:=DYNAINFO(3);
RC,COLORWHITE;
SK:=(SLOPE(EMA(JJ,2),7)*15+JJ)*0.8*0.0001,COLORRED;
SD:=EMA(SK,2),COLORGREEN;
SJ:=2.8*SK-1.8*SD,COLORRED;
S2:=SMA(C,3,1);
S6:=SMA(C,5,1);
DK:=2*(S2-S6)*15*4*1.5;
STICKLINE(SK>SD AND DK<RC OR DK=RC,RC,RC+DK,2,1),COLORRED;
STICKLINE(DK>0 AND SK>SD ,RC,RC+DK,2,0),COLORRED;
STICKLINE(DK>0 AND SK<SD ,RC,RC+DK,2,0),COLORCYAN;
STICKLINE(DK>0 AND 多方<空方,RC,RC+DK,2,0),COLORMAGENTA;
STICKLINE(CROSS(多方,空方),RC,RC+DK,2,0),COLORYELLOW;
STICKLINE(CROSS(空方,多方),RC,RC+DK,2,0),COLORCYAN;
STICKLINE(DK<0 AND 多方<空方 AND SK<SD,RC,RC+DK,2,1),COLORCYAN;

同花顺MACD粗线指标公式

 

相关文章