在线检测未来函数

通达信板块对比指标公式

来源:Internet,编辑:股旁网,2017-12-19

VAR1:=("880400$C");{医药}
VAR2:=("880471$C");{银行}
VAR3:=("880367$C");{纺织服饰}
VAR4:=("880476$C");{建筑}
VAR5:=("880437$C");{通用机械}
VAR6:=("880482$C");{房地产}
VAR7:=("880360$C");{农林牧渔}
VAR8:=("880494$C");{互联网*}
VAR9:=("880310$C");{石油}
VAR10:=("880492$C");{元器件*}
VAR11:=("880301$C");{煤炭}
VAR12:=("999999$C");{上证*}
VAR13:=("880324$C");{有色}
VAR14:=("880406$C");{商业连锁}
VAR15:=("880318$C");{钢铁}
VAR16:=("880305$C");{电力}
VAR17:=("880387$C");{电器}
VAR18:=("880418$C");{传媒}
VAR19:=("880387$C");{家电}
VAR20:=("880335$C");{日用化工}
VAR21:=("880424$C");{旅游}
VAR22:=("880350$C");{造纸}
VAR23:=("880454$C");{水务}
VAR24:=("880472$C");{证券}
VAR25:=("880430$C");{航空}
VAR26:=("880447$C");{工程机械}
VAR27:=("880330$C");{化纤}
VAR28:=("880446$C");{电气设备}
VAR29:=("880490$C");{通信设备}
VAR30:=("880489$C");{电脑设备}
VAR31:=("880452$C");{电信运营}
VAR32:=("880493$C");{软件服务}
VAR33:=("880432$C");{运输服务}
VAR34:=("880464$C");{仓储物流}
VAR35:=("880398$C");{医疗保健}
VAR36:=("880440$C");{工业机械}
VAR37:=("880431$C");{船舶}
VAR38:=("880456$C");{环境保护}
VAR39:=("880344$C");{建材}
VAR40:=("880474$C");{多元金融}
VAR41:=("880423$C");{酒店餐饮}
VAR42:=("880453$C");{公共交通}
VAR43:=("880390$C");{汽车类}
VAR44:=("880418$C");{传媒娱乐}
VAR45:=("880448$C");{电器仪表}
VAR46:=("880465$C");{交通设施}
VAR47:=("880351$C");{矿物制品}
VAR48:=("880372$C");{食品饮料}
VAR49:=("880473$C");{保险}
VAR50:=("880455$C");{供气供热}
VAR51:=("880497$C");{综合类}
VAR52:=("880380$C");{酿酒}
VAR53:=("880399$C");{家居用品}
VAR54:=("880422$C");{文教休闲}
VAR55:=("880421$C");{广告包装}
VAR56:=("880335$C");{化工}
医药A:SUM((VAR1/REF(VAR1,1)-1)*100,0)*2+100;
银行A:SUM((VAR2/REF(VAR2,1)-1)*100,0)*2+100;
纺织服饰A:SUM((VAR3/REF(VAR3,1)-1)*100,0)*2+100;
建筑A:SUM((VAR4/REF(VAR4,1)-1)*100,0)*2+100;
通用机械A:SUM((VAR5/REF(VAR5,1)-1)*100,0)*2+100;
地产A:SUM((VAR6/REF(VAR6,1)-1)*100,0)*2+100;
农林牧渔A:SUM((VAR7/REF(VAR7,1)-1)*100,0)*2+100;
互联网A:SUM((VAR8/REF(VAR8,1)-1)*100,0)*2+100;
石油A:SUM((VAR9/REF(VAR9,1)-1)*100,0)*2+100;
元器件A:SUM((VAR10/REF(VAR10,1)-1)*100,0)*2+100;
煤炭A:SUM((VAR11/REF(VAR11,1)-1)*100,0)*2+100;
上证A:SUM((VAR12/REF(VAR12,1)-1)*100,0)*2+100,COLORRED,LINETHICK3;
有色A:SUM((VAR13/REF(VAR13,1)-1)*100,0)*2+100;
商业连锁A:SUM((VAR14/REF(VAR14,1)-1)*100,0)*2+100;
钢铁A:SUM((VAR15/REF(VAR15,1)-1)*100,0)*2+100;
电力A:SUM((VAR16/REF(VAR16,1)-1)*100,0)*2+100;
电器A:SUM((VAR17/REF(VAR17,1)-1)*100,0)*2+100;
传媒A:SUM((VAR18/REF(VAR18,1)-1)*100,0)*2+100;
家电A:SUM((VAR19/REF(VAR19,1)-1)*100,0)*2+100;
日用化工A:SUM((VAR20/REF(VAR20,1)-1)*100,0)*2+100;
旅游A:SUM((VAR21/REF(VAR21,1)-1)*100,0)*2+100;
造纸A:SUM((VAR22/REF(VAR22,1)-1)*100,0)*2+100;
水务A:SUM((VAR23/REF(VAR23,1)-1)*100,0)*2+100;
证券A:SUM((VAR24/REF(VAR24,1)-1)*100,0)*2+100;
航空A:SUM((VAR25/REF(VAR25,1)-1)*100,0)*2+100;
工程机械A:SUM((VAR26/REF(VAR26,1)-1)*100,0)*2+100;
化纤A:SUM((VAR27/REF(VAR27,1)-1)*100,0)*2+100;
电气设备A:SUM((VAR28/REF(VAR28,1)-1)*100,0)*2+100;
通信设备A:SUM((VAR29/REF(VAR29,1)-1)*100,0)*2+100;
电脑设备A:SUM((VAR30/REF(VAR30,1)-1)*100,0)*2+100;
电信运营A:SUM((VAR31/REF(VAR31,1)-1)*100,0)*2+100;
软件服务A:SUM((VAR32/REF(VAR32,1)-1)*100,0)*2+100;
运输服务A:SUM((VAR33/REF(VAR33,1)-1)*100,0)*2+100;
仓储物流A:SUM((VAR34/REF(VAR34,1)-1)*100,0)*2+100;
医疗保健A:SUM((VAR35/REF(VAR35,1)-1)*100,0)*2+100;
工业机械A:SUM((VAR36/REF(VAR36,1)-1)*100,0)*2+100;
船舶A:SUM((VAR37/REF(VAR37,1)-1)*100,0)*2+100;
环境保护A:SUM((VAR38/REF(VAR38,1)-1)*100,0)*2+100;
建材A:SUM((VAR39/REF(VAR39,1)-1)*100,0)*2+100;
多元金融A:SUM((VAR40/REF(VAR40,1)-1)*100,0)*2+100;
酒店餐饮A:SUM((VAR41/REF(VAR41,1)-1)*100,0)*2+100;
公共交通A:SUM((VAR42/REF(VAR42,1)-1)*100,0)*2+100;
汽车类A:SUM((VAR43/REF(VAR43,1)-1)*100,0)*2+100;
传媒娱乐A:SUM((VAR44/REF(VAR44,1)-1)*100,0)*2+100;
电器仪表A:SUM((VAR45/REF(VAR45,1)-1)*100,0)*2+100;
交通设施A:SUM((VAR46/REF(VAR46,1)-1)*100,0)*2+100;
矿物制品A:SUM((VAR47/REF(VAR47,1)-1)*100,0)*2+100;
食品饮料A:SUM((VAR48/REF(VAR48,1)-1)*100,0)*2+100;
保险A:SUM((VAR49/REF(VAR49,1)-1)*100,0)*2+100;
供气供热A:SUM((VAR50/REF(VAR50,1)-1)*100,0)*2+100;
综合类A:SUM((VAR51/REF(VAR51,1)-1)*100,0)*2+100;
酿酒A:SUM((VAR52/REF(VAR52,1)-1)*100,0)*2+100;
家居用品A:SUM((VAR53/REF(VAR53,1)-1)*100,0)*2+100;
文教休闲A:SUM((VAR54/REF(VAR54,1)-1)*100,0)*2+100;
广告包装A:SUM((VAR55/REF(VAR55,1)-1)*100,0)*2+100;
化工A:SUM((VAR56/REF(VAR56,1)-1)*100,0)*2+100;
当前线:SUM((C/REF(C,1)-1)*100,0)*2+100,COLORCYAN,LINETHICK2;
Q1:=IF(BARSLAST(CURRBARSCOUNT=2),10,0);
DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),医药A,'医药');
{DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),银行A,'银行');}
{DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),纺织服饰A,'纺织服饰A');}
{DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),建筑A,'建筑');}
{DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),通用机械A,'通用机械');}
DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),地产A,'地产');
{DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),农林牧渔A,'农林牧渔');}
{DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),互联网A,'互联网');}
DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),石油A,'石油');
DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),元器件A,'元器件');
DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),煤炭A,'煤炭');
DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),有色A,'有色');
{DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),商业连锁A,'商业连锁');}
DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),钢铁A,'钢铁');
{DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),电力A,'电力');}
{DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),电器A,'电器');}
{DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),传媒A,'传媒');}
DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),家电A,'家电');
{DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),日用化工A,'日用化工');}
DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),旅游A,'旅游');
{DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),造纸A,'造纸');}
{DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),水务A,'水务');}
DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),证券A,'证券');
DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),航空A,'航空');
{DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),工程机械A,'工程机械');}
{DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),化纤A,'化纤');}
{DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),电气设备A,'电气设备');}
DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),通信设备A,'通信设备');
{DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),电脑设备A,'电脑设备');}
{DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),电信运营A,'电信运营');}
{DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),软件服务A,'软件服务');}
{DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),运输服务A,'运输服务');}
{DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),仓储物流A,'仓储物流');}
DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),医疗保健A,'医疗保健');
{DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),工业机械A,'工业机械');}
DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),船舶A,'船舶');
DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),环境保护A,'环境保护');
{DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),建材A,'建材');}
{DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),多元金融A,'多元金融');}
{DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),酒店餐饮A,'酒店餐饮');}
{DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),公共交通A,'公共交通');]
DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),汽车类A,'汽车类');
{DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),传媒娱乐A,'传媒娱乐');}
{DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),电器仪表A,'电器仪表');}
{DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),交通设施A,'交通设施');}
{DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),矿物制品A,'矿物制品');}
{DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),食品饮料A,'食品饮料');}
DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),保险A,'保险');
{DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),供气供热A,'供气供热');}
{DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),综合类A,'综合类');}
DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),酿酒A,'酿酒');
{DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),家居用品A,'家居用品');}
{DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),文教休闲A,'文教休闲');}
{DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),广告包装A,'广告包装');}
{DRAWTEXT((Q1>=10 AND REF(Q1,1)<=0),化工A,'化工');};

通达信板块对比指标公式

 

相关文章