在线检测未来函数

通达信凹口平衡线主图指标公式

来源:Internet,编辑:股旁网,2017-12-19

百分比:=5;
ZIG(3,百分比);{此行可省};
波峰距离: PEAKBARS(3,百分比,1),NODRAW;
波谷值:=TROUGH(2,百分比,1);
波谷距离:=TROUGHBARS(2,百分比,1);
距离:=CURRBARSCOUNT,NODRAW;
C2:=REF(C,1);
比前跌率:=(C2-C)*100/C2;
本日跌率:=(O-C)*100/O;
距离FK1:=波峰距离-1;{波峰右边K距离}
线位置:= REF(L,距离FK1),{NODRAW};
TJ1:=波峰距离>波谷距离+5 AND 波峰距离<120;
TJ2:=REF(本日跌率,距离FK1)>3 OR REF(比前跌率,距离FK1)>3;{跌率>3%}
TJ3:=距离<240;
TJ4:=REF(C,距离FK1)<REF(O,距离FK1) {阴K}
AND REF(C,距离FK1)<REF(MIN(C,O),距离FK1+1);{跌破前K}
画线条件:= 线位置=REF(线位置,1) AND TJ2 AND TJ4;{画线条件}
STICKLINE(画线条件,线位置,线位置,15,1),COLORMAGENTA;{画线}
画线: IF(画线条件,线位置,DRAWNULL),COLORMAGENTA;{画线}
打字条件:=FILTER(画线条件 AND TJ1 AND TJ3,20);
DRAWTEXT(打字条件,线位置*1.01,'凹口平衡线'),COLORMAGENTA;{此行可省};
{=============大阴线实顶平衡线,加上去主图花了一些========================}
MA5:=MA(C,5);
平衡线:=(比前跌率>4 OR 本日跌率>4) AND C<MA5;{4可自己调为3-10}
STICKLINE(平衡线,O,O,45,-1),COLORGREEN;{画绿虚线};

通达信凹口平衡线主图指标公式

 

相关文章