在线检测未来函数

通达信永涛杀入分时主图指标公式

来源:Internet,编辑:股旁网,2017-12-18

昨开:REF(O,1),COLORWHITE,NODRAW;
昨高:REF(H,1),COLORRED,NODRAW;
昨低:REF(L,1),COLORGREEN,NODRAW;
昨收:REF(C,1),COLORYELLOW,NODRAW;
HIGHN:=10;LOWN:=10;HIGHDISPLAY:=0;LOWDISPLAY:=0;ZGDISPLAY:=0;MADISPLAY:=0;
AA:=REF(H,HIGHN)=HHV(H,2*HIGHN+1);
QY:=BACKSET(AA,HIGHN+1);
CC:=FILTER(QY,HIGHN) AND H=HHV(H,HIGHN+1);
DDD:=BARSLAST(CC);
GDTS:=IF(CC,CURRBARSCOUNT,0);
DINGBU:=IF(DDD,REF(H,DDD),H);{顶部}
DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);
DINGBU1:=REF(DINGBU,DDD+1);
GDCS1:=CONST(DINGBUTS);
DINGBUTS1:=REF(DINGBUTS,DDD+1);
GDCS2:=CONST(DINGBUTS1);
DINGBU2:=REF(DINGBU1,DDD+1);
MM:=IF(CURRBARSCOUNT>GDCS2,0,1);
高点压力:DRAWLINE(CURRBARSCOUNT=GDCS2,H,CURRBARSCOUNT=GDCS1,H,1) COLORGREEN,LINETHICK1;
DRAWLINE(CURRBARSCOUNT=GDCS2,H,ISLASTBAR,REF(H,GDCS2-1),1),COLORGRAY,DOTLINE;
AA1:=REF(L,LOWN)=LLV(L,2*LOWN+1);
QY1:=BACKSET(AA1,LOWN+1);
CC2:=FILTER(QY1,LOWN) AND L=LLV(L,LOWN+1);
DD1:=BARSLAST(CC2);
DDTS:=IF(CC2,CURRBARSCOUNT,0);
YDB:=IF(DD1,REF(L,DD1),L);
DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);
DDCS1:=CONST(DDTS1);
ZDB:=REF(YDB,DD1+1);
DDTS2:=REF(DDTS1,DD1+1);
DDCS2:=CONST(DDTS2);
低点支撑:DRAWLINE(CURRBARSCOUNT=DDCS2,L,CURRBARSCOUNT=DDCS1,L,1) COLORLIBLUE,LINETHICK1;
ZGSTAR:=(高点压力+低点支撑)/2;
ZGEND:=CONST((高点压力+低点支撑)/2);
STARDAY:=IF(DDCS2<GDCS2,DDCS2,GDCS2);
T:=BARSLAST(O=HHV(O,30) AND V=HHV(V,30));
HT:=BARSLAST(O=HHV(O,T+1));
HT1:=BARSLAST((O<REF(O,HT),HT) AND CROSS(HT>=30,0.5))NODRAW;
天量最高价:DRAWLINE(HT=0,REF(O,HT),HT1=0,REF(O,HT),1),DOTLINE,COLORWHITE;
TT:=BARSLAST(CROSS(天量最高价>=0,0.5));
XG:=COUNT(CROSS(C>=天量最高价,0.5),TT+1)=1 AND CROSS(C>=天量最高价,0.5);
VAR14:=EMA(EMA(CLOSE,9),9);
主力:=(VAR14-REF(VAR14,1))/REF(VAR14,1)*1000;
开始进场:=CROSS(主力,0);
无庄:=主力<0;
有庄:=主力>REF(主力,1) AND 主力>0;
VAR15:=100*WINNER(CLOSE*0.95);
强庄:VAR15>50 AND COST(85)<CLOSE AND 主力>0,COLORYELLOW,NODRAW;
DRAWTEXT(强庄,MA(C,13),'*'),COLORYELLOW,LINETHICK4;
VAR1:=DYNAINFO(3);
VAR2:=DYNAINFO(5);
VAR3:=DYNAINFO(6);
VAR4:MA(REF(HHV(C,30),1),2)NODRAW;
VAR5:MA(REF(LLV(C,30),1),2)NODRAW;
VAR6:=MAX(VAR1,VAR2);
VAR7:=MIN(VAR1,VAR3);
VAR8:=VAR6-VAR7;
VAR9:=VAR7+VAR8*0.875;
VAR10:=VAR7+VAR8*0.0625;
VAR11:=CROSS(VAR10,C);
VAR12:=LONGCROSS(VAR10,C,2);
VAR13:=LONGCROSS(C,VAR9,2);
DRAWICON(VAR12,VAR10,41);
DRAWICON(VAR13,VAR9,8);
DYNAINFO(3)*1.02;

通达信永涛杀入分时主图指标公式

 

相关文章