在线检测未来函数

通达信永涛MACD指标公式

来源:Internet,编辑:股旁网,2017-12-25

_红柱:IF("MACD.MACD">REF("MACD.MACD",1),"MACD.MACD",DRAWNULL),
STICK,COLOR000080 LINETHICK7;
绿柱:IF("MACD.MACD"<REF("MACD.MACD",1),"MACD.MACD",DRAWNULL),
STICK,COLORGREEN LINETHICK4;
VAR1:=EMA(EMA(CLOSE,9),9);
控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*100;
STICKLINE(控盘<0,控盘,0,0.000005,0),COLORWHITE;
A10:=CROSS(控盘,0);
无庄控盘:IF(控盘<0,控盘,0),COLORWHITE,NODRAW;
STICKLINE(控盘>REF(控盘,1) AND 控盘>0,控盘,0,1,0),COLORLIMAGENTA;
有庄控盘:IF(控盘>REF(控盘,1) AND 控盘>0,控盘,0),COLORRED,NODRAW;
VAR2:=100*WINNER(CLOSE*0.95);
STICKLINE(VAR2>50 AND COST(85)<CLOSE AND 控盘>0,控盘,0,1,0),COLORFF00FF;
高度控盘:IF(VAR2>50 AND COST(85)<CLOSE AND 控盘>0,控盘,0),COLORFF00FF,NODRAW;
STICKLINE(控盘<REF(控盘,1) AND 控盘>0,控盘,0,1,0),COLORLIGREEN;
主力出货:IF(控盘<REF(控盘,1) AND 控盘>0,控盘,0),COLOR00FF00,NODRAW;
DIFF:EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:EMA(DIFF,9);
MACD:2*(DIFF-DEA),COLORSTICK;
DRAWICON(CROSS(DIFF,DEA),DIFF,1);
DRAWICON(CROSS(DEA,DIFF),DIFF,2);
PJGJ:=AMOUNT/VOL/0;
SSRYDJX:=MA(PJGJ,13);
SSRCJL:=EMA(VOL,13);
SSRCJE:=EMA(AMOUNT,13);
SSRCBJX:=SSRCJE/SSRCJL/100;
CYS13:=(CLOSE-SSRCBJX)/SSRCBJX*100;
XYSHSL:=EMA(VOL/CAPITAL*100,13);
STICKLINE(XYSHSL>6.1 AND CYS13>5 ,2 ,0 ,2,0 ),COLORGREEN;
STICKLINE(XYSHSL>3.8 AND CYS13>5 ,1.5 ,0 ,2 ,0 ),COLORYELLOW;
STICKLINE(XYSHSL>2.1 AND CYS13>5 ,1 ,0 ,2 ,0 ),COLORCYAN;
STICKLINE(XYSHSL>1.8 AND CYS13>5 ,0.5 ,0 ,2 ,0 ),COLORBLUE;
AA:=RANGE(MA(C,5) ,O,C)+RANGE(MA(C,8) ,O,C)+RANGE(MA(C,13) ,O,C)+RANGE(MA(C,21) ,O,C)
+RANGE(MA(C,34) ,O,C)+RANGE(MA(C,55) ,O,C)+RANGE(MA(C,89) ,O,C);
AAA:=IF(CURRBARSCOUNT=1,VOL*240/FROMOPEN/REF(VOL,1)-1,VOL/REF(VOL,1)-1);
AA>=3 AND AAA>=1;
AA>=3 AND AAA>=1;
DY:=C>1.02*REF(C,1) ;
DYI:=(C-REF(C,1))/REF(C,1)*100<-6 ;
YYIC:=REF(C,1)>(REF(C,BARSLAST(DY))+REF(C,BARSLAST(DY)+1))/2 AND C<(REF(C,BARSLAST(DY))+REF(C,BARSLAST(DY)+1))/2;
YIYC:=REF(C,1)<(REF(C,BARSLAST(DYI))+REF(C,BARSLAST(DYI)+1))/2 AND C>(REF(C,BARSLAST(DYI))+REF(C,BARSLAST(DYI)+1))/2;
永涛价异动:BARSLAST(DYI)<=7 AND DY AND YIYC AND COUNT(DY,BARSLAST(DYI))=1 AND NOT(H=L) AND REF(NOT(H=L),BARSLAST(DYI))=1;
MA3:=MA(C,3);
MA5:=MA(C,5);
停牌:=(DYNAINFO(4)=0);
AA1:=ATAN((MA3/REF(MA3,1)-1)*100)*57.3>60;
BB:=ATAN((MA5/REF(MA5,1)-1)*100)*57.3>50;
上穿1:=CROSS(MA(C,3),MA(C,55)) AND CROSS(MA(C,3),MA(C,60));
上穿2:=CROSS(MA(C,3),MA(C,55)) AND CROSS(MA(C,3),MA(C,50));
上穿3:=CROSS(MA(C,3),MA(C,50)) AND CROSS(MA(C,3),MA(C,60));
上穿4:=CROSS(MA(C,3),MA(C,50)) OR CROSS(MA(C,3),MA(C,55)) OR CROSS(MA(C,3),MA(C,60));
上穿5:=上穿1 OR 上穿2 OR 上穿3;
井字1:=上穿5 AND AA1;
井字2:=上穿4 AND AA1 AND BB;
井字:=井字1 OR 井字2;
三号:井字 AND NOT(停牌) AND CLOSE>OPEN;

通达信永涛MACD指标公式

 

相关文章