在线检测未来函数

通达信顾比2018主图指标公式

来源:Internet,编辑:股旁网,2017-12-26

ZA:=EMA(CLOSE,90);
ZB:=EMA(CLOSE,105);
ZC:=EMA(CLOSE,120);
ZD:=EMA(CLOSE,132);
ZE:=EMA(CLOSE,144);
NOTEXT1:ZA,COLORWHITE;
NOTEXT2:ZB,COLORWHITE;
NOTEXT3:ZC,COLORWHITE;
NOTEXT4:ZD,COLORWHITE;
NOTEXT5:ZE,COLORWHITE;
DA:=EMA(CLOSE,3);NOTEXT6:DA,COLORBLUE;
DB:=EMA(CLOSE,5) ;NOTEXT7:DB,COLORBLUE;
DC:=EMA(CLOSE,8) ;NOTEXT8:DC,COLORBLUE;
DD:=EMA(CLOSE,10);NOTEXT9:DD,COLORBLUE;
DE:=EMA(CLOSE,12);NOTEXT10:DE,COLORBLUE;
DF:=EMA(CLOSE,15);NOTEXT11:DF,COLORBLUE;
CA:=EMA(CLOSE,30);NOTEXT12:CA,COLORYELLOW;
CB:=EMA(CLOSE,35);NOTEXT13:CB,COLORYELLOW;
CC:=EMA(CLOSE,40);NOTEXT14:CC,COLORYELLOW;
CD:=EMA(CLOSE,45);NOTEXT15:CD,COLORYELLOW;
CE:=EMA(CLOSE,50);NOTEXT16:CD,COLORYELLOW;
CF:=EMA(CLOSE,60);NOTEXT17:CF,COLORYELLOW;
CDYX:=CA>CB AND CB>CC AND CC>CD AND CD>CE AND CE>CF;
CKYX:=CA<CB AND CB<CC AND CC<CD AND CD<CE AND CE<CF;
DDYX:=DA>DB AND DB>DC AND DC>DD AND DD>DE AND DE>DF;
DKYX:=CA<CB AND DB<DC AND DC<DD AND DD<DE AND DE<DF;
NOTEXT18:IF(CDYX,CA,DRAWNULL),COLORBROWN;
NOTEXT19:IF(CDYX,CB,DRAWNULL),COLORBROWN;
NOTEXT20:IF(CDYX,CC,DRAWNULL),COLORBROWN;
NOTEXT21:IF(CDYX,CD,DRAWNULL),COLORBROWN;
NOTEXT22:IF(CDYX,CE,DRAWNULL),COLORBROWN;
NOTEXT23:IF(CDYX,CF,DRAWNULL),COLORBROWN;
NOTEXT24:IF(CKYX,CA,DRAWNULL),COLORCYAN;
NOTEXT25:IF(CKYX,CB,DRAWNULL),COLORCYAN;
NOTEXT26:IF(CKYX,CC,DRAWNULL),COLORCYAN;
NOTEXT27:IF(CKYX,CD,DRAWNULL),COLORCYAN;
NOTEXT28:IF(CKYX,CE,DRAWNULL),COLORCYAN;
NOTEXT29:IF(CKYX,CF,DRAWNULL),COLORCYAN;
NOTEXT30:IF(DDYX,DA,DRAWNULL),COLORRED;
NOTEXT31:IF(DDYX,DB,DRAWNULL),COLORRED;
NOTEXT32:IF(DDYX,DC,DRAWNULL),COLORRED;
NOTEXT33:IF(DDYX,DD,DRAWNULL),COLORRED;
NOTEXT34:IF(DDYX,DE,DRAWNULL),COLORRED;
NOTEXT35:IF(DDYX,DF,DRAWNULL),COLORRED;
NOTEXT36:IF(DKYX,DA,DRAWNULL),COLORGREEN;
NOTEXT37:IF(DKYX,DB,DRAWNULL),COLORGREEN;
NOTEXT38:IF(DKYX,DC,DRAWNULL),COLORGREEN;
NOTEXT39:IF(DKYX,DD,DRAWNULL),COLORGREEN;
NOTEXT40:IF(DKYX,DE,DRAWNULL),COLORGREEN;
NOTEXT41:IF(DKYX,DF,DRAWNULL),COLORGREEN;
A23:=((C + L) + H) / 3;
A24:=EMA(A23,6);
A25:=EMA(A24,5);
A26:=CROSS(A24,A25) AND C>MA(C,55);
DRAWICON(A26,(LOW / 1.015),26),LINETHICK2,COLORMAGENTA;
A1:=DATE <= 13181231;
工作线:(EMA(C,14)),POINTDOT,LINETHICK4,COLORYELLOW;
P:=21;
WH1:=IF(L=LLV(L,P),L,DRAWNULL);
WH2:=CONST(BARSLAST(WH1!=DRAWNULL));
WH3:=CONST(IF(WH2=0,H,REF(H,WH2)));
WH4:=CONST(REF(BARSLAST(H>WH3),WH2+1)+WH2+1);
WH5:=CONST(IF(WH4=0,H,REF(H,WH4)));
WH6:=CONST(REF(BARSLAST(H>WH5),WH4+1)+WH4+1);
进场:IF(CURRBARSCOUNT<=WH2+21,CONST(IF(WH6=0,H,REF(H,WH6))),DRAWNULL),COLORRED;
IF(CURRBARSCOUNT<=WH2+1,IF(L=LLV(L,P),L,DRAWNULL),DRAWNULL),CIRCLEDOT,COLORRED;
DRAWTEXT(CURRBARSCOUNT=INTPART((WH2+21)*0.618),进场,'进场线'),COLORRED;
超跌进场:IF(CURRBARSCOUNT<=WH2+21,CONST(IF(WH4=0,H,REF(H,WH4))),DRAWNULL),COLORCB21BE;
DRAWTEXT(CURRBARSCOUNT=INTPART((WH2+21)*0.618),超跌进场,'超跌进场线'),COLORCB21BE;
H1:=IF(H=HHV(H,P),H,DRAWNULL);
H2:=CONST(BARSLAST(H1!=DRAWNULL));
H3:=CONST(IF(H2=0,L,REF(L,H2)));
H4:=CONST(REF(BARSLAST(L<H3),H2+1)+H2+1);
H5:=CONST(IF(H4=0,L,REF(L,H4)));
H6:=CONST(REF(BARSLAST(L<H5),H4+1)+H4+1);
DK:=(MA(CLOSE, 5)+MA(CLOSE, 10)+MA(CLOSE, 13)+MA(CLOSE, 21))/4;
IF(DK<=REF(DK,1),DK,DRAWNULL),COLORGREEN,LINETHICK3;
IF(DK>REF(DK,1),DK,DRAWNULL),COLORRED,LINETHICK3;
多空:DK,NODRAW;
总股本:=FINANCE(1)/100000000;
流通股本:=FINANCE(7)/100000000;
未流通比:=(总股本-流通股本)/总股本*100;
现价:=C;
全流通后价:=C*流通股本/总股本;
解禁股:=IF((流通股本-REF(流通股本,1))>0,(流通股本-REF(流通股本,1)),0),COLORYELLOW;{流通股增加}
DRAWTEXT(解禁股>0, L,'解禁'),COLORYELLOW;
冻结:IF((流通股本-REF(流通股本,1))<0,(REF(流通股本,1)-流通股本),0),COLORGREEN,NODRAW;{流通股减少};
上11:MA(C,55)+6.18*SMA(MAX(MAX(H-L,ABS(H-REF(C,1))),ABS(REF(C,1)-L)),17,1),COLORMAGENTA;
上22:MA(C,55)+3.82*SMA(MAX(MAX(H-L,ABS(H-REF(C,1))),ABS(REF(C,1)-L)),17,1),COLORYELLOW;
下11:MA(C,55)-3.82*SMA(MAX(MAX(H-L,ABS(H-REF(C,1))),ABS(REF(C,1)-L)),17,1),COLORYELLOW;
下22:MA(C,55)-6.18*SMA(MAX(MAX(H-L,ABS(H-REF(C,1))),ABS(REF(C,1)-L)),17,1),COLORMAGENTA;
中:MA(C,55),COLORRED,LINETHICK5;
IF(MA(C,55)<REF(MA(C,55),1),MA(C,55),DRAWNULL),COLORGREEN,LINETHICK5;

通达信顾比2018主图指标公式

 

相关文章