在线检测未来函数

通达信五行量化彩版指标公式

来源:Internet,编辑:股旁网,2017-12-28

X_1:=EMA(100*(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21)),13)/4;
X_2:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
X_3:=(X_2-LLV(X_2,21))/(HHV(X_2,21)-LLV(X_2,21))*4*25;
X_4:=CROSS(X_3,18);
X_5:=MA(CLOSE,20);
X_6:=CLOSE>MA(CLOSE,5);
X_7:=MA(CLOSE,5)>MA(CLOSE,10);
X_8:=CLOSE>MA(CLOSE,10);
X_9:=MA(CLOSE,5)>MA(CLOSE,20);
X_10:=CLOSE>MA(CLOSE,20);
X_11:=REF(X_5,1);
X_12:=X_5>X_11;
X_13:=IF(X_6,10,0-10)+IF(X_7,10,0-10)+IF(X_8,10,0-10)+IF(X_9,10,0-10)+IF(X_10,10,0-10)+IF(X_12,10,0-10);
X_14:=CLOSE>MA(LOW,20)*1.1;
X_15:=EMA(100*(1-WINNER(1.1*CLOSE)),1)=0;
X_16:=VOL*(CLOSE-OPEN)/(CLOSE+OPEN);
X_17:=EMA(VOL*(CLOSE-OPEN)/(CLOSE+OPEN),38);
X_18:=EMA(X_17,8);
X_19:=MA(X_18,3);
X_20:=MA(X_18,10);
X_21:=X_19>X_20 AND X_20>0;
X_22:=(MA(CLOSE,1)+MA(CLOSE,3)+MA(CLOSE,5)+MA(CLOSE,7)+MA(CLOSE,9))/5;
X_23:=(MA(CLOSE,2)+MA(CLOSE,4)+MA(CLOSE,6)+MA(CLOSE,8)+MA(CLOSE,10))/5;
X_24:=EMA(X_22,3);
X_25:=EMA(X_23,10);
X_26:=EMA(AMOUNT,1)/EMA(VOL,1)/100;
X_27:=DMA(X_24,X_26);
X_28:=DMA(X_25,X_26);
X_29:=MAX(2*(X_27-X_28),0)*100;
X_30:=X_29>0 AND X_29>REF(X_29,1);
STICKLINE(CLOSE,0,1,4,1),COLORGRAY;
STICKLINE(CLOSE,0,0.8,4,1),COLORGRAY;
STICKLINE(CLOSE,0,0.6,4,1),COLORGRAY;
STICKLINE(CLOSE,0,0.4,4,1),COLORGRAY;
STICKLINE(CLOSE,0,0.2,4,1),COLORGRAY;
X_31:=X_14>0 AND X_30>0 AND X_21>0 AND X_13=60 AND X_1>10;
DRAWICON(X_14>0,1,41);
DRAWICON(X_30>0,0.7,30);
DRAWICON(X_4>0,0.7,28);
DRAWICON(X_21>0,0.5,40);
DRAWICON(X_13=60,0.3,1);
DRAWICON(X_1>10,0.1,38);

通达信五行量化彩版指标公式

 

相关文章