在线检测未来函数

通达信买卖点大荟萃指标公式

来源:Internet,编辑:股旁网,2018-01-01

DRAWGBK(CURRBARSCOUNT=1, RGB(110,108,108),RGB(88,30,0),0,'',0);
VAR1:=REF(CLOSE,1);
VAR22:=SMA(MAX(CLOSE-VAR1,0),7,1)/SMA(ABS(CLOSE-VAR1),7,1)*100;
反弹底:FILTER(REF(VAR22,1)<20 AND VAR22>REF(VAR22,1),5)NODRAW;
STICKLINE(反弹底>0,2,反弹底,3,0),COLOR000099;
STICKLINE(反弹底>0,2,反弹底,2,0),COLOR0000BB;
STICKLINE(反弹底>0,2,反弹底,1,0),COLOR0000DD;
STICKLINE(反弹底>0,2,反弹底,0.2,0),COLOR0000FF;
DRAWICON(反弹底,0.5,18);
DRAWICON(反弹底,0.8,1);
{拉升也许涨停}
ZT1:=(C-LLV(L,14))/(HHV(H,14)-LLV(L,14))*100;
ZT2:=INTPART(SMA(ZT1,3,1));
ZT3:=INTPART(SMA(ZT2,3,1));
ZT4:=ZT2+ZT3;
ZT5:=MA(ZT4,2);
ZT6:=COUNT("MACD.MACD"<0,15)>=13;
ZTR:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
ZTK:=SMA(ZTR,3,1);
ZTD:=SMA(ZTK,3,1);
ZTJ:=3*ZTK-2*ZTD;
见底:IF(ZT6 AND CROSS(ZT4,ZT5) AND ZT4<50,1.5,0),COLORBROWN,NODRAW;
DRAWTEXT(见底>0,1,'见底'),COLORFF8080;
DRAWTEXT(见底>0,0.6,'见底'),COLORFF8080;
DRAWTEXT(见底>0,0.3,'见底'),COLORRED;
拉升也许涨停:IF(CROSS(ZT4,80) AND ZTJ>=REF(ZTJ,1),1,0),COLORRED,NODRAW;
DRAWICON(拉升也许涨停,1,25);
DRAWICON(拉升也许涨停,0.6,25);
DRAWICON(拉升也许涨停,0.3,25);
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
TT:=BARSLAST(DIF<0);
MACD零轴上金叉:SUM(CROSS(MACD,0),TT)=1 AND TT>0 AND CROSS(MACD,0)NODRAW;
STICKLINE(MACD零轴上金叉,1.5,0,3,0),COLOR555555;
STICKLINE(MACD零轴上金叉,1.5,0,2,0),COLOR777777;
STICKLINE(MACD零轴上金叉,1.5,0,1,0),COLOR999999;
STICKLINE(MACD零轴上金叉,1.5,0,0,0),COLOR999999;
DRAWICON(MACD零轴上金叉,1.4,29);
DRAWICON(MACD零轴上金叉,0.9,29);
黑马:"KDJ.J"-REF("KDJ.J",1)>30 AND C/REF(C,1)>1.043 AND "MACD.MACD">0
AND "MACD.DEA">0,COLORYELLOW,NODRAW;
STICKLINE(黑马,2,0,3,0),COLOR0099FF;
STICKLINE(黑马,2,0,2,0),COLOR00BBFF;
STICKLINE(黑马,2,0,1,0),COLOR00DDFF;
STICKLINE(黑马,2,0,0,0),COLOR00FFFF;
DRAWICON(黑马,1.7,1);
DRAWICON(黑马,1.1,24);
DRAWICON(黑马,0.6,1);
{组合}
LC:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),14,1)/SMA(ABS(CLOSE-LC),14,1)*100;
RSI2:=SMA(MAX(CLOSE-LC,0),60,1)/SMA(ABS(CLOSE-LC),60,1)*100;
强:=50;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
AAA:=EMA(CLOSE,8)-EMA(CLOSE,13);
BBB:=EMA(AAA,3);
组合:RSI1>强 AND RSI2>强 AND BARSLAST(CROSS(BB,AAA))<=21 AND CROSS(AAA,BB) OR
RSI1>强 AND RSI2>强 AND CROSS(K,D) AND J>=REF(J,1) NODRAW;
DRAWICON(组合,0.2,22);
DRAWICON(组合,0.5,22);
{头部}
UP:=( C > O OR C > REF(C,1)) AND V > REF(V,1);
AA:=COUNT(UP,3)=3;
BB:=LLV(L,5)=LLV(L,120);
CC:=C > MA(C,3);
LLT:=AA AND BB AND CC;
V1:=LLV(LOW,10);
V2:=HHV(H,25);
短线卖出:3.2,LINETHICK1,COLOR80FF80;
高位卖出:3.5,LINETHICK2,COLORRED;
价位线:EMA((C-V1)/(V2-V1)*4,4)COLOR008080,LINETHICK1;
STICKLINE(价位线>=3.2,3.2,(价位线*0.98),5,0),COLOR0000BB;
STICKLINE(价位线<0.3,0.3,价位线-0.05,5,0),COLORFFFFFF;
M5:=MA(价位线,5),LINETHICK2;
金山:LLT,LINETHICK1,COLORGREEN,LINETHICK2;
超卖区域:0.3,COLORFF8080,DOTLINE;
VAR2:=IF(EMA(CLOSE,5)/EMA(EMA(CLOSE,9),16)<=0.85 AND CLOSE/REF(CLOSE,1)>0.905 AND CLOSE/REF(CLOSE,1)<1.05 AND VOL/CAPITAL*100<5,50,0);
VAR3:=(-100)*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34))+100;
VAR4:=(-100)*(HHV(HIGH,50)-CLOSE)/(HHV(HIGH,50)-LLV(LOW,50))+100;
VAR5:=(-100)*(HHV(HIGH,70)-CLOSE)/(HHV(HIGH,70)-LLV(LOW,70))+100;
VAR6:=((CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100+10)*5;
VAR7:=((CLOSE-MA(CLOSE,50))/MA(CLOSE,50)*100+10)*5;
VAR8:=((CLOSE-MA(CLOSE,70))/MA(CLOSE,70)*100+10)*5;
VAR9:=(VAR3+VAR4+VAR5+VAR6+VAR7+VAR8)/6;
VARA:=EMA(VAR9,3);
VARB:=ABS(VAR6-VAR8);
VARC:=(VAR9+VARB)/2;
VARD:=(-1)*(EMA(100*(1-WINNER(CLOSE)),1)-50)+50;
VARE:=VARD+VARC;
VARF:=IF(VAR2>0 AND VARE<0,200,0);
VAR10:=IF(VARC<0 AND CLOSE=LLV(CLOSE,5) AND CLOSE/REF(CLOSE,1)>0.905 AND CLOSE/REF(CLOSE,1)<1.05 AND VOL/CAPITAL*100<5,-50,0);
VAR11:=IF(VARE<0 AND VAR10=-50,100,0);
VAR12:=MA(CLOSE,3);
VAR13:=REF(CLOSE,2)*0.865;
VAR14:=REF(CLOSE,13)*0.772;
VAR15:=MIN(VAR13,VAR14);
VAR16:=100*VOL/CAPITAL;
VAR17:=MA(CLOSE,13);
VAR18:=IF((CLOSE-VAR15)/CLOSE<0.03 AND SUM(VAR16,5)/5<1.8,1,0);
VAR19:=IF(VAR18>0 AND (VAR10<0 OR VAR2>0),100,0);
VAR1A:=VAR19;
VAR1B:=IF(VARF>0 AND VAR11>0 AND SUM(VOL/CAPITAL*100,5)/5<1 OR VAR18>0 AND REF(CLOSE,1)/REF(CLOSE,2)>0.902 OR (VARF>0 AND VAR11>0 AND SUM(VOL/CAPITAL*100,5)/5<1 OR VAR18>0) AND (VAR10<0 OR VAR2>0) AND VAR19<10,50,0);
VAR1C:=(VARF>0 AND VAR11>0 AND SUM(VOL/CAPITAL*100,5)/5<1 OR VAR18>0) AND (VAR10<0 OR VAR2>0);
VAR1D:=VARF>0 AND VAR11>0 AND SUM(VOL/CAPITAL*100,5)/5<1 OR VAR18>0 AND REF(CLOSE,1)/REF(CLOSE,2)>0.902;
大底区域 : ( VAR1C OR VAR1D )*2,LINETHICK2,COLORRED;
DRAWTEXT(大底区域>0,1.4,'大底区域'),COLORYELLOW,;

通达信买卖点大荟萃指标公式

 

相关文章