在线检测未来函数

通达信飞鸟和鱼主图指标公式

来源:Internet,编辑:股旁网,2018-01-08

DRAWBAND(SMA(SMA(SMA(MA(C,1),2,1),2,1),2,1),RGB(499,833,110),HHV(MA(SMA(SMA(SMA(MA(C,1),2,1),2,1),2,1),1),13),RGB(800,160,150));
飞鸟:HHV(MA(SMA(SMA(SMA(MA(C,1),2,1),2,1),2,1),1),13),COLOR00AAFF
,LINETHICK4;
跑道:=EMA(((SLOPE(CLOSE,21) * 20) + CLOSE),42)COLORCC60FF,LINETHICK3;
DRAWKLINE(H,O,L,C);
BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4,
COLORLICYAN,LINETHICK1;
YC:=FORCAST((C+L+H)/3,5);
上:=BBI+3*STD(BBI,10),COLORLIBLUE,LINETHICK1,POINTDOT;
下:=BBI-3*STD(BBI,10),COLORLIBLUE,LINETHICK1,POINTDOT;{COLORAACC66}
{DRAWBAND(上,RGB(780,100,120),下,RGB(00,00,00));DRAWKLINE(H,O,L,C);}
中:=BBI,COLORLICYAN,LINETHICK1;
惹1:=MA(C,13),COLORFFCC66,LINETHICK1;
AAA:=(3*C+H+L+O)/6;
VAR155:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36;
VAR255:=(HHV(VAR155,5)+HHV(VAR155,10)+HHV(VAR155,20))/3;
VAR355:=(LLV(VAR155,5)+LLV(VAR155,10)+LLV(VAR155,20))/3;
VAR455:=(HHV(VAR255,5)+HHV(VAR255,10)+HHV(VAR255,20))/3;
VAR555:=(LLV(VAR355,5)+LLV(VAR355,10)+LLV(VAR355,20))/3;
VAR655:=(LLV(VAR155,2)+LLV(VAR155,4)+LLV(VAR155,6))/3;
短线:=VAR155,COLORWHITE;
MA110:=MA(CLOSE,10),COLORYELLOW;
绿降:=(46.18*EMA(CLOSE,10)-31.82*EMA(CLOSE,4))/14.36,COLORGREEN,LINETHICK1;
VAR1:=VOL*(O+C)/2;
生命线:=SUM(VAR1,7)/SUM(VOL,7),COLORFF00FF,LINETHICK1;
MW:=17;FL:=MA(CLOSE,MW)+ABS(MA(CLOSE,MW)-REF(MA(CLOSE,MW),1)),COLORRED;
FS:=MA(CLOSE,MW)+MA(CLOSE,MW)-REF(MA(CLOSE,MW),1),COLORGREEN,LINETHICK2;
分水岭:=IF(MA(CLOSE,MW)<FS,FS,MA(CLOSE,MW)),COLORLIBLUE,LINETHICK1,;
界:=分水岭-(EMA(C,3)-分水岭),COLOR3571FF,LINETHICK1;
筹码密集:=HHV(MA(H,13),13),COLORRED,LINETHICK1;
TLAMSENR:=MAX(MAX((HIGH-LOW),ABS((REF(CLOSE,1)-HIGH))),ABS((REF(CLOSE,1)-LOW)));
ATR:=MA(TLAMSENR,13);VAR11A:=(REF(CLOSE,1)-REF(ATR,1));
多:=(HHV(VAR11A,12)),LINETHICK1,COLOR0099FF;{COLOR0080FF}
N:=20;
MB:=MA(C,N);
R:=C-MB;
X1:=MA(R*R,N);
X:=SQRT(X1);
M5:=MA(C,5),COLORWHITE,LINETHICK1;
M10:=MA(C,10),COLORLICYAN,LINETHICK1;
M20:MA(C,20),COLORLIGRAY,LINETHICK2;{COLOR9D7DE2}
M26:=MA(C,30),COLOR855E42,LINETHICK1;
M60:=MA(C,60),COLORLIGREEN,LINETHICK1;
M120:=MA(C,120),COLORLIGRAY,LINETHICK1;
RSV:=(CLOSE-LLV(LOW,12))/(HHV(HIGH,12)-LLV(LOW,12))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
RSV24:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
K24:=SMA(RSV24,3,1);
D24:=SMA(K24,3,1);
J24:=3*K24-2*D24;
压力:IF(CROSS(J24,J),H,REF(H,BARSLAST(CROSS(J24,J)))),COLORWHITE,POINTDOT,LINETHICK4;
支撑:IF(CROSS(J,J24),L,REF(L,BARSLAST(CROSS(J,J24)))),COLORLIBLUE,POINTDOT,LINETHICK4;
压力位:=IF(CROSS(J24,J),H,REF(H,BARSLAST(CROSS(J24,J)))),COLORLIGRAY,POINTDOT,LINETHICK4;
支撑位:=IF(CROSS(J,J24),L,REF(L,BARSLAST(CROSS(J,J24)))),COLORLIRED,POINTDOT,LINETHICK4;
XS:=MA(LOW,5)*(1-5/100),COLORLIRED;
XS1:=MA(HIGH,5)*(1+5/100),COLORLIRED;
VARR199:=SMA(MAX(CLOSE-REF(C,1),0),5,1)/SMA(ABS(CLOSE-REF(C,1)),5,1)*100;
{STICKLINE(CROSS(82,VARR199),MIN(C,O),MAX(C,O),2.5,0),COLORBLUE;}
STICKLINE(CROSS(XS1,C),MAX(C,O),(MAX(C,O)*1+MIN(O,C)*1)/2,2.5,0),COLORWHITE;
AA:=REF(CLOSE,1);
BBB:=SMA(MAX(CLOSE-AA,0),5,1)/SMA(ABS(CLOSE-AA),5,1)*1000;
HHH:=BBB-LLV(BBB,10);
SS:=(MA(HHH,2)*3+HHH*13)/16;
短线买点:=IF(SS>13,MA(SS,2),SS);
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
卖:=HHV(DX,2)=HHV(DX,7) AND COUNT(DX>50,2) AND CROSS(MA(DX,2),DX);
{DRAWTEXT(FILTER(卖=1,1),HIGH*1.01,'卖'),COLORGREEN;}
买:=LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2));
{RSI出击买点}
AA1:="RSI.RSI1"(3,14,24),LINETHICK1,COLOR6295D6;
BB1:=REF("RSI.RSI1"(3,14,24),1),LINETHICK1,COLORFF9800;
JJJJ:=STICKLINE((AA1-BB1)/BB1>13/10,O,C,2.5,0),COLORYELLOW;
{STICKLINE(FILTER(买=1,5),O,C,1,0),COLOR0000FF;}
{彩色K线}
F33:=100*(C-REF(C,1))/REF(C,1);
今小昨:=IF(C<REF(O,1) AND F33<0,1,0);
P133:=今小昨;
今小前:=IF(C<REF(O,2) AND F33<0,1,0);
P233:=今小前;
长压:=HHV(FORCAST(C,10),17)COLORCAF0D4;{COLOR0099FF}
短压:=HHV(FORCAST(C,10),8),COLORFF9933;
生命:=FORCAST(C,10),COLOR0099FF;{COLOR0099FF}{COLORA8C300}{COLORAAAA00}
买入:=IF(生命>REF(生命,1) AND COUNT(生命>REF(生命,1),2)=1,生命,DRAWNULL),COLORFF00FF,CIRCLEDOT,LINETHICK2;
加仓:=IF(短压=生命,生命,DRAWNULL),COLORYELLOW,LINETHICK2;
持股:=IF(长压=短压 AND 短压=生命,M60,DRAWNULL),COLOR5756FF,LINETHICK1;{COLOR5BD1F1}{COLOR5BD1D4}
赢在龙头:=(L+H+C*4)/6;
工作:=EMA(赢在龙头,12),COLOR00FF00;
度假:=EMA(赢在龙头,19);
赢在:=(工作-REF(工作,1))/REF(工作,1)*100;
龙头:=(度假-REF(度假,1))/REF(度假,1)*100;
G:=BARSLAST(CROSS(赢在,0));
龙:=REF(赢在龙头,G),COLOR00F0D4,LINETHICK1;{COLORCAF0D4}
V1:=DMA((HIGH+LOW+CLOSE+CLOSE)/4.15,0.9);
HY1:=REF(EMA(V1,3),1);
趋:=EMA(3*YC-2*SMA(YC,2,1),15),COLORFFCC66,LINETHICK1;
{中3:=DMA(CLOSE,VOL/SUM(VOL,13));
上3:=DMA(CLOSE,VOL/SUM(VOL,13))+3*STD(BBI,10),COLORFFCC66;
下3:=DMA(CLOSE,VOL/SUM(VOL,13))-3*STD(BBI,10),COLORFFCC66;};
AA999:=STICKLINE(1,REF(C,BARSLAST(V=HHV(V,20))),
REF(C,BARSLAST(V=HHV(V,20))),1,1),COLORLIRED;
HM1:= MA((REF(HIGH,2)+REF(LOW,2))/2,2),COLOR70DB93;
HM2:=LLV(MA((REF(HIGH,2)+REF(LOW,2))/2,2),3),COLORLIGRAY;
MB77:=MA(C,20);
R77:=C-MB77;
X177:=MA(R77*R77,20);
X77:=SQRT(X177);
上2:=MB77+1.96*X77,COLORGRAY,LINETHICK1,CROSSDOT;
下2:=MB77-1.96*X77,COLORGRAY,LINETHICK1,CROSSDOT;
上1:=MA(C,20)+2*STD(CLOSE,20)CROSSDOT,COLORAACC66,LINETHICK1;{COLORA8C300}
下1:=MA(C,20)-2*STD(CLOSE,20)CROSSDOT,COLORA8C300,LINETHICK1;
均价:=(3*C+H+L+O)/6;
VAR199:=(8*均价+7*REF(均价,1)+6*REF(均价,2)+5*REF(均价,3)+4*REF(均价,4)+3*REF(均价,5)+2*REF(均价,6)+REF(均价,8))/36;
趋势:=(LLV(VAR199,2)+LLV(VAR199,4)+LLV(VAR199,6))/3,LINETHICK1,COLORYELLOW;
MA6:=MA(CLOSE,6);
MA18:=MA(CLOSE,18);
MA3:=(3)*(MA18) - (2)*(MA6),LINETHICK1,COLORD39D91;{COLOR3571FF}{COLORD39D91}
MA4:=(3)*(MA6) - (2)*(MA18),LINETHICK2,COLOR87B08B;
M1:=SUM((EMA((CLOSE + LOW)/(2),2))/(2.98),3),POINTDOT,COLORFFFFFF;
M2:=EMA(M1,21),COLORFF00FF;
M30:=MA(CLOSE,30),LINETHICK1,COLORFF0000;
VAR166:=(2)*(MA((LLV((CLOSE + LOW)/(2),8))*(1.1),13)) - EMA((CLOSE + LOW)/(2),3) - ((CLOSE + LOW)/(2))*(0.1);
VAR266:=IF(((EMA((CLOSE + LOW)/(2),3) - VAR166)*(5) > 0),(POW((EMA((CLOSE + LOW)/(2),3) - VAR166)*(5),2))/(10),(((-1))*(POW((EMA((CLOSE + LOW)/(2),3) - VAR166)*(5),2)))/(10));
VAR366:=IF((VAR266 > 0),VAR266 - 0,(-1));
{DRAWICON(CROSS(VAR366,0) AND ((CLOSE + LOW)/(2) > MA((CLOSE + LOW)/(2),8))
,下1,24),LINETHICK2,COLORYELLOW;}
VAR1HH:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR2HH:=REF(VAR1HH,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR3HH:=REF(VAR2HH,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4HH:=REF(VAR3HH,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR5HH:=REF(VAR4HH,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR6HH:=REF(VAR5HH,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR7HH:=REF(VAR6HH,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR8HH:=REF(VAR7HH,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR9HH:=REF(VAR8HH,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARAHH:=REF(VAR9HH,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARBHH:=REF(VARAHH,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARCHH:=REF(VARBHH,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
{STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR
VAR8 OR VAR9 OR VARA OR VARB OR VARC,CLOSE,REF(CLOSE,1),3,1),COLORRED;}{红1}
VARDHH:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
VAREHH:=REF(VARDHH,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARFHH:=REF(VAREHH,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR10HH:=REF(VARFHH,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR11HH:=REF(VAR10HH,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR12HH:=REF(VAR11HH,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR13HH:=REF(VAR12HH,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR14HH:=REF(VAR13HH,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR15HH:=REF(VAR14HH,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR16HH:=REF(VAR15HH,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR17HH:=REF(VAR16HH,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR18HH:=REF(VAR17HH,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR19HH:=REF(VARDHH OR VAREHH OR VARFHH OR VAR10HH OR VAR11HH
OR VAR12HH OR VAR13HH OR
VAR14HH OR VAR15HH OR VAR16HH OR VAR17HH OR VAR18HH,1) AND VAR1HH;
QQQQ:=IF(VAR19HH,下,DRAWNULL),COLORLICYAN,POINTDOT;
STICKLINE(CROSS(短线买点,21),(MAX(C,O)+MIN(O,C)*3)/4,(MAX(C,O)*3+MIN(O,C)*1)/4,2.5,0),COLORMAGENTA;
STICKLINE(P133=0 AND REF(P133,1)=1 AND P233=0 AND REF(P233,1)=1,(MAX(C,O)+MIN(O,C)*3)/4,MIN(C,O),2.5,0),COLORYELLOW;
{DRAWICON(CROSS(短线买点,21),L*1,9),COLORYELLOW;}
{DRAWICON(CROSS(C,界),L*1,1);};
MMM:DRAWICON(CROSS(CLOSE,HY1),L*1,1),COLORWHITE;
VAR121:=AMOUNT/VOL/7;
VAR221:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
VAR321:=SUM(AMOUNT,10)/VAR121/7;
VAR4:=DMA(VAR221,VOL/VAR321),LINETHICK1,COLORLICYAN;
换手动态移动:=DMA(C,(VOL/CAPITAL))COLORGREEN;
B1:=MA(C,1);
B2:=SMA(SMA(SMA(B1,2,1),2,1),2,1);
SMA2:=MA(B2,3);
停损下限:=IF(LLV(MA(B2,8),3)<B2,LLV(MA(B2,8),3),B2)COLORLIBLUE,LINETHICK1;
红色拿:IF(B2>SMA2,B2,DRAWNULL),COLORRED,LINETHICK2;

通达信飞鸟和鱼主图指标公式

 

相关文章