在线检测未来函数

通达信擒庄操盘主图指标公式

来源:Internet,编辑:股旁网,2018-01-08

N:=11;
P:=6;
P1:=8;
M:=2;
M1:=3;
{================背景 ================};
DRAWGBK(CURRBARSCOUNT=1 , RGB(0,0,0),RGB(0,0,0),0,'1',0);
{================妖股 ================};
ZT:=REF(C,1)*1.1-C<0.01 AND H=C;
CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
DD:=DMA(CLOSE,CC);
上:(1+7/100)*DD,COLORWHITE;
DRAWTEXT(ISLASTBAR,上,' ←加速线'),COLORWHITE ;
乖离涨停2:=O>上 AND ZT;
DRAWTEXT(乖离涨停2,L,'妖股'),NODRAW ;
{================5日30日线买入 ================};
AA05:MA(C,5),COLORWHITE ,NODRAW ;
五日乖离率:=(C-AA05)/AA05*100;
AA30:MA(C,30)COLORBLUE,NODRAW ;
三拾日乖离率:=(C-AA30)/AA30*100,LINETHICK0;
MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA05>REF(AA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<AA30;
买入:=FILTER(MR,10);
DRAWTEXT(买入,LOW*0.95,'买入'),COLORYELLOW;
BB05:=ATAN((AA05/REF(AA05,1)-1)*100)*180/3.1416;
速度5:=SMA(EMA((AA05-REF(AA05,1))/REF(AA05,1),3)*100,3,1);
加速度5:=EMA((速度5-REF(速度5,1)),3),LINETHICK0;
AA10:MA(C,10)COLORMAGENTA ,LINETHICK2,NODRAW;
加仓:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND AA05>REF(AA05,1) AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA10>REF(AA10,1)AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1) ,10);
DRAWTEXT(加仓,LOW*0.98,'↖加仓'),COLORRED;
飞天:MA(CLOSE,25)+MA(CLOSE,25)*20/100,COLORMAGENTA ,LINETHICK1;
DRAWTEXT(ISLASTBAR,飞天,' ←成妖线'),COLORMAGENTA;
{=================K线柱=================}
{红}
STICKLINE(C>O,C,O,1,0),COLORYELLOW ;
STICKLINE(C>O,H,L,0,0),COLORRED;
{绿}
STICKLINE(C<O,C,O,2,0),COLORCYAN;
STICKLINE(C<O,H,L,0,0),COLORCYAN;
{=================板块、行业、概念=================}
DRAWTEXT_FIX(C>0,0.0,0.0,0,STRCAT(' ---所属行业---:',HYBLOCK)),COLORFFFFFF;
DRAWTEXT_FIX(C>0,0.30,0.0,0,STRCAT(' ---所属地区---:',DYBLOCK)),COLORFFFFFF;
DRAWTEXT_FIX(C>0,0.30,0.1,0,STRCAT('-------=======横盘做T+0坚决莫贪=======--------:',GNBLOCK)),COLORCYAN;
DRAWTEXT_FIX(ISLASTBAR,0.20,0.90,0,ZSBLOCK),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.20,0.99,0,FGBLOCK),COLORYELLOW;
{=================多空布林=================}
C2:=REF(C,1);
涨停:=IF((C-C2)*100/C2>=(10-0.01*100/C2),1,0);
STICKLINE(涨停,OPEN,CLOSE,2,0),COLORYELLOW;
STICKLINE(涨停,H,L,0,0),COLORMAGENTA;
BBI:(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4,COLORBLACK,LINETHICK1;
UPR:BBI+P*STD(BBI,N),COLORCYAN,LINETHICK1;
DWN:BBI-P*STD(BBI,N),COLORBLUE ,NODRAW , ;
MA1:MA(CLOSE,P1),COLORRED,LINETHICK1;
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);
指导线: EMA((EMA(CLOSE,4)+EMA(CLOSE,6)+EMA(CLOSE,12)+EMA(CLOSE,24))/4,2),COLORYELLOW,LINETHICK1;
界: MA(CLOSE,27),COLORMAGENTA ,LINETHICK1;
BU:=CROSS(指导线,界);
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
AAA:=(DIF-DEA)*2;
ZT1:=C>=REF(C,1)*1.097 ;
起爆:=AAA>=2*REF(AAA,1) AND ZT1 AND ABS(AAA)<=1 AND C>MA(C,20) AND C<MA(C,20)*1.2 ;
DRAWTEXT(起爆,L*0.99,'↖暴涨'),COLORYELLOW,LINETHICK3;
VAR1:=EMA(EMA(EMA((CLOSE*6+LOW*2+HIGH+OPEN)/10,M),M),M);
短线:= VAR1-REF(VAR1,1)+VAR1;
中短:= MA(短线,M1);
DRAWTEXT(CROSS(短线,中短),(LOW * 0.995),'★'),COLORYELLOW,LINETHICK3;
{=================量柱=================}
TJ:=VOL>=REF(V,1)*1.91 AND C>REF(C,1)*1.01;
DRAWTEXT(TJ,LOW*1.1,'量'),COLORMAGENTA ;
STICKLINE(TJ,OPEN,CLOSE,2.2,2),COLORMAGENTA ;
K1:=SUMBARS(TJ,1);
{================走强线 ================};
HM1:=ABS(((3.48*CLOSE+HIGH+LOW)/4-EMA(CLOSE,20))/EMA(CLOSE,20));
HM2:=DMA(((2.15*CLOSE+LOW+HIGH)/4),HM1);
走强线:EMA(HM2,200)*1.118 ,LINETHICK1,COLORRED;
DRAWTEXT(ISLASTBAR,走强线,' ←走强线'),COLORRED;
{=================必升=================};
VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0);
VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.05) AND ((HIGH)/(CLOSE)<1.01) AND (VAR3AA>0),91,0);
DRAWTEXT(FILTER((VAR4AA>90),45),(LOW)*(0.90),'★波段开始 '),COLORMAGENTA;
DRAWTEXT(FILTER((VAR4AA>90),35),(LOW)*(0.8),'★强势拉升'),COLOR00FFFF;
{============操作线:分水岭================}
B:=MA(CLOSE,17)+MA(CLOSE,17)-REF(MA(CLOSE,17),1);
分水岭:IF(MA(CLOSE,17)<B,B,MA(CLOSE,17)),COLORFF00FF,NODRAW;
操作线:分水岭-(EMA(C,3)-分水岭),COLORGREEN ,LINETHICK1;
DRAWTEXT(ISLASTBAR,操作线,' ←拐点线'),COLORGREEN;
{========超级主升==========}
VAR4:=(((((REF(C,1)) * (1.1)) - C) < (0.01)) AND (H = C));
E5:(EMA(C,5)),LINETHICK0 ,COLORWHITE;
R:=(20 * H + 19 * (REF(H,1)) + 18 * (REF(H,2)) + 17 * (REF(H,3)));
R1:=16*(REF(H,4)) +15*(REF(H,5))+14 * (REF(H,6)) + 13 * (REF(H,7));
R2:=12*(REF(H,8))+11*(REF(H,9))+10 * (REF(H,10)) + 9 * (REF(H,11));
R3:=8 * (REF(H,12)) + 7 * (REF(H,13)) +6*(REF(H,14))+5*(REF(H,15));
R4:=4 * (REF(H,16)) + 3 * (REF(H,17)) +2 * (REF(H,18)) + REF(H,20);
VAR5:=(R+R1+R2+R3+R4)/(210);
VAR6:=(EMA(VAR5,90));
妖股线:(VAR6 + (((C - (VAR6)) * C) - (VAR6)) / (VAR6)),LINETHICK0 ;
VAR8:=(CROSS(妖股线,E5));
DRAWTEXT((VAR8) AND (VAR4),L,'↖后市有牛'),LINETHICK3,COLORRED ;
{===================A级起暴点=====================}
DOWN:=OPEN>CLOSE;
F:=COUNT(DOWN,6)=6;
AD:=COUNT(C<REF(C,1) ,6)=6;
BB:=(C<MA(C,30)*0.9);
E:=F AND AD AND BB;
AA:="MACD.DEA"(12,26,9)<=0.6;
ZT4:=C>=REF(C,1)*1.099 AND C< MA(C,20)*1.15 AND C>MA(C,20) AND "MACD.DEA"(12,26,9)<=0.3 AND"MACD.DEA"(12,26,9)>=0;
ZT3:=C>=REF(C,1)*1.099 AND C< MA(C,20)*1.16 AND C>MA(C,20) AND AA AND C>=HHV(C,20) { AND V>REF(V,1)*1.3 } ;
DRAWTEXT(ZT4 ,L*0.84,'C级起暴点');
DRAWTEXT(ZT3,L*0.90,'A级起暴点');

通达信擒庄操盘主图指标公式

 

相关文章