在线检测未来函数

通达信精品抄底选股指标公式

来源:Internet,编辑:股旁网,2018-01-11

X_1:=6;
X_2:=80;
X_3:=REF(CLOSE,1);
X_4:=SMA(MAX(CLOSE-X_3,0),18,1)/SMA(ABS(CLOSE-X_3),13,1)*100;
X_5:=SMA(MAX(CLOSE-X_3,0),24,1)/SMA(ABS(CLOSE-X_3),20,1)*100;
X_6:=BARSLAST(X_5<48)<=3 AND CROSS(X_4,X_5);
X_7:=(CLOSE-MA(CLOSE,48))/MA(CLOSE,20)*100<(-12.5);
X_8:=LLV(LOW,5);
X_9:=HHV(HIGH,10);
X_10:=EMA((CLOSE-X_8)/(X_9-X_8)*100,4);
X_11:=EMA(0.667*REF(X_10,1)+0.333*X_10,2);
X_12:=1011131;
X_13:=IF(DATE<=X_12,X_7,0) OR IF(DATE<=X_12,X_2,0);
X_14:=REF(CLOSE,1);
X_15:=SMA(MAX(CLOSE-X_14,0),7,1)/SMA(ABS(CLOSE-X_14),7,1)*100;
X_16:=SMA(MAX(CLOSE-X_14,0),13,1)/SMA(ABS(CLOSE-X_14),13,1)*100;
X_17:=BARSLAST(X_16<43)<=3 AND CROSS(X_15,X_16);
X_18:=(CLOSE-MA(CLOSE,43))/MA(CLOSE,20)*100<(-12.5);
X_19:=LLV(LOW,5);
X_20:=HHV(HIGH,10);
X_21:=EMA((CLOSE-X_19)/(X_20-X_19)*100,4);
X_22:=EMA(0.667*REF(X_21,1)+0.333*X_21,2);
X_23:=1011131;
X_24:=IF(DATE<=X_23,X_18,0) OR IF(DATE<=X_23,X_2,0);
X_25:=0-(-1)*X_17 AND X_18 AND CROSS(X_21,X_22) AND X_21<=25;
X_26:=REF(CLOSE,1);
X_27:=SMA(MAX(CLOSE-X_26,0),7,1)/SMA(ABS(CLOSE-X_26),7,1)*100;
X_28:=SMA(MAX(CLOSE-X_26,0),13,1)/SMA(ABS(CLOSE-X_26),13,1)*100;
X_29:=BARSLAST(X_28<33)<=3 AND CROSS(X_27,X_28);
X_30:=(CLOSE-MA(CLOSE,33))/MA(CLOSE,20)*100<(-12.5);
X_31:=LLV(LOW,5);
X_32:=HHV(HIGH,10);
X_33:=EMA((CLOSE-X_31)/(X_32-X_31)*100,4);
X_34:=EMA(0.667*REF(X_33,1)+0.333*X_33,2);
X_35:=1011131;
X_36:=IF(DATE<=X_35,X_30,0) OR IF(DATE<=X_35,X_2,0);
X_37:=0-(-1)*X_29 AND X_30 AND CROSS(X_33,X_34) AND X_33<=25;
X_38:=REF(CLOSE,1);
X_39:=SMA(MAX(CLOSE-X_38,0),7,1)/SMA(ABS(CLOSE-X_38),7,1)*100;
X_40:=SMA(MAX(CLOSE-X_38,0),13,1)/SMA(ABS(CLOSE-X_38),13,1)*100;
X_41:=BARSLAST(X_40<23)<=3 AND CROSS(X_39,X_40);
X_42:=(CLOSE-MA(CLOSE,23))/MA(CLOSE,20)*100<(-12.5);
X_43:=LLV(LOW,5);
X_44:=HHV(HIGH,10);
X_45:=EMA((CLOSE-X_43)/(X_44-X_43)*100,4);
X_46:=EMA(0.667*REF(X_45,1)+0.333*X_45,2);
X_47:=1011131;
X_48:=IF(DATE<=X_47,X_42,0) OR IF(DATE<=X_47,X_2,0);
X_49:=0-(-1)*X_41 AND X_42 AND CROSS(X_45,X_46) AND X_45<=25;
X_50:=(MA(CLOSE,60)-LOW)/MA(CLOSE,20)*200;
X_51:=(MA(CLOSE,60)-LOW)/MA(CLOSE,60)*200;
X_52:=(MA(CLOSE,30)-LOW)/MA(CLOSE,60)*200;
X_53:=REF(CLOSE,1);
X_54:=SMA(MAX(CLOSE-X_53,0),7,1)/SMA(ABS(CLOSE-X_53),7,1)*100;
X_55:=FILTER(REF(X_54,1)<20 AND X_54>REF(X_54,1),5);
X_56:=CLOSE/MA(CLOSE,40)<0.74;
X_57:=5;
X_58:=EMA(CLOSE,X_57);
X_59:=EMA(X_58,X_57);
X_60:=X_58-REF(X_58,1);
X_61:=X_59-REF(X_59,1);
X_62:=ABS(X_58-X_59);
X_63:=(HIGH-LOW)/REF(CLOSE,1)>0.05;
X_64:=(X_60+X_61)/2;
X_65:=POW(X_62,1)*POW(X_64,3);
X_66:=X_65/HHV(ABS(X_65),X_57*3);
X_67:=COUNT(X_63,5)>1;
X_68:=X_56 AND X_63 AND X_67;
X_69:=CROSS(X_66,(-0.9));
X_70:=FILTER(X_55 AND X_52>20 OR CLOSE>REF(CLOSE,1) AND REF(X_68,1),10);
X_71:=FILTER(REF(X_68,1) AND (X_69 OR CLOSE>REF(CLOSE,1)) AND MACD.MACD>(-1.5),10);
X_72:=COUNT(X_71,13)>=1 AND X_70;
X_73:=X_72;
X_74:=X_37;
X_75:=X_49;
XG:IF(X_73 AND X_74,X_73 AND X_74,0) OR IF(X_73 AND X_75,X_73 AND X_75,0);

通达信精品抄底选股指标公式

 

相关文章