在线检测未来函数

通达信VOL新番指标公式

来源:Internet,编辑:股旁网,2018-01-11

主力仓:EMA(100*(CLOSE- LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)),3),COLORFF00FF,NODRAW;
主力筹码集中度:WINNER(C)*100,COLORRED,NODRAW;
NDDX:=10;
JJDDX:=(HIGH+LOW+CLOSE)/3;
QJ0DDX:=VOL/IF(HIGH=LOW,4,HIGH-LOW);
QJ1DDX:=IF(CAPITAL=0,QJ0DDX*(JJDDX-MIN(CLOSE,OPEN)),QJ0DDX*IF(HIGH=LOW,1,(MIN(OPEN,CLOSE)-LOW)));
QJ2DDX:=IF(CAPITAL=0,QJ0DDX*(MIN(OPEN,CLOSE)-LOW),QJ0DDX*IF(HIGH=LOW,1,(JJDDX-MIN(CLOSE,OPEN))));
QJ3DDX:=IF(CAPITAL=0,QJ0DDX*(HIGH-MAX(OPEN,CLOSE)),QJ0DDX*IF(HIGH=LOW,1,(HIGH-MAX(OPEN,CLOSE))));
QJ4DDX:=IF(CAPITAL=0,QJ0DDX*(MAX(CLOSE,OPEN)-JJDDX),QJ0DDX*IF(HIGH=LOW,1,(MAX(CLOSE,OPEN)-JJDDX)));
大单流向:((QJ1DDX+QJ2DDX)-(QJ3DDX+QJ4DDX))/IF(CAPITAL=0,1000000,10000),COLORRED,NODRAW;
SAT:=(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20));
量能饱和:IF(SAT>1,1,SAT)*100,COLOR00AAFF,NODRAW;
N1:=5;
N2:=3;
VAR1:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VAR2:=SMA(ABS(LOW-VAR1),13,1)/SMA(MAX(LOW-VAR1,0),10,1);
VAR3:=EMA(VAR2,10);
VAR4:=LLV(LOW,33);
VAR5:=EMA(IF(LOW<=VAR4,VAR3,0),3);
主力进场:IF(VAR5>REF(VAR5,1),VAR5,0),COLORRED,NODRAW;
STICKLINE(VAR5>REF(VAR5,1),0,VAR5,3,0 ),COLOR000055;
STICKLINE(VAR5>REF(VAR5,1),0,VAR5,2.6,0 ),COLOR000077;
STICKLINE(VAR5>REF(VAR5,1),0,VAR5,2.1,0 ),COLOR000099;
STICKLINE(VAR5>REF(VAR5,1),0,VAR5,1.5,0 ),COLOR0000BB;
STICKLINE(VAR5>REF(VAR5,1),0,VAR5,0.9,0 ),COLOR0000DD;
STICKLINE(VAR5>REF(VAR5,1),0,VAR5,0.3,0 ),COLOR0000FF;
拉升:IF(VAR5<REF(VAR5,1),VAR5,0),COLORGREEN,NODRAW;
STICKLINE(VAR5<REF(VAR5,1),0,VAR5,3,0),COLOR005500;
STICKLINE(VAR5<REF(VAR5,1),0,VAR5,2.6,0),COLOR007700;
STICKLINE(VAR5<REF(VAR5,1),0,VAR5,2.1,0),COLOR009900;
STICKLINE(VAR5<REF(VAR5,1),0,VAR5,1.5,0),COLOR00BB00;
STICKLINE(VAR5<REF(VAR5,1),0,VAR5,0.9,0),COLOR00DD00;
STICKLINE(VAR5<REF(VAR5,1),0,VAR5,0.3,0),COLOR00FF00;
{地量买点}
地量:DRAWTEXT(CROSS(0.9,1/VOL*1000>0.01 AND "KDJ.J"<0),L*1,'地量'),COLOR00FFFF;
STICKLINE(地量>0,0,30,2,0),COLOR008888;
STICKLINE(地量>0,0,30,1.5,0),COLOR00AAAA;
STICKLINE(地量>0,0,30,0.8,0),COLOR00DDDD;
STICKLINE(地量>0,0,30,0.3,0),COLOR00FFFF;
{成交量比%}
AA:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主买:=IF(CLOSE>OPEN,AA*(HIGH-LOW),IF(CLOSE<OPEN,AA*((HIGH-OPEN)+(CLOSE-LOW)),VOL /2));
成交量比%:主买/VOL*100,LINETHICK0;
{主力持仓}
主力持仓:EMA(100*(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)),3),LINETHICK0;
{逃人}
VARR1:=SMA(MAX(CLOSE-REF(C,1),0),6,1)/SMA(ABS(CLOSE-REF(C,1)),6,1)*100;
DRAWICON(CROSS(82,VARR1),10,15);
MTM:=C-REF(C,1);
主力线:100*EMA(EMA(MTM,N1),N1)/EMA(EMA(ABS(MTM),N1),N1),COLOR00FFFF,LINETHICK2;
趋势线:MA(主力线,N2),COLORRED,LINETHICK2;
{主力线变色}
IF(主力线<REF(主力线,1),主力线,DRAWNULL),COLORGREEN,LINETHICK2;
IF(主力线>REF(主力线,1),主力线,DRAWNULL),COLOR00FFFF,LINETHICK2;
{红绿箭头}
DRAWICON(CROSS(主力线,趋势线),趋势线,1);
DRAWICON(CROSS(趋势线,主力线),趋势线,2);

通达信VOL新番指标公式

 

相关文章