在线检测未来函数

通达信两仪万像指标公式

来源:Internet,编辑:股旁网,2018-01-16

N:=9;
M:=3;
多空:0,POINTDOT,COLORFFFFFF,NODRAW;
VAR1:=HHV(HIGH,9)-LLV(LOW,9);
VAR2:=HHV(HIGH,9)-CLOSE;
VAR3:=CLOSE-LLV(LOW,9);
VAR4:=VAR2/VAR1*100-70;
VAR5:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
VAR6:=(2*CLOSE+HIGH+LOW)/4;
VAR7:=SMA(VAR3/VAR1*100,3,1);
VAR8:=LLV(LOW,34);
VAR9:=SMA(VAR7,3,1)-SMA(VAR4,9,1);
AA:=IF(VAR9>100,VAR9-100,0);
BB:=HHV(HIGH,34);
CC:=EMA((VAR6-VAR8)/(BB-VAR8)*100,13);
DD:EMA(0.667*REF(CC,1)+0.333*CC,2),POINTDOT,COLORFFFFFF,LINETHICK1;
IF(DD>REF(DD,1),DD,DRAWNULL),COLORRED,LINETHICK1;
DRAWICON(FILTER(DD<REF(DD,1),10),DD,1);
OO:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*80;
EE:3.4*SMA(OO,M,1)-2.1*SMA(SMA(OO,M,1),M,1),POINTDOT,COLORFFFFFF;
IF(EE>REF(EE,1),EE,DRAWNULL),COLORRED,LINETHICK3;
老阴:=EE<REF(EE,1) AND DD<REF(DD,1);
老阳:=EE>REF(EE,1) AND DD>REF(DD,1);
少阳:=EE>REF(EE,1) AND DD<REF(DD,1);
少阴:=EE<REF(EE,1) AND DD>REF(DD,1);
DRAWBAND(DD,RGB(0,24,224),EE,RGB(255,0,0));
STICKLINE(少阳,DD,EE,4,0),COLORWHITE;
STICKLINE(少阴,DD,EE,4,0),COLORYELLOW;

通达信两仪万像指标公式

 

相关文章