在线检测未来函数

通达信持仓记录与操作提示主图指标公式

来源:Internet,编辑:股旁网,2018-01-18

平衡值:=5;
赢利系数:=5;
落后补:=8;
预损设定:=5;
代码1:='000757'; 收盘价1:=CONST("000757$C");昨收盘价1:=CONST(REF("000757$C",1));
代码2:='002495'; 收盘价2:=CONST("002495$C");昨收盘价2:=CONST(REF("002495$C",1));
代码3:=''; 收盘价3:=CONST("0$C");昨收盘价3:=CONST(REF("0$C",1));
代码4:=''; 收盘价4:=CONST("0$C");昨收盘价4:=CONST(REF("0$C",1));
代码5:=''; 收盘价5:=CONST("0$C");昨收盘价5:=CONST(REF("0$C",1));
代码6:=''; 收盘价6:=CONST("0$C");昨收盘价6:=CONST(REF("0$C",1));
代码7:=''; 收盘价7:=CONST("0$C");昨收盘价7:=CONST(REF("0$C",1));
{====================================}
{第一只个股.第1次}
价位A1:=7;
股数A1:=1000;
{第一只个股.第2次}
价位A2:=0;
股数A2:=000;
{第一只个股.第3次}
价位A3:=0;
股数A3:=000;
{第一只个股.第4次}
价位A4:=0;
股数A4:=000;
{第一只个股.第5次}
价位A5:=0;
股数A5:=000;
{====================================}
{第二只个股,第1次}
价位B1:=3.8;
股数B1:=1000;
{第二只个股,第2次}
价位B2:=0;
股数B2:=00;
{第二只个股,第3次}
价位B3:=0;
股数B3:=000;
{第二只个股,第4次}
价位B4:=0;
股数B4:=000;
{第二只个股,第5次}
价位B5:=0;
股数B5:=000;
{====================================}
{第三只个股,第1次}
价位C1:=0;
股数C1:=00;
{第三只个股,第2次}
价位C2:=0;
股数C2:=000;
{第三只个股,第3次}
价位C3:=0;
股数C3:=00;
{第三只个股,第4次}
价位C4:=0;
股数C4:=0;
{第三只个股,第5次}
价位C5:=0;
股数C5:=000;
{=====================================}
{第四只个股,第1次}
价位D1:=0;
股数D1:=00;
{第四只个股,第2次}
价位D2:=0;
股数D2:=00;
{第四只个股,第3次}
价位D3:=00;
股数D3:=00;
{第四只个股,第4次}
价位D4:=0;
股数D4:=000;
{第四只个股,第5次}
价位D5:=0;
股数D5:=000;
{======================================}
{第五只个股,第1次}
价位E1:=0;
股数E1:=00;
{第五只个股,第2次}
价位E2:=0;
股数E2:=00;
{第五只个股,第3次}
价位E3:=0;
股数E3:=00;
{第五只个股,第4次}
价位E4:=0;
股数E4:=00;
{第五只个股,第5次}
价位E5:=0;
股数E5:=00;
{======================================}
{第六只个股,第1次}
价位F1:=0;
股数F1:=00;
{第六只个股,第2次}
价位F2:=0;
股数F2:=000;
{第六只个股,第3次}
价位F3:=0;
股数F3:=00;
{第六只个股,第4次}
价位F4:=0;
股数F4:=000;
{第六只个股,第5次}
价位F5:=0;
股数F5:=000;
{======================================}
{第7只个股,第1次}
价位G1:=0;
股数G1:=0;
{第7只个股,第2次}
价位G2:=0;
股数G2:=00;
{第7只个股,第3次}
价位G3:=0;
股数G3:=0;
{第7只个股,第4次}
价位G4:=0;
股数G4:=00;
{第7只个股,第5次}
价位G5:=0;
股数G5:=00;
{=====}
DRAWRECTREL(0,0,1000,1000,RGB(50,80,50));
DRAWRECTREL(0,10,968,990,RGB(50,100,140));
{=======K线=====}
DRAWKLINE(H,O,L,C);
{=========下面可以换自己指标==========}
MA5:MA(C,5),LINETHICK1,DOTLINE,COLORYELLOW;
MA10:MA(C,10),LINETHICK1,DOTLINE,COLORWHITE;
MA20:MA(C,20),LINETHICK1,DOTLINE,COLORRED;
MA60:MA(C,60),LINETHICK1,DOTLINE,COLORGREEN;
{======中框K线=======}
AU:=CONST(HHV(H,100));
BU:=CONST(LLV(L,100));
差距:=AU-BU;
FFF:=差距/1000,NODRAW,COLOR00FFFF;
高:=差距/FFF;
支撑:=(AU-(BU+差距*0.191))/FFF;
强势:=(AU-(BU+差距*0.382))/FFF;
突破:=(AU-(BU+差距/2))/FFF;
警示:=(AU-(BU+差距*0.618))/FFF;
压力:=(AU-(BU+差距*0.809))/FFF;
DRAWRECTREL(968,压力,1000,支撑,RGB(50,80,50));
DRAWRECTREL(968,警示,1000,强势,RGB(50,80,50));
DRAWRECTREL(968,突破,1000,突破,RGB(200,200,200));
DRAWTEXT_FIX(C>O,0.972,0.085,0,'风险 '),COLORWHITE;
DRAWTEXT_FIX(C>O,0.972,0.265,0,'警示 '),COLORWHITE;
DRAWTEXT_FIX(C>O,0.972,0.425, 0,'突破 '),COLORWHITE;
DRAWTEXT_FIX(C>O,0.972,0.54,0,'拉升 '),COLORWHITE;
DRAWTEXT_FIX(C>O,0.972,0.705,0,'低买 '),COLORWHITE;
DRAWTEXT_FIX(C>O,0.972,0.88,0,'建仓 '),COLORWHITE;
{==========}
买股量1:=股数A5+股数A4+股数A3+股数A2+股数A1,NODRAW;
买股量2:=股数B5+股数B4+股数B3+股数B2+股数B1,NODRAW;
买股量3:=股数C5+股数C4+股数C3+股数C2+股数C1,NODRAW;
买股量4:=股数D5+股数D4+股数D3+股数D2+股数D1,NODRAW;
买股量5:=股数E5+股数E4+股数E3+股数E2+股数E1,NODRAW;
买股量6:=股数F5+股数F4+股数F3+股数F2+股数F1,NODRAW;
买股量7:=股数G5+股数G4+股数G3+股数G2+股数G1,NODRAW;
持股价1:=(价位A1*股数A1+价位A2*股数A2+价位A3*股数A3+价位A4*股数A4+价位A5*股数A5)/买股量1,NODRAW;
持股价2:=(价位B1*股数B1+价位B2*股数B2+价位B3*股数B3+价位B4*股数B4+价位B5*股数B5)/买股量2,NODRAW;
持股价3:=(价位C1*股数C1+价位C2*股数C2+价位C3*股数C3+价位C4*股数C4+价位C5*股数C5)/买股量3,NODRAW;
持股价4:=(价位D1*股数D1+价位D2*股数D2+价位D3*股数D3+价位D4*股数D4+价位D5*股数D5)/买股量4,NODRAW;
持股价5:=(价位E1*股数E1+价位E2*股数E2+价位E3*股数E3+价位E4*股数E4+价位E5*股数E5)/买股量5,NODRAW;
持股价6:=(价位F1*股数F1+价位F2*股数F2+价位F3*股数F3+价位F4*股数F4+价位F5*股数F5)/买股量6,NODRAW;
持股价7:=(价位G1*股数G1+价位G2*股数G2+价位G3*股数G3+价位G4*股数G4+价位G5*股数G5)/买股量7,NODRAW;
投资1:=IF((持股价1*买股量1+持股价1*买股量1*0.003)!=DRAWNULL,(持股价1*买股量1+持股价1*买股量1*0.003),0),NODRAW;
投资2:=IF((持股价2*买股量2+持股价2*买股量2*0.003)!=DRAWNULL,(持股价2*买股量2+持股价2*买股量2*0.003),0),NODRAW;
投资3:=IF((持股价3*买股量3+持股价3*买股量3*0.003)!=DRAWNULL,(持股价3*买股量3+持股价3*买股量3*0.003),0),NODRAW;
投资4:=IF((持股价4*买股量4+持股价4*买股量4*0.003)!=DRAWNULL,(持股价4*买股量4+持股价4*买股量4*0.003),0),NODRAW;
投资5:=IF((持股价5*买股量5+持股价5*买股量5*0.003)!=DRAWNULL,(持股价5*买股量5+持股价5*买股量5*0.003),0),NODRAW;
投资6:=IF((持股价6*买股量6+持股价6*买股量6*0.003)!=DRAWNULL,(持股价6*买股量6+持股价6*买股量6*0.003),0),NODRAW;
投资7:=IF((持股价7*买股量7+持股价7*买股量7*0.003)!=DRAWNULL,(持股价7*买股量7+持股价7*买股量7*0.003),0),NODRAW;
价值1:=收盘价1*买股量1-收盘价1*买股量1*0.003,NODRAW;
价值2:=收盘价2*买股量2-收盘价2*买股量2*0.003,NODRAW;
价值3:=收盘价3*买股量3-收盘价3*买股量3*0.003,NODRAW;
价值4:=收盘价4*买股量4-收盘价4*买股量4*0.003,NODRAW;
价值5:=收盘价5*买股量5-收盘价5*买股量5*0.003,NODRAW;
价值6:=收盘价6*买股量6-收盘价6*买股量6*0.003,NODRAW;
价值7:=收盘价7*买股量7-收盘价7*买股量7*0.003,NODRAW;
昨价值1:=昨收盘价1*买股量1-昨收盘价1*买股量1*0.003,NODRAW;
昨价值2:=昨收盘价2*买股量2-昨收盘价2*买股量2*0.003,NODRAW;
昨价值3:=昨收盘价3*买股量3-昨收盘价3*买股量3*0.003,NODRAW;
昨价值4:=昨收盘价4*买股量4-昨收盘价4*买股量4*0.003,NODRAW;
昨价值5:=昨收盘价5*买股量5-昨收盘价5*买股量5*0.003,NODRAW;
昨价值6:=昨收盘价6*买股量6-昨收盘价6*买股量6*0.003,NODRAW;
昨价值7:=昨收盘价7*买股量7-昨收盘价7*买股量7*0.003,NODRAW;
浮动赢亏1:=价值1-投资1,NODRAW,COLORWHITE;
浮动赢亏2:=价值2-投资2,NODRAW,COLORWHITE;
浮动赢亏3:=价值3-投资3,NODRAW,COLORWHITE;
浮动赢亏4:=价值4-投资4,NODRAW,COLORWHITE;
浮动赢亏5:=价值5-投资5,NODRAW,COLORWHITE;
浮动赢亏6:=价值6-投资6,NODRAW,COLORWHITE;
浮动赢亏7:=价值7-投资7,NODRAW,COLORWHITE;
昨浮动赢亏1:=昨价值1-投资1,NODRAW,COLORWHITE;
昨浮动赢亏2:=昨价值2-投资2,NODRAW,COLORWHITE;
昨浮动赢亏3:=昨价值3-投资3,NODRAW,COLORWHITE;
昨浮动赢亏4:=昨价值4-投资4,NODRAW,COLORWHITE;
昨浮动赢亏5:=昨价值5-投资5,NODRAW,COLORWHITE;
昨浮动赢亏6:=昨价值6-投资6,NODRAW,COLORWHITE;
昨浮动赢亏7:=昨价值7-投资7,NODRAW,COLORWHITE;
今赢亏:=浮动赢亏1+浮动赢亏2+浮动赢亏3+浮动赢亏4+浮动赢亏5+浮动赢亏6+浮动赢亏7;
昨赢亏:=昨浮动赢亏1+昨浮动赢亏2+昨浮动赢亏3+昨浮动赢亏4+昨浮动赢亏5+昨浮动赢亏6+昨浮动赢亏7;
今昨比:=今赢亏-昨赢亏,NODRAW,COLORWHITE;
总投资:=投资1+投资2+投资3+投资4+投资5+投资6+投资7,NODRAW;
现价值:=价值1+价值2+价值3+价值4+价值5+价值6+价值7,NODRAW;
赢利率:=(现价值-总投资)/总投资*100;
持股价:=IF(CODELIKE(代码1),持股价1,IF(CODELIKE(代码2),持股价2,IF(CODELIKE(代码3),持股价3,IF(CODELIKE(代码4),持股价4,
IF(CODELIKE(代码5),持股价5,IF(CODELIKE(代码6),持股价6,IF(CODELIKE(代码7),持股价7,DRAWNULL))))))),NODRAW;
买股量:=IF(CODELIKE(代码1),买股量1,IF(CODELIKE(代码2),买股量2,IF(CODELIKE(代码3),买股量3,IF(CODELIKE(代码4),买股量4,
IF(CODELIKE(代码5),买股量5,IF(CODELIKE(代码6),买股量6,IF(CODELIKE(代码7),买股量7,DRAWNULL))))))),NODRAW;
{======补仓提醒==========}
补仓价1:=持股价*(100-落后补)/100,COLORWHITE,NODRAW;
补仓:=L*1.01<补仓价1,COLORWHITE,NODRAW;
补仓价:=MIN(补仓价1,MIN(C,O)),COLORWHITE,NODRAW;
补平:=补仓价*(100+平衡值)/100,COLORWHITE,NODRAW;
平衡:=IF(持股价>0,补平,DRAWNULL),COLORWHITE,NODRAW;
补股比:=(持股价-平衡)/(平衡-补仓价),COLORWHITE,NODRAW;
补仓量A:=INTPART(买股量*补股比/100);
补仓量:=IF(L<补仓价,补仓量A*100,DRAWNULL),COLORWHITE;
补后均价:=(买股量*持股价+补仓价*补仓量)/(买股量+补仓量);
STICKLINE(CURRBARSCOUNT=1 AND L<补仓价,L,补仓价,0.8,0),COLORYELLOW;
{========持股价桌面显示========}
STICKLINE(CONST(持股价)>1 AND CURRBARSCOUNT<16,CONST(持股价),CONST(持股价),2,0),LINETHICK2,COLORYELLOW;
STICKLINE(CURRBARSCOUNT>15 AND CURRBARSCOUNT<28 AND CONST(持股价)>1 ,持股价+持股价*0.01,持股价-持股价*0.01,4,0),COLOR256D7C ;
DRAWTEXT(CONST(持股价)>1 AND CURRBARSCOUNT=27,CONST(持股价),STRCAT(STRCAT(STRCAT(CON2STR(持股价,2),'元 持'),CON2STR(买股量,0)),' 股')),COLORWHITE;
{========补后平衡显示========}
STICKLINE(CONST(持股价)>1 AND CURRBARSCOUNT<49,CONST(补后均价),CONST(补后均价),2,0),LINETHICK2,COLORYELLOW;
STICKLINE(CURRBARSCOUNT>49 AND CURRBARSCOUNT<62 AND CONST(补后均价) ,CONST(补后均价)+CONST(补后均价)*0.01,CONST(补后均价)-CONST(补后均价)*0.01,4,0),COLOR256D7C ;
DRAWTEXT(CONST(持股价)>1 AND CURRBARSCOUNT=60,CONST(补后均价),' 补仓后平衡显示'),COLORWHITE;
{==========持股色屏==========}
上市天数:=BARSCOUNT(C);
移:=CONST(上市天数)>=63;
左边:=IF(移,5,620);
右边:=IF(移,375,995);
DRAWRECTREL(左边-5,0,右边+5,1000,RGB(50,80,50));
DRAWRECTREL(左边,12,右边,988,RGB(50,80,50));
DRAWRECTREL(左边,108,右边,724,RGB(30,30,30));
DRAWRECTREL(左边,196,右边,636,RGB(30,30,30));
DRAWRECTREL(左边,284,右边,548,RGB(30,30,30));
DRAWRECTREL(左边,372,右边,460,RGB(30,30,30));
竖1:=IF(移,63,678);
竖2:=IF(移,186,803);
竖3:=IF(移,253,868);
竖4:=IF(移,318,932);
DRAWRECTREL(竖1,12,竖1,724,RGB(200,200,200));
DRAWRECTREL(竖2,12,竖2,724,RGB(200,200,200));
DRAWRECTREL(竖3,12,竖3,724,RGB(200,200,200));
DRAWRECTREL(竖4,12,竖4,724,RGB(200,200,200));
移码:=IF(移,0.01,0.627);
DRAWTEXT_FIX(C>0,移码,0.131,0,代码1),COLORLIRED;
DRAWTEXT_FIX(C>0,移码,0.219,0,代码2),COLORLIRED;
DRAWTEXT_FIX(C>0,移码,0.307,0,代码3),COLORLIRED;
DRAWTEXT_FIX(C>0,移码,0.395,0,代码4),COLORLIRED;
DRAWTEXT_FIX(C>0,移码,0.483,0,代码5),COLORLIRED;
DRAWTEXT_FIX(C>0,移码,0.571,0,代码6),COLORLIRED;
DRAWTEXT_FIX(C>0,移码,0.659,0,代码7),COLORLIRED;
DRAWTEXT_FIX(C>0,移码-0.002,0.04,0,'代码名称'),COLORYELLOW;
DRAWTEXT_FIX(C>0,移码+0.065,0.04,0,'买股 价位 及 数量'),COLORYELLOW;
DRAWTEXT_FIX(C>0,移码+0.184,0.04,0,'今日股价'),COLORYELLOW;
DRAWTEXT_FIX(C>0,移码+0.25,0.04,0,' 盈亏额'),COLORYELLOW;
DRAWTEXT_FIX(C>0,移码+0.315,0.04,0,' 赢亏比'),COLORYELLOW;
{=======}
价量1:=STRCAT(STRCAT(STRCAT(CON2STR(持股价1,2),' 元 持'),CON2STR(买股量1,0)),' 股');
DRAWTEXT_FIX(买股量1>0,移码+0.06,0.131,0,价量1),COLORWHITE;
价量2:=STRCAT(STRCAT(STRCAT(CON2STR(持股价2,2),' 元 持'),CON2STR(买股量2,0)),' 股');
DRAWTEXT_FIX(买股量2>0,移码+0.06,0.219,0,价量2),COLORWHITE;
价量3:=STRCAT(STRCAT(STRCAT(CON2STR(持股价3,2),' 元 持'),CON2STR(买股量3,0)),' 股');
DRAWTEXT_FIX(买股量3>0,移码+0.06,0.307,0,价量3),COLORWHITE;
价量4:=STRCAT(STRCAT(STRCAT(CON2STR(持股价4,2),' 元 持'),CON2STR(买股量4,0)),' 股');
DRAWTEXT_FIX(买股量4>0,移码+0.06,0.395,0,价量4),COLORWHITE;
价量5:=STRCAT(STRCAT(STRCAT(CON2STR(持股价5,2),' 元 持'),CON2STR(买股量5,0)),' 股');
DRAWTEXT_FIX(买股量5>0,移码+0.06,0.483,0,价量5),COLORWHITE;
价量6:=STRCAT(STRCAT(STRCAT(CON2STR(持股价6,2),' 元 持'),CON2STR(买股量6,0)),' 股');
DRAWTEXT_FIX(买股量6>0,移码+0.06,0.571,0,价量6),COLORWHITE;
价量7:=STRCAT(STRCAT(STRCAT(CON2STR(持股价7,2),' 元 持'),CON2STR(买股量7,0)),' 股');
DRAWTEXT_FIX(买股量7>0,移码+0.06,0.659,0,价量7),COLORWHITE;
{=====}
收盘1:=STRCAT(CON2STR(收盘价1,2),' 元');
DRAWTEXT_FIX(买股量1>0,移码+0.185,0.131,0,收盘1),COLORGREEN;
收盘2:=STRCAT(CON2STR(收盘价2,2),' 元');
DRAWTEXT_FIX(买股量2>0,移码+0.185,0.219,0,收盘2),COLORGREEN;
收盘3:=STRCAT(CON2STR(收盘价3,2),' 元');
DRAWTEXT_FIX(买股量3>0,移码+0.185,0.307,0,收盘3),COLORGREEN;
收盘4:=STRCAT(CON2STR(收盘价4,2),' 元');
DRAWTEXT_FIX(买股量4>0,移码+0.185,0.395,0,收盘4),COLORGREEN;
收盘5:=STRCAT(CON2STR(收盘价5,2),' 元');
DRAWTEXT_FIX(买股量5>0,移码+0.185,0.483,0,收盘5),COLORGREEN;
收盘6:=STRCAT(CON2STR(收盘价6,2),' 元');
DRAWTEXT_FIX(买股量6>0,移码+0.185,0.571,0,收盘6),COLORGREEN;
收盘7:=STRCAT(CON2STR(收盘价7,2),' 元');
DRAWTEXT_FIX(买股量7>0,移码+0.185,0.659,0,收盘7),COLORGREEN;
{====}
赢亏1:=STRCAT(CON2STR(浮动赢亏1,0),' 元');
DRAWTEXT_FIX(买股量1>0 ,移码+0.248,0.131,0,赢亏1),COLORWHITE;
赢亏2:=STRCAT(CON2STR(浮动赢亏2,0),' 元');
DRAWTEXT_FIX(买股量2>0,移码+0.248,0.219,0,赢亏2),COLORWHITE;
赢亏3:=STRCAT(CON2STR(浮动赢亏3,0),' 元');
DRAWTEXT_FIX(买股量3>0 ,移码+0.248,0.307,0,赢亏3),COLORWHITE;
赢亏4:=STRCAT(CON2STR(浮动赢亏4,0),' 元');
DRAWTEXT_FIX(买股量4>0 ,移码+0.248,0.395,0,赢亏4),COLORWHITE;
赢亏5:=STRCAT(CON2STR(浮动赢亏5,0),' 元');
DRAWTEXT_FIX(买股量5>0 ,移码+0.248,0.483,0,赢亏5),COLORWHITE;
赢亏6:=STRCAT(CON2STR(浮动赢亏6,0),' 元');
DRAWTEXT_FIX(买股量6>0 ,移码+0.248,0.571,0,赢亏6),COLORWHITE;
赢亏7:=STRCAT(CON2STR(浮动赢亏7,0),' 元');
DRAWTEXT_FIX(买股量7>0 ,移码+0.248,0.659,0,赢亏7),COLORWHITE;
{========}
位:=差距/11;位1:=CONST(BU+位*9.3);位2:=CONST(BU+位*8.3);位3:=CONST(BU+位*7.3);
位4:=CONST(BU+位*6.3);位5:=CONST(BU+位*5.3);位6:=CONST(BU+位*4.3);位7:=CONST(BU+位*3.3);
位置:=IF(CODELIKE(代码1),位1,IF(CODELIKE(代码2),位2,IF(CODELIKE(代码3),位3,IF(CODELIKE(代码4),位4,
IF(CODELIKE(代码5),位5,IF(CODELIKE(代码6),位6,IF(CODELIKE(代码7),位7,DRAWNULL))))))),COLORWHITE;
{=====买点赢亏及标记位置====}
计算日:=CROSS(C,持股价),NODRAW;
计算距:=BARSLAST(计算日) ,NODRAW;
尺:=计算距>=1,NODRAW;
预损:=持股价*(100-预损设定{5%})/100,COLORWHITE,NODRAW;
利:=SUM(预损*0.01,计算距),COLORGREEN,NODRAW;
税:=IF(C>REF(MAX(C,O),1)*1.025,(C-REF(MAX(C,O),1))*0.5,0),COLORGREEN,NODRAW;
计税:=SUM(税,计算距),COLORGREEN,NODRAW;
利税:=利+计税,COLORGREEN,NODRAW;
告别价:=预损+利税*尺,COLORGREEN,NODRAW;
采摘价1:=持股价*(100+赢利系数)/100,COLORWHITE,NODRAW;
采摘价2:=持股价*(100+赢利系数*2)/100,COLORWHITE,NODRAW;
采摘价3:=持股价*(100+赢利系数*3)/100,COLORWHITE,NODRAW;
采摘价4:=持股价*(100+赢利系数*4)/100,COLORWHITE,NODRAW;
标记:=CROSS(H,采摘价1) OR CROSS(H,采摘价2) OR CROSS(H,采摘价3) OR CROSS(H,采摘价4) OR CROSS(告别价,C) OR CONST(补仓量)>=100;
标记2:=CROSS(H,采摘价1) OR CROSS(H,采摘价2) OR CROSS(H,采摘价3) OR CROSS(H,采摘价4) ;
提示价:=IF(CROSS(H,采摘价1),采摘价1,IF(CROSS(H,采摘价2),采摘价2,IF(CROSS(H,采摘价3),采摘价3,IF(CROSS(H,采摘价4),采摘价4,告别价))));
DRAWICON(CURRBARSCOUNT=65 AND 买股量>0 AND (CONST(标记)!=0 OR CONST(补仓量)>=100), 位置 ,12);{上标记}
DRAWICON(CURRBARSCOUNT=68 AND 买股量>0 AND CONST(标记)!=0, CONST(BU+位*2.1) ,15);{下标记}
图样:=IF(CONST(标记2)!=0,17,9);
DRAWICON(CURRBARSCOUNT=66 AND 买股量>0 AND ( CONST(标记2)!=0 OR CONST(标记)!=0) , CONST(BU+位*2.3) ,图样);{上标记}
涨1:='【 股 价 涨 5 % ';
涨2:='【 股 价 涨 10 % ';
涨3:='【 股 价 涨 15 % ';
涨4:='【 股 价 涨 20 % ';
规律1:=IF(CROSS(H,采摘价1),涨1,IF(CROSS(H,采摘价2),涨2,IF(CROSS(H,采摘价3),涨3,涨4)));
采摘:=STRCAT(STRCAT(规律1,CON2STR(提示价,2)),' 元 请 择 高 采 摘 】' );
DRAWTEXT_FIX(CONST(标记2) ,移码+0.004,0.767,0,采摘),COLORGREEN;
采摘2:=STRCAT(STRCAT('【 ' ,CON2STR(提示价,2)),' 元 保 护 价 破 了 要 卖 股 快 跑 】 ' );
DRAWTEXT_FIX(CONST(CROSS(告别价,C)) ,移码+0.004,0.767,0,采摘2),COLORGREEN;
赢利率1:=STRCAT(CON2STR((价值1-投资1)/投资1*100,2),' %');
DRAWTEXT_FIX(买股量1>0 AND (位置!=位1 OR (位置=位1 AND CONST(标记)=0)) ,移码+0.312,0.131,0,赢利率1),COLORCYAN;
赢利率2:=STRCAT(CON2STR((价值2-投资2)/投资2*100,2),' %');
DRAWTEXT_FIX(买股量2>0 AND (位置!=位2 OR (位置=位2 AND CONST(标记)=0)) ,移码+0.312,0.219,0,赢利率2),COLORCYAN;
赢利率3:=STRCAT(CON2STR((价值3-投资3)/投资3*100,2),' %');
DRAWTEXT_FIX(买股量3>0 AND (位置!=位3 OR (位置=位3 AND CONST(标记)=0)),移码+0.312,0.307,0,赢利率3),COLORCYAN;
赢利率4:=STRCAT(CON2STR((价值4-投资4)/投资4*100,2),' %');
DRAWTEXT_FIX(买股量4>0 AND (位置!=位4 OR (位置=位4 AND CONST(标记)=0)),移码+0.312,0.395,0,赢利率4),COLORCYAN;
赢利率5:=STRCAT(CON2STR((价值5-投资5)/投资5*100,2),' %');
DRAWTEXT_FIX(买股量5>0 AND (位置!=位5 OR (位置=位5 AND CONST(标记)=0)) ,移码+0.312,0.483,0,赢利率5),COLORCYAN;
赢利率6:=STRCAT(CON2STR((价值6-投资6)/投资6*100,2),' %');
DRAWTEXT_FIX(买股量6>0 AND (位置!=位6 OR (位置=位6 AND CONST(标记)=0)) ,移码+0.312,0.571,0,赢利率6),COLORCYAN;
赢利率7:=STRCAT(CON2STR((价值7-投资7)/投资7*100,2),' %');
DRAWTEXT_FIX(买股量7>0 AND (位置!=位7 OR (位置=位7 AND CONST(标记)=0)),移码+0.312,0.659,0,赢利率7),COLORCYAN;
{========}
差派1:=IF(CONST(标记)!=1,0.8,0.845);
投入赢亏:=STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT('持股赢亏 : ' ,CON2STR(今赢亏,0)),' 元 赢利率 : ') ,CON2STR(赢利率,0)),' % 今日增减 : '),CON2STR(今昨比,0)),' 元');
DRAWTEXT_FIX(C>0,移码+0.01,差派1,0,投入赢亏),COLORWHITE;
持股资金:=STRCAT(STRCAT(STRCAT(STRCAT('【 持 股 资 金 : ', CON2STR(总投资,0)),' 元 】 【 双 重 跑 道 费 '),CON2STR(C*0.006,2)),' 元 】');
差派2:=IF(CONST(标记)!=1,0.89,0.923);
DRAWTEXT_FIX(C>0,移码+0.002,差派2,0, 持股资金),COLORYELLOW;
{============}
YKY3:=IF(CONST(补仓量)>=100,724,DRAWNULL);
YKY4:=IF(CONST(补仓量)>=100,988,DRAWNULL);
DRAWRECTREL(5,YKY3,375,YKY4,RGB(50,80,50));
DRAWTEXT_FIX(CONST(补仓量)>=100 ,0.018,0.767,0,'【 若 补 仓 操 作 请 思 前 想 后 】'),COLORCYAN;
DRAWICON(CONST(补仓量)>=100 AND CURRBARSCOUNT=81 , CONST(BU+位*2.15),5);
A1AU:=STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(CON2STR(补仓价,2),' 元 以 下 可 视 情 况 续 买 '),CON2STR(补仓量,0)),' 股 补 后 价 为 '),CON2STR(补平,2)),' 元');
DRAWTEXT_FIX(CONST(补仓量 >0) ,0.018,0.845,0,A1AU),COLORWHITE;
补仓撤:=补平*0.98,NODRAW;
后撤量:=INTPART(补仓量*补仓价/补平/100)*100;
A1AS:=STRCAT(STRCAT(STRCAT(STRCAT('当 股 价 达 ',CON2STR(补仓撤,2)), ' 元 , 也 可 先 撒 ' ),CON2STR(后撤量,0)),' 股 或 者 撤 前 仓 ' );
DRAWTEXT_FIX(CONST(补仓量 >0) ,0.018,0.923,0,A1AS),COLORWHITE;

通达信持仓记录与操作提示主图指标公式

 

相关文章