在线检测未来函数

通达信综合参谋指标公式

来源:Internet,编辑:股旁网,2018-01-23

DRAWRECTREL(0,0,1000,1000,RGB(45,75,45));
DRAWRECTREL(290,20,1000,980,RGB(5,10,15));
MMM:=CURRBARSCOUNT<37;
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,27);
DIEA:=EMA(DIFF,9);
零轴:=60;
MACDZ:=(DIFF-DIEA),COLORSTICK;
系数:=CONST(HHV(ABS(MACDZ),150));
自由度:=MACDZ*零轴/系数*0.9;
STICKLINE((零轴+自由度)>零轴 AND MMM AND (零轴+自由度)<=REF(零轴+自由度,1),零轴,零轴+自由度,2,0),COLOR00FFFF;
STICKLINE((零轴+自由度)>零轴 AND MMM AND (零轴+自由度)>REF(零轴+自由度,1),零轴,零轴+自由度,2,0),COLOR0055FF;
STICKLINE((零轴+自由度)<=零轴 AND MMM AND (零轴+自由度)<=REF(零轴+自由度,1),零轴,零轴+自由度,2,0),COLORFFFF55;
STICKLINE((零轴+自由度)<=零轴 AND MMM AND (零轴+自由度)>REF(零轴+自由度,1),零轴,零轴+自由度,2,0),COLORFF55BB;
JCCOUNT:=COUNT(CROSS(DIFF,DIEA),BARSLAST(DIEA>=0));
二次金叉:=CROSS(DIFF,DIEA) AND DIEA<0 AND COUNT(JCCOUNT=2,21)=1;
STICKLINE(二次金叉 AND MMM=1 ,40,50,1,0),COLORYELLOW;
DRAWTEXT(二次金叉 AND MMM=1,40,' 二次金叉'),COLORYELLOW;
低位金叉:=CROSS(DIFF,DIEA) AND DIFF<-0.1;
STICKLINE(低位金叉 AND MMM=1,40,60,1,0),COLORYELLOW;
DRAWTEXT(低位金叉 AND MMM=1,50,' 低位金叉'),COLORYELLOW;
AQ1:=BARSLAST(REF(CROSS(DIFF,DIEA),1));
背离:=REF(CLOSE,AQ1+1)>CLOSE AND DIFF>REF(DIFF,AQ1+1) AND CROSS(DIFF,DIEA);
STICKLINE(底背离 AND MMM=1,60,50,1,0),COLOR00FF00;
DRAWTEXT(底背离 AND MMM=1,50,' 底背离'),COLOR00FF00;
AQ2:=BARSLAST(REF(CROSS(DIEA,DIFF),1));
顶背离:=REF(CLOSE,AQ2+1)<CLOSE AND REF(DIFF,AQ2+1)>DIFF AND CROSS(DIEA,DIFF);
STICKLINE(顶背离 AND MMM=1,60,70,1,0),COLORGREEN;
DRAWTEXT(顶背离 AND MMM=1,70,' 顶背离'),COLORGREEN;
VAR2:=LLV(LOW,10);
VAR3:=HHV(HIGH,25);
卖出:= 3.2,COLORYELLOW;
清仓:= 3.5,COLORFFFF00;
动力线:=(EMA((CLOSE-VAR2)/(VAR3-VAR2)*4,4))*17;
STICKLINE(动力线>REF(动力线,1) AND MMM ,动力线 ,REF(动力线,1),3 ,0),COLORRED;
STICKLINE(动力线<=REF(动力线,1) AND MMM ,动力线 ,REF(动力线,1),3 ,0),COLOR00FF00;
定位:=38;
系数A:=CONST(HHV(ABS(VOL),36));
成交:=VOL/系数A*60,VOLSTICK;
条件阳:=C>O OR (C=O AND C>=REF(C,1));
条件阴:=C<O OR (C=O AND C<REF(C,1));
STICKLINE(REFX(条件阳 ,定位) AND CURRBARSCOUNT>定位,0,REFX(成交,定位),2,2),COLOR0055FF;
STICKLINE(REFX(条件阴 ,定位) AND CURRBARSCOUNT>定位,0,REFX(成交,定位),2,0),COLORFFFF55;
DRAWRECTREL(290,0,320,1000,RGB(45,75,45));
DRAWRECTREL(295,30,315,970,RGB(45,75,45));
DRAWRECTREL(600,0,630,1000,RGB(45,75,45));
DRAWRECTREL(605,30,625,955,RGB(45,75,45));
DRAWRECTREL(970,0,1000,1000,RGB(45,75,45));
DRAWRECTREL(975,30,995,970,RGB(45,75,45));
DRAWTEXT_FIX(C>O,0.299,0.15, 0,'成 '),COLORWHITE;
DRAWTEXT_FIX(C>O,0.299,0.45, 0,'交 '),COLORWHITE;
DRAWTEXT_FIX(C>O,0.299,0.75,0,'量'),COLORWHITE;
DRAWTEXT_FIX(C>O,0.609,0.15, 0,'动 '),COLORWHITE;
DRAWTEXT_FIX(C>O,0.609,0.45,0,'力'),COLORWHITE;
DRAWTEXT_FIX(C>O,0.609,0.75,0,'线 '),COLORWHITE;
DRAWTEXT_FIX(C>0,0.98,0.12,0,'M'),COLORWHITE;
DRAWTEXT_FIX(C>0,0.981,0.34,0,'A'),COLORWHITE;
DRAWTEXT_FIX(C>0,0.98,0.56,0,'C'),COLORWHITE;
DRAWTEXT_FIX(C>0,0.98,0.78,0,'D'),COLORWHITE;
DRAWRECTREL(0,0,290,1000,RGB(45,75,45));
DRAWRECTREL(5,10,70,990,RGB(45,75,45));
DRAWRECTREL(70,10,235,990,RGB(130,110,40));
DRAWRECTREL(125,10,180,990,RGB(45,75,45));
DRAWRECTREL(5,10,290,10,RGB(200,200,200));
DRAWRECTREL(5,150,290,150,RGB(200,200,200));
DRAWRECTREL(5,290,290,290,RGB(200,200,200));
DRAWRECTREL(5,430,290,430,RGB(200,200,200));
DRAWRECTREL(5,570,290,570,RGB(200,200,200));
DRAWRECTREL(5,710,290,710,RGB(200,200,200));
DRAWRECTREL(5,850,290,850,RGB(200,200,200));
DRAWRECTREL(5,990,290,990,RGB(200,200,200));
AX1:=STRCAT(STRCAT(STRCAT(STRCAT('日 期' ,' 测 高') ,' 实高') ,' 测 低') ,' 实低');
DRAWTEXT_FIX(C>0,0.02,0.04,0,AX1),COLORYELLOW;
DRAWTEXT_FIX(C>0,0.01,0.88,0,' 今 ' ),COLORWHITE;
AAAS:=STRCAT(CON2STR(DAY,0),'日');
DRAWTEXT_FIX(C>0,0.03,0.88,0,AAAS),COLORWHITE;
BB1:=STRCAT(CON2STR(REF(MONTH,1),0),'月');
BB2:=STRCAT(CON2STR(REF(DAY,1),0),'日');
BB3:=STRCAT(BB1,BB2);
DRAWTEXT_FIX(C>0,0.01,0.74,0,BB3),COLORWHITE;
CC1:=STRCAT(CON2STR(REF(MONTH,2),0),'月');
CC2:=STRCAT(CON2STR(REF(DAY,2),0),'日');
CC3:=STRCAT(CC1,CC2);
DRAWTEXT_FIX(C>0,0.01,0.6,0,CC3),COLORWHITE;
DD1:=STRCAT(CON2STR(REF(MONTH,3),0),'月');
DD2:=STRCAT(CON2STR(REF(DAY,3),0),'日');
DD3:=STRCAT(DD1,DD2);
DRAWTEXT_FIX(C>0,0.01,0.46,0,DD3),COLORWHITE;
EE1:=STRCAT(CON2STR(REF(MONTH,4),0),'月');
EE2:=STRCAT(CON2STR(REF(DAY,4),0),'日');
EE3:=STRCAT(EE1,EE2);
DRAWTEXT_FIX(C>0,0.01,0.32,0,EE3),COLORWHITE;
FF1:=STRCAT(CON2STR(REF(MONTH,5),0),'月');
FF2:=STRCAT(CON2STR(REF(DAY,5),0),'日');
FF3:=STRCAT(FF1,FF2);
DRAWTEXT_FIX(C>0,0.01,0.18,0,FF3),COLORWHITE;
上涨值:=MA((H+REF(L,1))/2,3);
下跌值:=MA((REF(H,1)+L)/2,3);
买进高点:=MA((H+REF(H,1))/2,3);
卖出低点:=MA((REF(L,1)+L)/2,3);
买值:=((O+H+L+2*C)/5)*2-L;
卖值:=((O+H+L+2*C)/5)*2-H;
突破买入值:=MA(买值,3);
突破卖出值:=MA(卖值,3);
测高:=(上涨值+买进高点+突破买入值+H)/4;
测低:=(下跌值+卖出低点+突破卖出值+L)/4;
低价1:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(测高,2),' '),STRCAT(CON2STR(H,2),' ')),STRCAT(CON2STR(测低,2),' ')),CON2STR(L,2)) ;
低价2:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测高,1),2),' '),STRCAT(CON2STR(REF(H,1),2),' ')),STRCAT(CON2STR(REF(测低,1),2),' ')),CON2STR(REF(L,1),2)) ;
低价3:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测高,2),2),' '),STRCAT(CON2STR(REF(H,2),2),' ')),STRCAT(CON2STR(REF(测低,2),2),' ')),CON2STR(REF(L,2),2)) ;
低价4:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测高,3),2),' '),STRCAT(CON2STR(REF(H,3),2),' ')),STRCAT(CON2STR(REF(测低,3),2),' ')),CON2STR(REF(L,3),2)) ;
低价5:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测高,4),2),' '),STRCAT(CON2STR(REF(H,4),2),' ')),STRCAT(CON2STR(REF(测低,4),2),' ')),CON2STR(REF(L,4),2)) ;
低价6:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测高,5),2),' '),STRCAT(CON2STR(REF(H,5),2),' ')),STRCAT(CON2STR(REF(测低,5),2),' ')),CON2STR(REF(L,5),2)) ;
中价1:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(测高,2),' '),STRCAT(CON2STR(H,2),' ')),STRCAT(CON2STR(测低,2),' ')),CON2STR(L,2)) ;
中价2:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测高,1),2),' '),STRCAT(CON2STR(REF(H,1),2),' ')),STRCAT(CON2STR(REF(测低,1),2),' ')),CON2STR(REF(L,1),2)) ;
中价3:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测高,2),2),' '),STRCAT(CON2STR(REF(H,2),2),' ')),STRCAT(CON2STR(REF(测低,2),2),' ')),CON2STR(REF(L,2),2)) ;
中价4:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测高,3),2),' '),STRCAT(CON2STR(REF(H,3),2),' ')),STRCAT(CON2STR(REF(测低,3),2),' ')),CON2STR(REF(L,3),2)) ;
中价5:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测高,4),2),' '),STRCAT(CON2STR(REF(H,4),2),' ')),STRCAT(CON2STR(REF(测低,4),2),' ')),CON2STR(REF(L,4),2)) ;
中价6:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测高,5),2),' '),STRCAT(CON2STR(REF(H,5),2),' ')),STRCAT(CON2STR(REF(测低,5),2),' ')),CON2STR(REF(L,5),2)) ;
中高1:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(测高,2),' '),STRCAT(CON2STR(H,2),' ')),STRCAT(CON2STR(测低,2),' ')),CON2STR(L,2)) ;
中高2:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测高,1),2),' '),STRCAT(CON2STR(REF(H,1),2),' ')),STRCAT(CON2STR(REF(测低,1),2),' ')),CON2STR(REF(L,1),2)) ;
中高3:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测高,2),2),' '),STRCAT(CON2STR(REF(H,2),2),' ')),STRCAT(CON2STR(REF(测低,2),2),' ')),CON2STR(REF(L,2),2)) ;
中高4:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测高,3),2),' '),STRCAT(CON2STR(REF(H,3),2),' ')),STRCAT(CON2STR(REF(测低,3),2),' ')),CON2STR(REF(L,3),2)) ;
中高5:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测高,4),2),' '),STRCAT(CON2STR(REF(H,4),2),' ')),STRCAT(CON2STR(REF(测低,4),2),' ')),CON2STR(REF(L,4),2)) ;
中高6:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测高,5),2),' '),STRCAT(CON2STR(REF(H,5),2),' ')),STRCAT(CON2STR(REF(测低,5),2),' ')),CON2STR(REF(L,5),2)) ;
高价1:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(测高,2),' '),STRCAT(CON2STR(H,2),' ')),STRCAT(CON2STR(测低,2),' ')),CON2STR(L,2)) ;
高价2:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测高,1),2),' '),STRCAT(CON2STR(REF(H,1),2),' ')),STRCAT(CON2STR(REF(测低,1),2),' ')),CON2STR(REF(L,1),2)) ;
高价3:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测高,2),2),' '),STRCAT(CON2STR(REF(H,2),2),' ')),STRCAT(CON2STR(REF(测低,2),2),' ')),CON2STR(REF(L,2),2)) ;
高价4:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测高,3),2),' '),STRCAT(CON2STR(REF(H,3),2),' ')),STRCAT(CON2STR(REF(测低,3),2),' ')),CON2STR(REF(L,3),2)) ;
高价5:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测高,4),2),' '),STRCAT(CON2STR(REF(H,4),2),' ')),STRCAT(CON2STR(REF(测低,4),2),' ')),CON2STR(REF(L,4),2)) ;
高价6:=VARCAT(VARCAT(VARCAT(STRCAT(CON2STR(REF(测高,5),2),' '),STRCAT(CON2STR(REF(H,5),2),' ')),STRCAT(CON2STR(REF(测低,5),2),' ')),CON2STR(REF(L,5),2)) ;
QQ1:=IF(CONST(测高)<10,低价1,IF(CONST(测高)<100,中价1,IF( CONST(测高)<900 ,中高1,高价1)));
QQ2:=IF(CONST(REF(测高,1))<10,低价2,IF(CONST(REF(测高,1))<100,中价2,IF(CONST(REF(测高,1))<900,中高2,高价2)));
QQ3:=IF(CONST(REF(测高,2))<10,低价3,IF(CONST(REF(测高,2))<100,中价3,IF(CONST(REF(测高,1))<900,中高3,高价3)));
QQ4:=IF(CONST(REF(测高,3))<10,低价4,IF(CONST(REF(测高,3))<100,中价4,IF(CONST(REF(测高,1))<900,中高4,高价4)));
QQ5:=IF(CONST(REF(测高,4))<10,低价5,IF(CONST(REF(测高,4))<100,中价5,IF(CONST(REF(测高,1))<900,中高5,高价5)));
QQ6:=IF(CONST(REF(测高,5))<10,低价6,IF(CONST(REF(测高,5))<100,中价6,IF(CONST(REF(测高,1))<900,中高6,高价6)));
DRAWTEXT_FIX(C>0,0.073,0.88,0,QQ1),COLORWHITE;
DRAWTEXT_FIX(C>0,0.073,0.74,0,QQ2),COLORWHITE;
DRAWTEXT_FIX(C>0,0.073,0.6,0,QQ3),COLORWHITE;
DRAWTEXT_FIX(C>0,0.073,0.46,0,QQ4),COLORWHITE;
DRAWTEXT_FIX(C>0,0.073,0.32,0,QQ5),COLORWHITE;
DRAWTEXT_FIX(C>0,0.073,0.18,0,QQ6),COLORWHITE;

通达信综合参谋指标公式

 

相关文章