在线检测未来函数

通达信MACD顶底钝化指标公式

来源:Internet,编辑:股旁网,2018-02-01

DIF:EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:EMA(DIF,9);
MACD:(DIF-DEA)*2,COLORSTICK;
SWIFTK:='MACD.MACD' * REF('MACD.MACD',1)<0;
EARLYDAY_1:=BARSLAST(REF(SWIFTK,1));
EARLYDAY_2:=BARSLAST(REF(SWIFTK,2));
EARLYDAY_3:=BARSLAST(REF(SWIFTK,3));
EARLYDAY_4:=BARSLAST(REF(SWIFTK,4));
EARLYDAY_5:=BARSLAST(REF(SWIFTK,5));
CLOW_0:=REF(LLV(MIN(O,C),EARLYDAY_5-EARLYDAY_4-1),EARLYDAY_4+2);
CLOW_1:=REF(LLV(MIN(O,C),EARLYDAY_3-EARLYDAY_2-1),EARLYDAY_2+2);
CLOW_2:=LLV(MIN(O,C),EARLYDAY_1);
DIFFLOW_0:=REF(LLV('MACD.DIFF',EARLYDAY_5-EARLYDAY_4-1),EARLYDAY_4+2);
DIFFLOW_1:=REF(LLV('MACD.DIFF',EARLYDAY_3-EARLYDAY_2-1),EARLYDAY_2+2);
DIFFLOW_2:=LLV('MACD.DIFF',EARLYDAY_1);
钝化L:=
'MACD.MACD'<0 AND (
(INTPART(DIFFLOW_2)-INTPART(DIFFLOW_1)>0 AND CLOW_1>CLOW_2) OR
(INTPART(DIFFLOW_2)-INTPART(DIFFLOW_0)>0 AND CLOW_0>CLOW_2)
);
结构L:=
'MACD.MACD'<0 AND INTPART('MACD.DIFF')>REF(INTPART('MACD.DIFF'),1) AND (
(INTPART(DIFFLOW_2)-INTPART(DIFFLOW_1)>0 AND CLOW_1>CLOW_2 AND INTPART('MACD.DIFF')>INTPART(DIFFLOW_2)) OR
(INTPART(DIFFLOW_2)-INTPART(DIFFLOW_0)>0 AND CLOW_0>CLOW_2 AND INTPART('MACD.DIFF')>INTPART(DIFFLOW_2))
);
DRAWTEXT(钝化L,'MACD.DIFF','L');
DRAWICON(结构L,'MACD.DIFF',4);
CHIGH_0:=REF(HHV(MAX(O,C),EARLYDAY_5-EARLYDAY_4-1),EARLYDAY_4+2);
CHIGH_1:=REF(HHV(MAX(O,C),EARLYDAY_3-EARLYDAY_2-1),EARLYDAY_2+2);
CHIGH_2:=HHV(MAX(O,C),EARLYDAY_1);
DIFFHIGH_0:=REF(HHV('MACD.DIFF',EARLYDAY_5-EARLYDAY_4-1),EARLYDAY_4+2);
DIFFHIGH_1:=REF(HHV('MACD.DIFF',EARLYDAY_3-EARLYDAY_2-1),EARLYDAY_2+2);
DIFFHIGH_2:=HHV('MACD.DIFF',EARLYDAY_1);
钝化H:=
'MACD.MACD'>0 AND (
(INTPART(DIFFHIGH_2)-INTPART(DIFFHIGH_1)<0 AND CHIGH_1<CHIGH_2) OR
(INTPART(DIFFHIGH_2)-INTPART(DIFFHIGH_0)<0 AND CHIGH_0<CHIGH_2)
);
结构H:=
'MACD.MACD'>0 AND INTPART('MACD.DIFF')<REF(INTPART('MACD.DIFF'),1) AND(
(INTPART(DIFFHIGH_2)-INTPART(DIFFHIGH_1)<0 AND CHIGH_1<CHIGH_2 AND INTPART('MACD.DIFF')<INTPART(DIFFHIGH_2)) OR
(INTPART(DIFFHIGH_2)-INTPART(DIFFHIGH_0)<0 AND CHIGH_0<CHIGH_2 AND INTPART('MACD.DIFF')<INTPART(DIFFHIGH_2))
);
DRAWTEXT(钝化H,'MACD.DIFF'*1.02,'H'),COLORGREEN;
DRAWICON(结构H,'MACD.DIFF',5),COLORGREEN;

通达信MACD顶底钝化指标公式

 

相关文章