在线检测未来函数

通达信创赢解盘主图指标公式

来源:Internet,编辑:股旁网,2018-02-14

M1:=3;M2:=6;M3:=9;M4:=18;M5:=21;M6:=24;M7:=48;M8:=55;M9:=62;
PBX1:(EMA(CLOSE,M1)+MA(CLOSE,M1*2)+MA(CLOSE,M1*4))/3,COLORGREEN DOTLINE;
PBX2:(EMA(CLOSE,M2)+MA(CLOSE,M2*2)+MA(CLOSE,M2*4))/3, COLORGREEN DOTLINE;
PBX3:(EMA(CLOSE,M3)+MA(CLOSE,M3*2)+MA(CLOSE,M3*4))/3 ,COLORGREEN DOTLINE;
PBX4:(EMA(CLOSE,M4)+MA(CLOSE,M4*2)+MA(CLOSE,M4*4))/3, COLORFF9900 DOTLINE;
PBX5:(EMA(CLOSE,M5)+MA(CLOSE,M5*2)+MA(CLOSE,M5*4))/3, COLORFF9900 DOTLINE;
PBX6:(EMA(CLOSE,M6)+MA(CLOSE,M6*2)+MA(CLOSE,M6*4))/3, COLORFF9900 DOTLINE;
PBX7:(EMA(CLOSE,M7)+MA(CLOSE,M7*2)+MA(CLOSE,M7*4))/3, COLORGREEN DOTLINE;
PBX8:(EMA(CLOSE,M8)+MA(CLOSE,M8*2)+MA(CLOSE,M8*4))/3 ,COLORGREEN DOTLINE;
PBX9:(EMA(CLOSE,M9)+MA(CLOSE,M9*2)+MA(CLOSE,M9*4))/3, COLORGREEN DOTLINE;
IF(PBX1>=REF(PBX1,1),PBX1,DRAWNULL),COLORRED,LINETHICK1 DOTLINE;
IF(PBX2>=REF(PBX2,1),PBX2,DRAWNULL),COLORRED,LINETHICK1 DOTLINE;
IF(PBX3>=REF(PBX3,1),PBX3,DRAWNULL),COLORRED,LINETHICK1 DOTLINE;
IF(PBX4>=REF(PBX4,1),PBX4,DRAWNULL),COLOR0080FF,LINETHICK1 DOTLINE;
IF(PBX5>=REF(PBX5,1),PBX5,DRAWNULL),COLOR0080FF,LINETHICK1 DOTLINE;
IF(PBX6>=REF(PBX6,1),PBX6,DRAWNULL),COLOR0080FF,LINETHICK1 DOTLINE;
IF(PBX7>=REF(PBX7,1),PBX7,DRAWNULL),COLORFF00FF,LINETHICK1 DOTLINE;
IF(PBX8>=REF(PBX8,1),PBX8,DRAWNULL),COLORFF00FF,LINETHICK1 DOTLINE;
IF(PBX9>=REF(PBX9,1),PBX9,DRAWNULL),COLORFF00FF,LINETHICK1 DOTLINE;
{涨停}
STICKLINE(CLOSE>REF(CLOSE,1)*1.0985 AND CLOSE=HIGH,CLOSE,OPEN,4,-1),COLOR00FFFF;
{跌停}{WWW.88GS.COM}
STICKLINE(CLOSE<REF(CLOSE,1)*0.9015 AND CLOSE=LOW,CLOSE,OPEN,4,-1),COLORGREEN;
{蓝}
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,3,0),COLORFF7700;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,2.2,0),COLORFF9900;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,1.5,0),COLORFFBB00;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,0.5,0),COLORCYAN;
{红}
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0),COLOR000099;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2.2,0),COLOR0000CC;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1.5,0),COLOR0000FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0.5,0),COLORCC66FF;
{量比5分钟}主力量能:=(VOL+REF(V,2)+REF(V,3)+REF(V,4)+REF(V,5))/3.3 COLOR00FFFF LINETHICK1 DOTLINE;
{量比10}市场量能:=(REF(V,6)+REF(V,7)+REF(V,8)+REF(V,9)+REF(V,10)+REF(V,11)+REF(V,12)+REF(V,13)+REF(V,14)+REF(V,15))/3.3 COLORFF9900,DOTLINE;
Z1A:=STRCAT(HYBLOCK,' ');
Z2A:=STRCAT(Z1A,FGBLOCK);
Z3A:=STRCAT(Z2A,DYBLOCK);
Z4A:=STRCAT(Z3A,' ');
DRAWTEXT_FIX(ISLASTBAR,0.3,0.99,0,STRCAT(Z4A,GNBLOCK)),COLORCYAN;
{T+1止赢止损}
CC:=IF(CURRBARSCOUNT<21,CONST(REF(C,2)),DRAWNULL),COLORWHITE;
止赢:=1.05*CC,COLORYELLOW;
止损:=0.97*CC,COLORFF6EC7;
STICKLINE(CC,CC,CC,3,1),COLORFF8918;
STICKLINE(止赢,止赢,止赢,3,1),COLORYELLOW;
STICKLINE(止损,止损,止损,3,1),COLORWHITE;
MA10:=MA(C,10)COLOR00FF00 LINETHICK1 DOTLINE;
BB05:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416;
IF(BB05>25,MA10,DRAWNULL),LINETHICK3,COLORFF9900 ;
IF(BB05>35,MA10,DRAWNULL),LINETHICK3,COLORGREEN;
IF(BB05>50,MA10,DRAWNULL),LINETHICK3,COLORRED;
TT:=240/FROMOPEN;
比:=TT;{WWW.88GS.COM}
促进指数MFL:=(HIGH-LOW)*1000000/(VOL*比),COLORRED;
AY2:=EMA(CLOSE,12)-EMA(CLOSE,26);
AZ2:=EMA(AY2,9);
LT2:=(AY2-AZ2);
L211:=IF(LT2,LLV(L,21),DRAWNULL),COLOR217158,CIRCLEDOT;
ZGD:=HHV(H,80)*0.99;
ZGD2:=CONST(ZGD);
ZDD:=LLV(L211,80);
ZDD2:=CONST(ZDD);
YYA4:=MA(CLOSE,20);
YYA5:=(CLOSE > MA(CLOSE,5));
YYA6:=(MA(CLOSE,5) > MA(CLOSE,10));
YYA7:=(CLOSE > MA(CLOSE,10));
YYA8:=(MA(CLOSE,5) > MA(CLOSE,20));
YYA9:=(CLOSE>MA(CLOSE,20));
YYA10:=REF(YYA4,1);
YYA11:=(YYA4>YYA10);
YYAVX:=(((((IF(YYA5,10,(0 - 10)) + IF(YYA6,10,(0 - 10))) + IF(YYA7,10,(0 - 10))) + IF(YYA8,10,(0 - 10))) + IF(YYA9,10,(0 - 10))) + IF(YYA11,10,(0 - 10)));
DSLX:=(CLOSE/INDEXC);
DSLX1:=MA(DSLX,5);
DSLX2:=MA(DSLX,10);
YYV1:=MA(VOL,5);
YYV2:=MA(VOL,60);
J1:=CONST(IF( YYAVX > 0,200,100));
J2:=CONST(IF( YYAVX > 0,00,100));
J3:=CONST(IF( YYAVX > 0,100,100));
ZGD3:=ZGD2;
ZDD3:=ZDD2;
ZGD4:=ZGD2;
情况1:=CONST(IF(((CROSS(YYAVX,1) AND (YYV1 >= YYV2)) AND (DSLX >= DSLX1)),1,0)),NODRAW;
情况2:=CONST(IF(((CROSS(YYAVX,1) AND (YYV1 < YYV2)) AND (DSLX >= DSLX1)),1,0));
情况3:=CONST(IF(((CROSS(YYAVX,1) AND (YYV1 > YYV2)) AND (DSLX < DSLX1)),1,0));
情况4:=CONST(IF(((CROSS(YYAVX,1) AND (YYV1 <= YYV2)) AND (DSLX < DSLX1)),1,0));
情况5:=CONST(IF(((CROSS(1,YYAVX) AND (YYV1 >= YYV2)) AND (DSLX >= DSLX1)),1,0));
情况6:=CONST(IF(((CROSS(1,YYAVX) AND (YYV1 < YYV2)) AND (DSLX >= DSLX1)),1,0));
情况7:=CONST(IF(((CROSS(1,YYAVX) AND (YYV1 >= YYV2)) AND (DSLX < DSLX1)),1,0));
情况8:=CONST(IF(((CROSS(1,YYAVX) AND (YYV1 < YYV2)) AND (DSLX < DSLX1)),1,0));
情况9:=CONST(IF(((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 >= YYV2)) AND (DSLX >= DSLX1)),1,0));
情况10:=CONST(IF(((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 < YYV2)) AND (DSLX >= DSLX1)),1,0));
情况11:=CONST(IF(((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 >= YYV2)) AND (DSLX < DSLX1)),1,0)),NODRAW;
情况12:=CONST(IF(((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 < YYV2)) AND (DSLX < DSLX1)),1,0));
情况13:=CONST(IF(((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 >= YYV2)) AND (DSLX >= DSLX1)),1,0));
情况14:=CONST(IF(((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 < YYV2)) AND (DSLX >= DSLX1)),1,0));
情况15:=CONST(IF(((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 >= YYV2)) AND (DSLX < DSLX1)),1,0));
情况16:=CONST(IF(((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 < YYV2)) AND (DSLX < DSLX1)),1,0));
大盘1:=CONST(IF((CROSS(YYAVX,1) AND (YYV1 >= YYV2)),1,0));
大盘2:=CONST(IF((CROSS(YYAVX,1) AND (YYV1 < YYV2)),1,0));
大盘3:=CONST(IF((CROSS(1,YYAVX) AND (YYV1 >= YYV2)),1,0));
大盘4:=CONST(IF((CROSS(1,YYAVX) AND (YYV1 < YYV2)),1,0));
大盘5:=CONST(IF((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 >= YYV2)),1,0));
大盘6:=CONST(IF((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 < YYV2)),1,0));
大盘7:=CONST(IF((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 >= YYV2)),1,0));
大盘8:=CONST(IF((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 < YYV2)),1,0));
MFI:=(HIGH-LOW)*1000000/(VOL*比);
绿灯:=MFI>=REF(MFI,1)AND VOL*比>=REF(VOL,1);
MMM1:=CONST(绿灯);{WWW.88GS.COM}
衰退:=MFI<REF(MFI,1)AND VOL*比<REF(VOL,1);
蛰伏:=MFI<REF(MFI,1)AND VOL*比>=REF(VOL,1);
MMM4:=CONST(蛰伏);
TS1:=IF(情况1=1,0.06+0.06,0.06); TS2:=IF(情况2=1,TS1+0.06,TS1);
TS3:=IF(情况3=1,TS2+0.06,TS2); TS4:=IF(情况4=1,TS3+0.06,TS3);
TS5:=IF(情况5=1,TS4+0.06,TS4); TS6:=IF(情况6=1,TS5+0.06,TS5);
TS7:=IF(情况7=1,TS6+0.06,TS6); TS8:=IF(情况8=1,TS7+0.06,TS7);
TS9:=IF(情况9=1,TS8+0.06,TS8); TS10:=IF(情况10=1,TS9+0.06,TS9);
TS11:=IF(情况11=1,TS10+0.06,TS10); TS12:=IF(情况12=1,TS11+0.06,TS11);
TS13:=IF(情况13=1,TS12+0.06,TS12); TS14:=IF(情况14=1,TS13+0.06,TS13);
TS15:=IF(情况15=1,TS14+0.06,TS14); TS16:=IF(情况16=1,TS15+0.06,TS15);
TS17:=IF(大盘1=1,TS16+0.06,TS16); TS18:=IF(大盘2=1,TS17+0.06,TS17);
TS19:=IF(大盘3=1,TS18+0.06,TS18); TS20:=IF(大盘4=1,TS19+0.06,TS19);
TS21:=IF(大盘5=1,TS20+0.06,TS20); TS22:=IF(大盘6=1,TS21+0.06,TS21);
TS23:=IF(大盘7=1,TS22+0.06,TS22); TS24:=IF(大盘8=1,TS23+0.06,TS23);
TS25:=IF(MMM1=1,TS24+0.06,TS24);
DRAWTEXT_FIX(情况1=1 ,0.05,TS1,0,'量能理想,明显走强,中线参与,仓位在2/3左右'),COLORFF00FF;
DRAWTEXT_FIX(情况2=1 ,0.05,TS2,0,'走势趋强量能不足,短线进场,仓位在1/2左右'),COLORFF00FF;
DRAWTEXT_FIX(情况3=1 ,0.05,TS3,0,'量价良好,并没有明显走强,短线进场,仓位1/2左右。'),COLORFF00FF;
DRAWTEXT_FIX(情况4=1 ,0.05,TS4,0,'形态尚可,量能不足,未完全走强,短线参与,仓位1/3左右。'),COLORFF00FF;
DRAWTEXT_FIX(情况5=1 ,0.05,TS5,0,'形态变坏,走势尚可,重仓减大半,清仓者观望。'),COLOR00FFFF;
DRAWTEXT_FIX(情况6=1 ,0.05,TS6,0,'随大盘一起下跌,明显缩量走势,考虑大盘风险,减持或清仓。'),COLOR00FFFF;
DRAWTEXT_FIX(情况7=1 ,0.05,TS7,0,'该股放量下跌,走势明显偏弱,离场观望。'),COLORFFFFFF;
DRAWTEXT_FIX(情况8=1 ,0.05,TS8,0,'该股缩量下跌,走势偏弱,离场观望。'),COLORFFFF00;
DRAWTEXT_FIX(情况9=1 ,0.05,TS9,0,'该股形态良好,强势明显,量能充足,可以继续持有。'),COLOR00FFFF;
DRAWTEXT_FIX(情况10=1,0.05,TS10,0,'该股上行趋势不变,强势依然,但量能开始转弱,注意风险'),COLOR00FFFF;
DRAWTEXT_FIX(情况11=1,0.05,TS11,0,'该股仍然具备上涨潜力,但股性偏弱,可考虑减仓。'),COLORFFFFFF;
DRAWTEXT_FIX(情况12=1,0.05,TS12,0,'该股走势趋弱,量能不足,减持大部分筹码'),COLORFFFF00;
DRAWTEXT_FIX(情况13=1,0.05,TS13,0,'该股形态不佳,注意成交量的变化,但目前不适合参与。'),COLORFFFF00;
DRAWTEXT_FIX(情况14=1,0.05,TS14,0,'该股趋势不明,股价偏弱,注意量能变化,目前不宜参与。'),COLORFFFF00;
DRAWTEXT_FIX(情况15=1,0.05,TS15,0,'有走强迹象,但量能不足,趋势不明,不适合操作'),COLORFFFF00;
DRAWTEXT_FIX(情况16=1,0.05,TS16,0,'该股走势太弱,没有参与价值。'),COLORFFFFFF;
DRAWTEXT_FIX(大盘1,0.05,TS17,0,'总势量能理想,2/3仓位, 前一轮下跌,是否最佳买点,否则谨慎介入。'),COLOR00FF00;
DRAWTEXT_FIX(大盘2,0.05,TS18,0,'总势趋强,量能不足,若前一轮下跌,短线进场1/2,量能放大加仓。'),COLORFF00FF;
DRAWTEXT_FIX(大盘3,0.05,TS19,0,'总势形态走坏,重仓者可以减去大部分仓位。'),COLORAAAAAA;
DRAWTEXT_FIX(大盘4,0.05,TS20,0,'总势缩量调整,注意风险,短线清仓观望。'),COLORFFFFFF;
DRAWTEXT_FIX(大盘5,0.05,TS21,0,'总势走势良好,量能理想,可以继续持有强势股。'),COLOR00FFFF;
DRAWTEXT_FIX(大盘6,0.05,TS22,0,'总势形态良好,但量能稍显不足,随时准备减仓'),COLOR00FF00;
DRAWTEXT_FIX(大盘7,0.05,TS23,0,'总势趋势不明,注意成交量变化,目前不适宜进场。'),COLORFFFFFF;
DRAWTEXT_FIX(大盘8,0.05,TS24,0,'总势趋势向下,量能萎缩,不适合进场。'),COLORFFFFFF;
天使:=EMA(C,3),COLOR000000;
魔鬼:=EMA(SLOPE(C,21)*20+C,42),COLOR000000;
买:=CROSS(天使,魔鬼) AND (MA(C,5)>=MA(C,60) AND ((MA(C,10)>=MA(C,60) OR MA(C,10)>MA(C,89)) AND MA(C,5)>MA(C,20)) OR L>REF(H,1));
卖:=CROSS(魔鬼,天使);
ZT:=CLOSE>REF(CLOSE,1)*1.08;
JXG:=C>MA(C,20) AND C>MA(C,30) AND C>MA(C,60) AND C>MA(C,120) AND C>MA(C,250);
JXTJ:=MA(C,5)>MA(C,30) AND MA(C,10)>MA(C,30) AND MA(C,20)>=MA(C,60) AND MA(C,20)>REF(MA(C,20),1);
MA1:=MA(CLOSE,5);
MA2:=MA(CLOSE,13);
MA3:=MA(CLOSE,21);
AQ:=MAX(MAX(MA1,MA2),MA3);
B:=MIN(MIN(MA1,MA2),MA3);
DSXN:=RANGE(100*(AQ-B)/B,0,5),100*(AQ-B)/B<13;
M60:=MA(CLOSE,60);
M70:=MA(CLOSE,89);
M80:=MA(CLOSE,120);
LD:=MAX(MAX(M60,M70),M80);
LX:=MIN(MIN(M60,M70),M80);
JXZQ:=RANGE(100*(LD-LX)/LX,0,5),100*(LD-LX)/LX<16;
ZTTS:=COUNT(ZT,150)>=1 AND DSXN AND JXZQ AND JXG AND JXTJ AND NOT(REF(ZT,1));
DRAWICON(买 AND ZTTS,L*0.98,1);
DRAWTEXT(买 AND ZTTS,L*0.96,'B'),COLORYELLOW;
STICKLINE(买 AND ZTTS,O,L,0.5,0),COLORYELLOW;
STICKLINE(CROSS(魔鬼,天使),OPEN,C,2.5,0),COLORLIGREEN;
涨停:=C>REF(C,1)*1.09 AND C=H;
STICKLINE(涨停,OPEN,CLOSE,4,0),COLORRED;
STICKLINE(涨停,OPEN,CLOSE,3,0),COLORYELLOW;

通达信创赢解盘主图指标公式

 

相关文章