在线检测未来函数

macd连续三次底背离的选股公式

来源:Internet,编辑:股旁网,2018-02-28

编写要求:

DIF连续三次金叉,并且DIF金叉时的数值每次都比上一次大,股价每次都比上一次低。

股旁网解答:

MACD:=(DIF-DEA)*2,COLORSTICK;
T:=BARSLAST(CROSS(DIF,DEA) AND DIF<0);
T1:=SUMBARS(T=0,2);
T2:=SUMBARS(T=0,3);
M:=BARSLAST(CROSS(0,MACD));
M1:=SUMBARS(M=0,2);
M2:=SUMBARS(M=0,3);
D1:=REF(DIF,BARSLAST(DIF=LLV(DIF,M+1)));
D2:=REF(D1,T1-1);
D3:=REF(D2,T1-1);
LT:=BARSLAST(L=LLV(L,M+1));
MT:=BARSLAST(DIF=LLV(DIF,M+1));
L1:=REF(L,LT);
L2:=REF(L1,T1-1);
L3:=REF(L2,T1-1);
XG:T=0 AND L1<L2 AND L2<L3 AND D1>D2 AND D2>D3;

相关文章