在线检测未来函数

通达信珍藏操盘主图指标公式

来源:Internet,编辑:股旁网,2018-03-09

{使用说明:1、当指标发出“立刻出击”或“↑买”信号,股价一路上涨;在股价下跌之前的顶部,它能准确发出“↓卖”信号,提示立即规避风险。2、当出现粉红区域盘整时,密切关注或逐步建仓。一旦出现浅黄金柱和“迅速出击”说明底部盘整结束,短牛第一时间买入。}

短牛分界线:MA(C,13),COLOR0066FF,LINETHICK2;STICKLINE(C>短牛分界线,L,H,0,0),COLORRED;
STICKLINE(C>短牛分界线,O,C,3,0),COLOR000088;STICKLINE(C>短牛分界线,O,C,2,0),COLOR0000AA;
STICKLINE(C>短牛分界线,O,C,0.1,0),COLOR0000CC;STICKLINE(C>短牛分界线,O,C,0,0),COLOR0000FF;
BICCUP1:=MA((C-MA(C,13))/MA(C,13),3)*100,COLORWHITE,LINETHICK0;
BICCUP3:=MA((C-MA(C,34))/MA(C,34),3)*100,COLORFF00FF,LINETHICK0;
进入视野区域:=COUNT(BICCUP3<0,8)>=8 AND COUNT(BICCUP3>0,34)>13 AND COUNT(BICCUP3<0,55)>30 OR BICCUP3<-15,LINETHICK0;
STICKLINE(进入视野区域,C,O,3,0),COLOR8977FF;STICKLINE(进入视野区域,L,H,0,0),COLOR8977FF;
迅速出击:=CROSS(BICCUP1,0) AND SUM(IF(BICCUP3<-15,10,0),8)>10,LINETHICK0;
STICKLINE(迅速出击,C,O,3,0),COLOR0066BB;STICKLINE(迅速出击,C,O,2,0),COLOR0099CC;
STICKLINE(迅速出击,C,O,1,0),COLOR00CCEE;STICKLINE(迅速出击,C,O,0.1,0),COLOR00FFFF;
STICKLINE(迅速出击,L,H,0,0),COLOR00FFFF;DRAWTEXT(迅速出击,C*0.97,'迅速出击'),COLOR0000FF;
LC:=REF(C,1),LINETHICK0;RSI:=((SMA(MAX((C-LC),0),13,1)/SMA(ABS((C-LC)),13,1))*100);
STICKLINE((RSI<20),L,H,0.1,0),COLORFF6600;STICKLINE((RSI<20),O,C,8,0),COLORCC5000;
DRAWTEXT(CROSS(RSI,20-0.0005),L*0.97,'短牛'),COLORAA99AA;
STICKLINE(CROSS(RSI,20-0.0005),C,O,3,0),COLOR888888;
STICKLINE(CROSS(RSI,20-0.0005),C,O,2,0),COLORAAAAAA;
STICKLINE(CROSS(RSI,20-0.0005),C,O,1,0),COLORCCCCCC;
STICKLINE(CROSS(RSI,20-0.0005),C,O,0.1,0),COLORFFFFFF;
STICKLINE(CROSS(RSI,20-0.0005),L,H,0,0),COLORFFFFFF;
RSV:=(((C-LLV(L,9))/(HHV(H,9)-LLV(L,9)))*100);
猛马:=SMA(RSV,3,1);
D:=SMA(猛马,3,1);
牛来了:=((C>LC) AND C>O);
K猛马:=HHV(猛马,5);
白猛马:=HHV(D,5);
D1:=REF(D,1);K1:=REF(猛马,1);
STICKLINE(((白猛马>75) AND CROSS(D,猛马)),C,O,3,0),COLOR008800;
STICKLINE(((白猛马>75) AND CROSS(D,猛马)),C,O,2,0),COLOR00AA00;
STICKLINE(((白猛马>75) AND CROSS(D,猛马)),C,O,1,0),COLOR00CC00;
STICKLINE(((白猛马>75) AND CROSS(D,猛马)),C,O,0.1,0),COLOR00FF00;
STICKLINE(((白猛马>75) AND CROSS(D,猛马)),L,H,0,0),COLOR00FF00;
STICKLINE((((D1<30) AND CROSS(猛马,D)) AND 牛来了),C,O,3,0),COLOR0011FF;
STICKLINE((((D1<30) AND CROSS(猛马,D)) AND 牛来了),C,O,2,0),COLOR0044FF;
STICKLINE((((D1<30) AND CROSS(猛马,D)) AND 牛来了),C,O,1,0),COLOR0077FF;
STICKLINE((((D1<30) AND CROSS(猛马,D)) AND 牛来了),C,O,0.1,0),COLOR0099FF;
STICKLINE((((D1<30) AND CROSS(猛马,D)) AND 牛来了),L,H,0,0),COLOR0099FF;
DRAWTEXT((((D1<30) AND CROSS(猛马,D)) AND 牛来了),L,'立刻出击'),COLOR0066FF;
DRAWTEXT((((D1<30) AND CROSS(猛马,D)) AND 牛来了),L*0.95,'↑买'),COLORFFAAFF;
DRAWTEXT(((白猛马>75) AND CROSS(D,猛马)),H*1.05,'↓卖'),COLOR00CC00;
GXL1:=MA(C,13);
GXL:=ATAN((GXL1-REF(GXL1,1)))*180/2;
STICKLINE(GXL>1 AND GXL1>REF(GXL1,1),GXL1,REF(GXL1,1),5,0),COLOR00FFFF;
STICKLINE(GXL<1 AND GXL1<REF(GXL1,1),GXL1,REF(GXL1,1),5,1),COLORGREEN;
GXL2:=MA(C,21);
GXL3:=ATAN((GXL2-REF(GXL2,1)))*180/2;
STICKLINE(GXL3>1,GXL2,REF(GXL2,1),5,0),COLORFF00FF;
STICKLINE(GXL3<1,GXL2,REF(GXL2,1),5,1),COLORFF0000;

通达信珍藏操盘主图指标公式

 

相关文章