在线检测未来函数

通达信机械量化MACD趋势指标公式

来源:Internet,编辑:股旁网,2018-03-07

DIFF:=( EMA(CLOSE,12) - EMA(CLOSE,26));
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA),STICK;
STICKLINE(DIFF<0,0,DIFF,2,0),COLORGREEN;
STICKLINE(DIFF>=0,0,DIFF,2,0),COLORRED;
STICKLINE(DEA>=0,0,DEA,2,-1),COLOR0000CC;
STICKLINE(DEA<0,0,DEA,2,-1),COLORGREEN;
柱1:=IF(DIFF>DEA,DIFF,0),COLORRED;
柱2:=IF(DEA<DIFF,DEA,0),COLORMAGENTA;
DRAWICON(CROSS(DIFF,DEA),柱2,1);
DRAWICON(CROSS(DEA,DIFF),DEA*1.1,2);
总涨跌比:DYNAINFO(60)/(DYNAINFO(60)+DYNAINFO(61))*100,COLORCYAN,NODRAW;
净资产:=FINANCE(34);
年ROE:FINANCE(33)/FINANCE(34)COLORCYAN,NODRAW;
PE:=DYNAINFO(39),COLORRED,NODRAW;
PB:CONST(DYNAINFO(7) / FINANCE(34))COLOREE3AB2,NODRAW;
投资回报率:年ROE/PB*100,COLOR0099FF,NODRAW;{每股收益年/C AND 1/PE;};
M:=9; SHORT:=12;LONG:=26;
JCSC:=(M-1)/(M+1)*DEA/(1-2/(M+1));{计算出金叉死叉时的DIFF值}
DD:=(MACD/2+(DEA*(M-1)/(M+1)))/(1-2/(M+1));{计算出明日MACD=MACD时的DIFF值}
DIF拐头价:=(DIFF*(SHORT+1)*(LONG+1)-(LONG+1)*(SHORT-1)*EMA(C,SHORT)+(SHORT+1)*(LONG-1)*EMA(C,LONG))/(2*((LONG+1)-(SHORT+1)))COLORCYAN,LINETHICK3;
柱变向价:=(DD*(SHORT+1)*(LONG+1)-(LONG+1)*(SHORT-1)*EMA(C,SHORT)+(SHORT+1)*(LONG-1)*EMA(C,LONG))/(2*((LONG+1)-(SHORT+1))),COLORGREEN;
DRAWTEXT_FIX(1,0.9,0.94,0,STRCAT('拐点价格: ',CON2STR(DIF拐头价,2))),COLORYELLOW;
DRAWNUMBER(DIFF>DEA,3,BARSLAST(CROSS(DIFF,DEA))+1),COLORRED,NODRAW;
DRAWNUMBER(DIFF<DEA,-1,BARSLAST(CROSS(DEA,DIFF))+1),COLORGREEN,NODRAW;
DRAWTEXT_FIX(1,0.0,0.95,0,STRCAT('停止操作: ',CON2STR(CLOSE<MA(CLOSE,60),2))),COLORCYAN;
VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);
OBV1:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);
OBV2:=EMA(OBV1,3)-MA(OBV1,9);
OBV3:=EMA(IF(OBV2>0,OBV2,0),3);
MAC3:=MA(C,3);
STICKLINE(OBV3>REF(OBV3,1) AND MAC3>REF(MAC3,1),0,DEA/4,2,0),COLORYELLOW;
{MDIF:=2*(DIFF-DEA);
MDEA:=SMA(MDIF,5,2);
买卖力道:=2*(MDIF-MDEA),COLORCC0033,LINETHICK1;
DRAWBAND(MDIF,RGB(244,0,0),MDEA,RGB(0,0,244));};

通达信机械量化MACD趋势指标公式

 

相关文章