在线检测未来函数

通达信MACD应用主图指标公式

来源:Internet,编辑:股旁网,2018-03-13

顶部:=0;
超短线:=0;
看红柱高低:=0;
红色主升:=1;
基本数据:=0;
DRAWTEXT_FIX(1,0.00,0.10,0,'调整参数看顶部');
超大1:=EMA(CLOSE,300)-EMA(CLOSE,650);
红色1:=EMA(超大1,225);
白大于红:BARSLAST(超大1<REF(红色1,1)),COLORWHITE,NODRAW;
{---------主升区:主要选股指标,有1个就可以了-----};
中2:=EMA(CLOSE,50)-EMA(CLOSE,130),COLORBROWN;
DYO:=IF(中2>0,0.3,DRAWNULL);{显示}
主升:BARSLAST(DYO=DRAWNULL),COLORLIRED,NODRAW;
红周期:BARSLAST(红色1<REF(红色1,1)),COLORRED,NODRAW;
{-----以上为了排序指标在前面显示---------以下显示指标线-----------------------};
超大线:EMA(CLOSE,300)-EMA(CLOSE,650),COLORWHITE,LINETHICK2;
红色线:EMA(超大线,225),COLORRED,LINETHICK2;
S1:=EMA(CLOSE,150)-EMA(CLOSE,320);
蓝色:EMA(S1,90),COLORBLUE,LINETHICK1;
中级:EMA(CLOSE,50)-EMA(CLOSE,130),COLORBROWN;
绿色:EMA(中级,45),COLORGREEN;
{=====================================================================}
VARA1:=IF(红色线<0,超大线<红色线,DRAWNULL);
距离:IF(BARSLAST(VARA1)>0,0-红色线,0),COLORYELLOW,LINETHICK1;{仅供欣赏}
VART2:=(EMA(CLOSE,6)-EMA(CLOSE,13));
超短:IF(VART2<-0.8,-0.8,VART2)*超短线,COLORLICYAN;
{日线 MACD指标 快线}
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:看红柱高低*IF((DIF-DEA)*2>0,(DIF-DEA)*2,0),COLORSTICK;
MACD快线:IF(DIF<-1,-1,DIF)*看顶部,COLOR855C82;
最小值:=MIN(超大线,MIN(红色线,MIN(蓝色,MIN(中级,绿色))));
{中线区:IF((VAR1>0)/水平线,REF(最小值,VAR1),DRAWNULL),COLORLIRED,LINETHICK2;}
主升区:IF(主升/红色主升,REF(红色线,主升),DRAWNULL),COLORLIRED,LINETHICK4;
{OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO};
{以下数据通达信已经验证}
{上市日期:REF(DATE,BARSSINCE(C)),NODRAW;{指标栏显示}
{交易天数:BARSSINCE(C)+1,NODRAW; {指标栏显示, 跟随鼠标变动}
{定点窗口位置显示 [上市日期],[自然日]天数,[交易日]天数 }
A1Q:=FINANCE(42);
A2Q:=DATETODAY(CONST(DATE));
A3Q:=A2Q-A1Q;
A4Q:=DAYTODATE(A3Q)+19000000,NODRAW;{求上市日期}
上市的日期:=STRCAT(CON2STR(HHV((BARSCOUNT(C)=0)*(DATE+19000000),0),0),STRCAT(' 上市日期: ',CON2STR(A4Q,0)));
上市天数:=STRCAT(STRCAT(' 自然日: ',CON2STR(FINANCE(42),0)),'天');
交易日:=STRCAT(STRCAT(' [交易天数]: ',CON2STR(BARSSINCE(C),0)),'天 收缩K线准');
显示:=STRCAT(STRCAT(上市的日期,上市天数),交易日);
DRAWTEXT_FIX(基本数据*C>0,0.00,0.00,0,显示),COLORLIGRAY;
{上市日期前后数据有时有一些误差, 自然日数据准确,交易日天数大周期收缩K线准确}
{----------------------------------------------------------------------------}
{通达信指标中显示年月日指标公式 显示交易日最后一根K线的年月日星期数据}
N8:=STRCAT(CON2STR(YEAR,0),' 年 ');
Y8:=STRCAT(CON2STR(MONTH,0),' 月 ');
R8:=STRCAT(CON2STR(DAY,0),' 日 ');
R9:=STRCAT(CON2STR(WEEKDAY,0),' ');
RA:=STRCAT(STRCAT('【',IF(WEEKDAY=1,'一',IF(WEEKDAY=2,'二',IF(WEEKDAY=3,'三',IF(WEEKDAY=4,'四',IF(WEEKDAY=5,'五',IF(WEEKDAY=6,'六','日'))))))),'】');
SJ9:=STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(N8,Y8),R8),' 星期 '),R9),RA);
DRAWTEXT_FIX(基本数据*C>0,0.425,0.00,0,SJ9),COLORGREEN;

通达信MACD应用主图指标公式

 

相关文章