在线检测未来函数

通达信底部分析指标公式

来源:Internet,编辑:股旁网,2018-03-13

VARA:=LLV(LOW,36);
VARB:=HHV(HIGH,30);
VARC:=EMA((CLOSE-VARA)/(VARB-VARA)*4,4)*25;
趋势:=VARC,COLORMAGENTA;
底背:STICKLINE(VARC<10,27,37,8,0),COLOR00FFCC;
{---------底部信号-----------------------------};
VAR8:=600*(EMA(CLOSE,3)-EMA(LOW,30))/EMA(LOW,30);
VAR9:=EMA(VAR8,7);
底部N:IF(VAR9<-18,6,0),COLORFF3300,NODRAW;
STICKLINE(底部N>0,0,25,6,0),COLORFF3300;{底部蓝色块}
{冠军排序}
DEA66:=EMA((EMA(EMA(CLOSE,4)-EMA(CLOSE,12), 6)-EMA(EMA(CLOSE,4)-EMA(CLOSE,12), 12)),9);
DEA12:=EMA((EMA(EMA(CLOSE,4)-EMA(CLOSE,12), 12)-EMA(EMA(CLOSE,4)-EMA(CLOSE,12), 24)),9);
DEA18:=EMA((EMA(EMA(CLOSE,4)-EMA(CLOSE,12), 18)-EMA(EMA(CLOSE,4)-EMA(CLOSE,12), 36)),9);
DEA51:=EMA((EMA(EMA(CLOSE,4)-EMA(CLOSE,12), 51)-EMA(EMA(CLOSE,4)-EMA(CLOSE,12),102)),9);
DEA102:=EMA((EMA(EMA(CLOSE,4)-EMA(CLOSE,12),102)-EMA(EMA(CLOSE,4)-EMA(CLOSE,12),204)),9);
多头1:=DEA102>0 AND DEA51>0;
多头2:=DEA102>0 AND DEA66>DEA12 AND DEA12>DEA18;
多头3:=DEA18>DEA51 AND DEA18>DEA102 AND DEA18>0;
多头:=多头1=1 OR 多头2=1 OR 多头3=1;
空头1:=DEA18>DEA51 OR DEA18>DEA102;
空头2:=DEA51>DEA102;
空头:=空头1=1 OR 空头2=1;
抄底1:=DEA66>DEA12 AND DEA12>DEA18;
抄底2:=抄底1=1 OR 多头=1 OR 空头=1;
抄底:IF(抄底2,0,12),COLORYELLOW,LINETHICK2;
{红色趋势线上覆盖淡蓝色线}
{庄家三步 副图(吸筹、拉升出货)~~简单明了 };
STICKLINE(C>0,0,0.001,8,0),COLORRED;
庄家:=EMA(EMA(CLOSE,10),10);
现价:=(庄家-REF(庄家,1))/REF(庄家,1)*1000;
平均价:=SMA(现价,5,1)-SMA(现价,13,1);
升势:=平均价-SMA(平均价, 3,1),LINETHICK3,COLORCYAN;{2#红色线}
0,LINETHICK3,COLORRED;
跌势:IF(升势<REF(升势,1),0,DRAWNULL)LINETHICK3,COLORLIBLUE;{淡蓝色线覆盖在红色趋势线上面};
{--------------青色信号线------------------};
入底线:IF(EMA((CLOSE-MA(CLOSE,20))/MA(CLOSE,20),7)<-0.04,30,37),COLORCYAN,COLORLICYAN,LINETHICK2;

通达信底部分析指标公式

 

相关文章