在线检测未来函数

通达信买卖背离指标公式

来源:Internet,编辑:股旁网,2018-03-14

LOWV:=LLV(LOW,9);
HIGHV:=HHV(HIGH,9);
RSV:=EMA((CLOSE-LOWV)/(HIGHV-LOWV)*100,3);
K:EMA(RSV,3);
D:MA(K,3);
STICKLINE(K>D,K,D,2.5,0),COLORRED,LINETHICK2;
STICKLINE(D>K,K,D,2.5,0),COLORGREEN,LINETHICK2;
逃顶线:90,COLORGREEN;
中轴线:50,COLORRED;
抄底线:10,COLORYELLOW;
DRAWICON(CROSS(K,D) AND K<=50,12,11),COLORRED;
DRAWICON(CROSS(D,K)AND K>=80,88,4),COLORGREEN;
A1:=BARSLAST(REF(CROSS(K,D),1));
背离:REF(CLOSE,A1+1)>CLOSE AND K>REF(K,A1+1) AND CROSS(K,D);
DRAWLINE(A1=0,D,底背离,D,0),COLORRED,LINETHICK1;
A2:=BARSLAST(REF(CROSS(D,K),1));
顶背离:REF(CLOSE,A2+1)<CLOSE AND REF(D,A2+1)>D AND CROSS(D,K);
DRAWLINE(A2=0,D,顶背离,D,0),COLORGREEN,LINETHICK1;
DRAWTEXT(底背离>0,D-5,'加仓'),COLORRED;
DRAWTEXT(顶背离>0,D-5,'减仓'),COLORGREEN;
DRAWTEXT(CROSS(K,D) AND (D<8),30,'买'),COLORRED;
STICKLINE(CROSS(K,D) AND (D<8)=1,3,20,8,0),COLORRED;
DRAWTEXT(CROSS(D,K) AND (D>85),70,'卖'),COLORGREEN;
STICKLINE(CROSS(D,K) AND (D>85)=1,85,70,8,0),COLORGREEN

通达信买卖背离指标公式

 

相关文章